aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fossil
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-19 13:54:08 +0800
committerbapt <bapt@FreeBSD.org>2013-06-19 13:54:08 +0800
commitb75930155b5776ed0502ec786cc63b96a21e85cd (patch)
tree996023afc0b7dfa9b0ad97a08b7a3815f4fa49e8 /devel/fossil
parent1d937d4c85d15220441082e5e656c54b8be1ee64 (diff)
downloadfreebsd-ports-gnome-b75930155b5776ed0502ec786cc63b96a21e85cd.tar.gz
freebsd-ports-gnome-b75930155b5776ed0502ec786cc63b96a21e85cd.tar.zst
freebsd-ports-gnome-b75930155b5776ed0502ec786cc63b96a21e85cd.zip
Update to 20130618210923 aka 1.26
Changes: - The argument to the --port option for the fossil ui and fossil server commands can take an IP address in addition to the port number - After prompting for a password, also ask if that password should be remembered - Performance improvements to the diff engine - Fix the side-by-side diff engine to work better with multi-byte unicode text - The markdown formatter is now available by default and can be used for tickets, wiki, and embedded documentation - Add subcommands "fossil bisect log" and "fossil bisect status" to the fossil bisect command - Enhanced defenses that prevent spiders from using excessive CPU and bandwidth - Consistent use of the -n or --dry-run command line options. - Enhancements to /timeline.rss, adding more flags for filtering results - Added /stats_report page - ssh:// and file:// protocols now ignore proxy settings - Cherry-pick merges are recorded internally (though no yet displayed on the timeline graph.)
Diffstat (limited to 'devel/fossil')
-rw-r--r--devel/fossil/Makefile7
-rw-r--r--devel/fossil/distinfo4
-rw-r--r--devel/fossil/files/patch-annotate57
-rw-r--r--devel/fossil/files/patch-fix-srub-private35
4 files changed, 4 insertions, 99 deletions
diff --git a/devel/fossil/Makefile b/devel/fossil/Makefile
index df43fb23fb31..ffca555466e6 100644
--- a/devel/fossil/Makefile
+++ b/devel/fossil/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= fossil
-PORTVERSION= 20130216000435
-PORTREVISION= 2
+PORTVERSION= 20130618210923
PORTEPOCH= 1
CATEGORIES= devel www
MASTER_SITES= http://www.fossil-scm.org/download/
@@ -19,12 +18,10 @@ PLIST_FILES= bin/fossil
HAS_CONFIGURE= yes
-OPTIONS_DEFINE= JSON MARKDOWN STATIC
+OPTIONS_DEFINE= JSON STATIC
JSON_DESC= JSON API support
-MARKDOWN_DESC= Markdown format support
JSON_CONFIGURE_ON= --json
-MARKDOWN_CONFIGURE_ON= --markdown
STATIC_CONFIGURE_ON= --static
do-install:
diff --git a/devel/fossil/distinfo b/devel/fossil/distinfo
index e314c69cd57b..c77826d82c5f 100644
--- a/devel/fossil/distinfo
+++ b/devel/fossil/distinfo
@@ -1,2 +1,2 @@
-SHA256 (fossil-src-20130216000435.tar.gz) = 6fc0068a9174fc24ec9323cf7fddd771320248d9befc4a417746839a442c8de1
-SIZE (fossil-src-20130216000435.tar.gz) = 3541732
+SHA256 (fossil-src-20130618210923.tar.gz) = 8dcb58c0ee80385827e4c3b5f84a05264a350a61680d93f4f9497e7b67210b98
+SIZE (fossil-src-20130618210923.tar.gz) = 3641306
diff --git a/devel/fossil/files/patch-annotate b/devel/fossil/files/patch-annotate
deleted file mode 100644
index bf99b7d4b84e..000000000000
--- a/devel/fossil/files/patch-annotate
+++ /dev/null
@@ -1,57 +0,0 @@
---- src/diff.c.orig 2013-02-16 01:13:55.000000000 +0100
-+++ src/diff.c 2013-03-18 11:16:10.684776601 +0100
-@@ -2202,6 +2202,7 @@
- int rid; /* Artifact ID of the file being annotated */
- char *zLabel; /* Label to apply to a line */
- Stmt q; /* Query returning all ancestor versions */
-+ Stmt ins; /* Inserts into the temporary VSEEN table */
- int cnt = 0; /* Number of versions examined */
-
- /* Initialize the annotation */
-@@ -2214,7 +2215,13 @@
- }
- if( iLimit<=0 ) iLimit = 1000000000;
- annotation_start(p, &toAnnotate);
--
-+ db_begin_transaction();
-+ db_multi_exec(
-+ "CREATE TABLE IF NOT EXISTS vseen(rid INTEGER PRIMARY KEY);"
-+ "DELETE FROM vseen;"
-+ );
-+
-+ db_prepare(&ins, "INSERT OR IGNORE INTO vseen(rid) VALUES(:rid)");
- db_prepare(&q,
- "SELECT (SELECT uuid FROM blob WHERE rid=mlink.%s),"
- " date(event.mtime),"
-@@ -2223,10 +2230,11 @@
- " FROM mlink, event"
- " WHERE mlink.fid=:rid"
- " AND event.objid=mlink.mid"
-+ " AND mlink.pid NOT IN vseen"
- " ORDER BY event.mtime",
- (annFlags & ANN_FILE_VERS)!=0 ? "fid" : "mid"
- );
--
-+
- db_bind_int(&q, ":rid", rid);
- if( iLimit==0 ) iLimit = 1000000000;
- while( rid && iLimit>cnt && db_step(&q)==SQLITE_ROW ){
-@@ -2247,6 +2255,9 @@
- p->azVers[p->nVers-1] = zLabel;
- content_get(rid, &step);
- annotation_step(p, &step, zLabel);
-+ db_bind_int(&ins, ":rid", rid);
-+ db_step(&ins);
-+ db_reset(&ins);
- blob_reset(&step);
- db_reset(&q);
- rid = prevId;
-@@ -2254,6 +2265,8 @@
- cnt++;
- }
- db_finalize(&q);
-+ db_finalize(&ins);
-+ db_end_transaction(0);
- }
-
- /*
diff --git a/devel/fossil/files/patch-fix-srub-private b/devel/fossil/files/patch-fix-srub-private
deleted file mode 100644
index 6ad4cf9e5698..000000000000
--- a/devel/fossil/files/patch-fix-srub-private
+++ /dev/null
@@ -1,35 +0,0 @@
-Index: src/db.c
-==================================================================
---- src/db.c
-+++ src/db.c
-@@ -882,10 +882,11 @@
- lsize = file_size(zDbName);
- if( lsize%1024!=0 || lsize<4096 ) return 0;
- db_open_or_attach(zDbName, "localdb", 0);
- zVFileDef = db_text(0, "SELECT sql FROM %s.sqlite_master"
- " WHERE name=='vfile'", db_name("localdb"));
-+ if( zVFileDef==0 ) return 0;
-
- /* If the "isexe" column is missing from the vfile table, then
- ** add it now. This code added on 2010-03-06. After all users have
- ** upgraded, this code can be safely deleted.
- */
-
-Index: src/rebuild.c
-==================================================================
---- src/rebuild.c
-+++ src/rebuild.c
-@@ -785,10 +785,12 @@
- int bVerily = find_option("verily",0,0)!=0;
- int bForce = find_option("force", "f", 0)!=0;
- int privateOnly = find_option("private",0,0)!=0;
- int bNeedRebuild = 0;
- db_find_and_open_repository(OPEN_ANY_SCHEMA, 2);
-+ db_close(1);
-+ db_open_repository(g.zRepositoryName);
- if( !bForce ){
- Blob ans;
- char cReply;
- blob_zero(&ans);
- prompt_user(
-