aboutsummaryrefslogtreecommitdiffstats
path: root/devel/fossil
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-14 15:43:23 +0800
committerbapt <bapt@FreeBSD.org>2013-03-14 15:43:23 +0800
commiteb2b3e0715ca56036812b1d44b000dffbd44e1a8 (patch)
treec8873df2fd3c375c050c009fdde5dc7b80233ee5 /devel/fossil
parent46e9e55279cbf59b088091e8f74aa69c9393999e (diff)
downloadfreebsd-ports-gnome-eb2b3e0715ca56036812b1d44b000dffbd44e1a8.tar.gz
freebsd-ports-gnome-eb2b3e0715ca56036812b1d44b000dffbd44e1a8.tar.zst
freebsd-ports-gnome-eb2b3e0715ca56036812b1d44b000dffbd44e1a8.zip
Add a patch to fix fossil scrub --private
Obtained from: fossil's upstream (http://www.fossil-scm.org/fossil/info/60acc2de34)
Diffstat (limited to 'devel/fossil')
-rw-r--r--devel/fossil/Makefile1
-rw-r--r--devel/fossil/files/patch-fix-srub-private35
2 files changed, 36 insertions, 0 deletions
diff --git a/devel/fossil/Makefile b/devel/fossil/Makefile
index ae49faedc30f..21bfa384fb39 100644
--- a/devel/fossil/Makefile
+++ b/devel/fossil/Makefile
@@ -2,6 +2,7 @@
PORTNAME= fossil
PORTVERSION= 20130216000435
+POREREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel www
MASTER_SITES= http://www.fossil-scm.org/download/
diff --git a/devel/fossil/files/patch-fix-srub-private b/devel/fossil/files/patch-fix-srub-private
new file mode 100644
index 000000000000..6ad4cf9e5698
--- /dev/null
+++ b/devel/fossil/files/patch-fix-srub-private
@@ -0,0 +1,35 @@
+Index: src/db.c
+==================================================================
+--- src/db.c
++++ src/db.c
+@@ -882,10 +882,11 @@
+ lsize = file_size(zDbName);
+ if( lsize%1024!=0 || lsize<4096 ) return 0;
+ db_open_or_attach(zDbName, "localdb", 0);
+ zVFileDef = db_text(0, "SELECT sql FROM %s.sqlite_master"
+ " WHERE name=='vfile'", db_name("localdb"));
++ if( zVFileDef==0 ) return 0;
+
+ /* If the "isexe" column is missing from the vfile table, then
+ ** add it now. This code added on 2010-03-06. After all users have
+ ** upgraded, this code can be safely deleted.
+ */
+
+Index: src/rebuild.c
+==================================================================
+--- src/rebuild.c
++++ src/rebuild.c
+@@ -785,10 +785,12 @@
+ int bVerily = find_option("verily",0,0)!=0;
+ int bForce = find_option("force", "f", 0)!=0;
+ int privateOnly = find_option("private",0,0)!=0;
+ int bNeedRebuild = 0;
+ db_find_and_open_repository(OPEN_ANY_SCHEMA, 2);
++ db_close(1);
++ db_open_repository(g.zRepositoryName);
+ if( !bForce ){
+ Blob ans;
+ char cReply;
+ blob_zero(&ans);
+ prompt_user(
+