aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gamin
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2012-02-13 01:03:59 +0800
committermarcus <marcus@FreeBSD.org>2012-02-13 01:03:59 +0800
commit4dafd7f3b8172310ffa8c132fce10da5a365611c (patch)
tree8bc53a1b13817f7a43b9d6eb566e7c3b97b0e629 /devel/gamin
parenta0a58bcfd797ad9460ec3ac2645bac7c6069513a (diff)
downloadfreebsd-ports-gnome-4dafd7f3b8172310ffa8c132fce10da5a365611c.tar.gz
freebsd-ports-gnome-4dafd7f3b8172310ffa8c132fce10da5a365611c.tar.zst
freebsd-ports-gnome-4dafd7f3b8172310ffa8c132fce10da5a365611c.zip
Add optional libinotify support (default disabled) and fix the build
if devel/libinotify is installed. PR: 164756 Submitted by: sunpoet
Diffstat (limited to 'devel/gamin')
-rw-r--r--devel/gamin/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/devel/gamin/Makefile b/devel/gamin/Makefile
index 960721705e42..d56f4af553e0 100644
--- a/devel/gamin/Makefile
+++ b/devel/gamin/Makefile
@@ -30,7 +30,8 @@ CONFLICTS= fam-[0-9]*
GNU_CONFIGURE= yes
.if !defined(GAMIN_SLAVE)
-OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off
+OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off \
+ LIBINOTIFY "Use libinotify as the FAM backend" off
.endif
.include <bsd.port.pre.mk>
@@ -39,6 +40,14 @@ OPTIONS= GAM_POLLER "Use gamin's poller instead of kqueue's" off
.if defined(WITH_GAM_POLLER)
CPPFLAGS+= -DUSE_GAMIN_POLLER=1
.endif
+
+.if defined(WITH_LIBINOTIFY)
+CONFIGURE_ARGS+=--enable-inotify
+LDFLAGS+= -L${LOCALBASE}/lib -linotify
+LIB_DEPENDS+= inotify.0:${PORTSDIR}/devel/libinotify
+.else
+CONFIGURE_ARGS+=--disable-inotify
+.endif
.endif
post-patch: