aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb6/Makefile
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2007-06-29 06:04:31 +0800
committermi <mi@FreeBSD.org>2007-06-29 06:04:31 +0800
commit6cafed7521a61e0aea12f1dd8ce20e17a778698f (patch)
tree93f6629799a04fe5b9b9f6d811b9ba89eb9d5023 /devel/gdb6/Makefile
parent9b9d86cb90f8571870a7d2a4b7e61fdadcb326cb (diff)
downloadfreebsd-ports-gnome-6cafed7521a61e0aea12f1dd8ce20e17a778698f.tar.gz
freebsd-ports-gnome-6cafed7521a61e0aea12f1dd8ce20e17a778698f.tar.zst
freebsd-ports-gnome-6cafed7521a61e0aea12f1dd8ce20e17a778698f.zip
Fix the PREFIX vs. LOCALBASE nits, and install man-pages with
INSTALL_MAN into MANPREFIX as suggested by sat earlier. Add more fixes to the itcl-3.3 compatibility patch, and upgrade the status of Insight-GUI from "broken" to "experimental". It, actually, seems to work now...
Diffstat (limited to 'devel/gdb6/Makefile')
-rw-r--r--devel/gdb6/Makefile13
1 files changed, 6 insertions, 7 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index 53d8dae59982..5f94d678925f 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -17,7 +17,7 @@ DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}:gdb
MAINTAINER= mi@aldan.algebra.com
COMMENT= GNU GDB of newer version than comes with the system
-OPTIONS= INSIGHT "Build the Tcl/Tk GUI (broken!)" off
+OPTIONS= INSIGHT "Build the Tcl/Tk GUI (experimental!)" off
USE_BZIP2= yes
USE_GMAKE= yes
@@ -27,7 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV+= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
--enable-target=all \
- --enable-tui --with-libiconv-prefix=${PREFIX}
+ --enable-tui --with-libiconv-prefix=${LOCALBASE}
CFLAGS:= ${CFLAGS:C/ +$//} # blanks at EOL creep in sometimes
CFLAGS+= -DRL_NO_COMPAT
EXCLUDE= dejagnu expect readline sim texinfo intl
@@ -56,10 +56,9 @@ CONFIGURE_ARGS+=--enable-gdbtk \
pre-everything::
#
- # The Tk-based GUI (Insight) is severely broken at the moment.
- # Do not submit bug-reports, unless you have fixes for them --
- # insight code needs to be ported to use the most recent ITk and
- # IWidgets.
+ # The Tk-based GUI (Insight) is patched to work with [incr tcl]
+ # version 3.3 and is currently experimental. Bug reports should
+ # be accompanied by patches.
#
pre-configure:
@@ -84,7 +83,7 @@ post-patch:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gdb/gdb ${PREFIX}/bin/gdb${VER}
${LN} ${PREFIX}/bin/gdb${VER} ${PREFIX}/bin/gdbtui${VER}
- ${INSTALL_DATA} ${WRKSRC}/gdb/gdb.1 ${PREFIX}/man/man1/gdb${VER}.1
+ ${INSTALL_MAN} ${WRKSRC}/gdb/gdb.1 ${MAN1PREFIX}/man/man1/gdb${VER}.1
.if defined(WITH_INSIGHT)
${LN} ${PREFIX}/bin/gdb${VER} ${PREFIX}/bin/insight
${MKDIR} ${PREFIX}/share/redhat/gui