aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-11-18 11:35:30 +0800
committerdanilo <danilo@FreeBSD.org>2013-11-18 11:35:30 +0800
commit738c155324d9035348cc8b6b8ae02fa1b8ba8377 (patch)
tree2e643403ae1d5c219a16eb890db7b5c40471c0ee /devel/gdb
parente16be6ff41a501397a457f23fbcbde134f08196d (diff)
downloadfreebsd-ports-gnome-738c155324d9035348cc8b6b8ae02fa1b8ba8377.tar.gz
freebsd-ports-gnome-738c155324d9035348cc8b6b8ae02fa1b8ba8377.tar.zst
freebsd-ports-gnome-738c155324d9035348cc8b6b8ae02fa1b8ba8377.zip
- Fix the search path of python files
PR: ports/184008 Reported by: Jean-Paul Calderone <jean-paul@hybridcluster.com> Reviewed by: Luca Pizzamiglio <luca.pizzamiglio@gmail.com> (maintainer)
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 6f1f9d431b16..43ec93c7c396 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -18,7 +18,7 @@ USES= iconv gmake
GNU_CONFIGURE= yes
CONFIGURE_ENV= CONFIGURED_M4=m4 CONFIGURED_BISON=byacc
CONFIGURE_ARGS= --program-suffix=${PORTVERSION:S/.//g} \
- --with-gdb-datadir=${STAGEDIR}${PREFIX}/share/gdb${PORTVERSION:S/.//g} \
+ --with-gdb-datadir=${PREFIX}/share/gdb${PORTVERSION:S/.//g} \
${ICONV_CONFIGURE_ARG} \
--without-libunwind-ia64 \
--enable-targets=all
@@ -91,8 +91,8 @@ do-install:
${LN} -sf gdb${VER} ${STAGEDIR}${PREFIX}/bin/gdb
.endif
.if ${PORT_OPTIONS:MPYTHON}
- (cd ${WRKSRC}/gdb; ${GMAKE} install-python )
- (cd ${WRKSRC}/gdb/data-directory; ${GMAKE} install-python )
+ (cd ${WRKSRC}/gdb; ${GMAKE} DESTDIR=${STAGEDIR} install-python )
+ (cd ${WRKSRC}/gdb/data-directory; ${GMAKE} DESTDIR=${STAGEDIR} install-python )
.endif
post-install: