aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gdb
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2012-09-09 21:56:00 +0800
committerbdrewery <bdrewery@FreeBSD.org>2012-09-09 21:56:00 +0800
commitdf28ae9ed769f0c2073bb8d58cdb070874ec1709 (patch)
tree8fe0c1aeedbda5ecc446c646931cdc0213fe5930 /devel/gdb
parent9879b153c716a73e6b9c537baadb9beee8fcdaec (diff)
downloadfreebsd-ports-gnome-df28ae9ed769f0c2073bb8d58cdb070874ec1709.tar.gz
freebsd-ports-gnome-df28ae9ed769f0c2073bb8d58cdb070874ec1709.tar.zst
freebsd-ports-gnome-df28ae9ed769f0c2073bb8d58cdb070874ec1709.zip
- Switch readline lib dependency to USE_READLINE
to ensure the port version is always used. This also makes portlint happy and still does the right thing. PR: ports/171325 Submitted by: bdrewery Approved by: Luca Pizzamiglio <luca.pizzamiglio@gmail.com> (maintainer) Approved by: eadler (mentor)
Diffstat (limited to 'devel/gdb')
-rw-r--r--devel/gdb/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index 561653efbfe1..c2f6398104ef 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -40,10 +40,8 @@ MAN1= gdb${VER}.1
ONLY_FOR_ARCHS= i386 amd64 # untested elsewhere, might work
# Forcing to use readline.6 from ports (newer readline in FreeBSD world is not
-# compatible anymore). Please ignore portlint here.
-LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
-CFLAGS+= -isystem ${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+# compatible anymore).
+USE_READLINE= port
OPTIONS_DEFINE= DEBUG EXPAT PYTHON THREADS GDB_LINK
GDB_LINK_DESC= Create the gdb link