aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gearmand-devel
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2018-10-30 19:52:54 +0800
committerlinimon <linimon@FreeBSD.org>2018-10-30 19:52:54 +0800
commit3fb22c61ce67f42e8b56b5e9109628ddc24b5c65 (patch)
tree97edc9922f445b23d9118d3e2cd03057cf792910 /devel/gearmand-devel
parent3b628f1a18636d51e8e605a368fdf28b75addf42 (diff)
downloadfreebsd-ports-gnome-3fb22c61ce67f42e8b56b5e9109628ddc24b5c65.tar.gz
freebsd-ports-gnome-3fb22c61ce67f42e8b56b5e9109628ddc24b5c65.tar.zst
freebsd-ports-gnome-3fb22c61ce67f42e8b56b5e9109628ddc24b5c65.zip
Fix build on powerpc64 the same way as non-devel port. Probably
fixes sparc64 as well. PR: 232096 Submitted by: Piotr Kubaj
Diffstat (limited to 'devel/gearmand-devel')
-rw-r--r--devel/gearmand-devel/Makefile5
-rw-r--r--devel/gearmand-devel/files/patch-configure24
2 files changed, 19 insertions, 10 deletions
diff --git a/devel/gearmand-devel/Makefile b/devel/gearmand-devel/Makefile
index c84cd1c28b17..8ec3bbe6b3f0 100644
--- a/devel/gearmand-devel/Makefile
+++ b/devel/gearmand-devel/Makefile
@@ -11,9 +11,6 @@ PKGNAMESUFFIX= -devel
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= Gearman C Server and Library
-BROKEN_sparc64= fails to build: cannot link with boost
-BROKEN_powerpc64= fails to build: checking for the Boost program_options library... no
-
BUILD_DEPENDS= boost-libs>=0:devel/boost-libs \
${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
LIB_DEPENDS= libevent.so:devel/libevent \
@@ -24,7 +21,7 @@ CONFLICTS= p5-Gearman-Server-1.* gearmand-1.0.*
USERS= gearmand
GROUPS= gearmand
-USES= pathfix perl5 gmake gperf libtool python:build
+USES= compiler:c++11-lang pathfix perl5 gmake gperf libtool python:build
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/gearmand-devel/files/patch-configure b/devel/gearmand-devel/files/patch-configure
index 49219c48fe3f..9651acdd405f 100644
--- a/devel/gearmand-devel/files/patch-configure
+++ b/devel/gearmand-devel/files/patch-configure
@@ -1,6 +1,18 @@
---- ./configure.orig 2013-06-06 19:06:29.000000000 -0400
-+++ ./configure 2013-07-17 14:33:54.000000000 -0400
-@@ -17976,7 +17976,7 @@
+--- configure.orig 2013-06-06 23:06:29 UTC
++++ configure
+@@ -16844,11 +16844,6 @@ fi
+ $as_echo "$boost_cv_lib_version" >&6; }
+ # e.g. "134" for 1_34_1 or "135" for 1_35
+ boost_major_version=`echo "$boost_cv_lib_version" | sed 's/_//;s/_.*//'`
+- case $boost_major_version in #(
+- '' | *[!0-9]*)
+- as_fn_error $? "invalid value: boost_major_version=$boost_major_version" "$LINENO" 5
+- ;;
+- esac
+ fi
+ CPPFLAGS=$boost_save_CPPFLAGS
+
+@@ -17976,7 +17971,7 @@ fi
done
test -n "$CURL_CONFIG" || CURL_CONFIG="no"
@@ -9,7 +21,7 @@
:
-@@ -17986,7 +17986,7 @@
+@@ -17986,7 +17981,7 @@ $as_echo "#define HAVE_LIBCURL 0" >>confdefs.h
else
@@ -18,7 +30,7 @@
CURL_CFLAGS="`$CURL_CONFIG $curl_config_args --cflags`"
-@@ -17996,7 +17996,7 @@
+@@ -17996,7 +17991,7 @@ else
fi
@@ -27,7 +39,7 @@
CURL_LIBS="`$CURL_CONFIG $curl_config_args --libs`"
-@@ -23954,8 +23954,8 @@
+@@ -23954,8 +23949,8 @@ else
LIBS="$PTHREAD_LIBS"
ac_ext=c
ac_cpp='$CPP $CPPFLAGS'