aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git-absorb
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-04-17 15:33:34 +0800
committertobik <tobik@FreeBSD.org>2019-04-17 15:33:34 +0800
commita0ae3ecc502dcbce23438ff6d05df59909528154 (patch)
treee05f59866e6139badbc92c7524966ba640a8fed5 /devel/git-absorb
parentcb55b190e0ecf582a7e823ac459c89c83fb58b1e (diff)
downloadfreebsd-ports-gnome-a0ae3ecc502dcbce23438ff6d05df59909528154.tar.gz
freebsd-ports-gnome-a0ae3ecc502dcbce23438ff6d05df59909528154.tar.zst
freebsd-ports-gnome-a0ae3ecc502dcbce23438ff6d05df59909528154.zip
Mk/Uses/cargo.mk: Push lib dependencies back down into ports
Some crates are optional via Cargo features or are only used during tests, however the framework has no way to discriminate between test or run dependencies using just CARGO_CRATES leading to more run dependencies than necessary for some packages. With more ported Rust applications it's time to let individual ports make that decision now. The environmental setup to use dependencies from ports instead of bundled ones and implied build dependencies (cmake, gmake, pkgconf) are left in place for now. Assign cargo.mk to rust@ while here.
Diffstat (limited to 'devel/git-absorb')
-rw-r--r--devel/git-absorb/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/git-absorb/Makefile b/devel/git-absorb/Makefile
index 7c830dafc396..3286e240a559 100644
--- a/devel/git-absorb/Makefile
+++ b/devel/git-absorb/Makefile
@@ -11,6 +11,8 @@ COMMENT= Git command for automating fixup/autosquash commits
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.md
+LIB_DEPENDS= libgit2.so:devel/libgit2
+
USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= tummychow