aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-06-30 08:16:50 +0800
committerwxs <wxs@FreeBSD.org>2011-06-30 08:16:50 +0800
commit784a291ee56d820cd5ad01daf5f838fdcfe1f616 (patch)
treefb70d410929e0a868d657f25822f8fb83c81e319 /devel/git
parentc24e03f175147af1ea7e9a094cdfa767ef9d281b (diff)
downloadfreebsd-ports-gnome-784a291ee56d820cd5ad01daf5f838fdcfe1f616.tar.gz
freebsd-ports-gnome-784a291ee56d820cd5ad01daf5f838fdcfe1f616.tar.zst
freebsd-ports-gnome-784a291ee56d820cd5ad01daf5f838fdcfe1f616.zip
- Fix build with clang by being specific about pthread library.
Submitted by: sahil@
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 77d4b7715d44..e63eeb768b64 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -183,6 +183,8 @@ USE_OPENSSL= yes
USE_RC_SUBR= git_daemon
WANT_PERL= yes
+CONFIGURE_ARGS= --enable-pthreads=${PTHREAD_LIBS}
+
OPTIONS= GUI "Enable building of GUI tools" off \
SVN "Enable required dependencies for SVN tools" off \
SVN_FBSD "Use subversion-freebsd dependency (implies SVN)" off \