aboutsummaryrefslogtreecommitdiffstats
path: root/devel/git
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2007-05-28 07:43:32 +0800
committeralexbl <alexbl@FreeBSD.org>2007-05-28 07:43:32 +0800
commit8d331d01997795d91dfb26193b7b48e98392093f (patch)
tree63db59e533607c7964ce23b6f7f759eaf55307d9 /devel/git
parentc00c30a66ccd4db1fd852e3d5deba6cd328ebb38 (diff)
downloadfreebsd-ports-gnome-8d331d01997795d91dfb26193b7b48e98392093f.tar.gz
freebsd-ports-gnome-8d331d01997795d91dfb26193b7b48e98392093f.tar.zst
freebsd-ports-gnome-8d331d01997795d91dfb26193b7b48e98392093f.zip
- obey CFLAGS
- make WITHOUT_GUI work properly PR: 113030 Submitted by: Ed Schouten <ed@fxq.nl> Approved by: anholt (maintainer)
Diffstat (limited to 'devel/git')
-rw-r--r--devel/git/Makefile28
-rw-r--r--devel/git/files/patch-Makefile34
-rw-r--r--devel/git/files/patch-gitk10
-rw-r--r--devel/git/pkg-plist2
4 files changed, 49 insertions, 25 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 8ca182d9c5bf..0b7932dd97bf 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -7,6 +7,7 @@
PORTNAME= git
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.kernel.org/pub/software/scm/git/
@@ -24,7 +25,7 @@ LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
CONFLICTS= cogito-0.1[012] git-4.*
-MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+.if !defined(NOPORTDOCS)
MAN1= git-add.1 \
git-am.1 \
git-annotate.1 \
@@ -157,17 +158,23 @@ MAN1= git-add.1 \
git-whatchanged.1 \
git-write-tree.1 \
gitk.1
-MAN3= Git.3
MAN5= gitattributes.5
MAN7= git.7
+.endif
+MAN3PREFIX= ${TARGETDIR}/lib/perl5/${PERL_VERSION}
+MAN3= Git.3
USE_BZIP2= yes
USE_PERL5= yes
USE_PYTHON= yes
USE_ICONV= yes
USE_GMAKE= yes
-ALL_TARGET= all doc
-INSTALL_TARGET= install install-doc
+ALL_TARGET= all
+INSTALL_TARGET= install
+.if !defined(NOPORTDOCS)
+ALL_TARGET+= doc
+INSTALL_TARGET+=install-doc
+.endif
CFLAGS+= -I${LOCALBASE}/include
MAKE_ENV+= CURLDIR=${LOCALBASE} \
NEEDS_LIBICONV=yes \
@@ -179,22 +186,15 @@ MAKE_ARGS+= prefix="${PREFIX}"
.ifndef WITHOUT_GUI
PLIST_SUB+= GUI=""
-GITGUIVERSION= 0.6-GITGUI
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
+MAKE_ENV+= TCL_PATH=tclsh8.4 TCLTK_PATH=wish8.4
.else
PLIST_SUB+= GUI="@comment "
-MAKE_ENV+= NO_GUI=yes
-.endif
-
-# We should place version files to avoid git's attempt to figure it by itself
-post-patch:
- ${ECHO} "GIT_VERSION = ${PORTVERSION}-dirty" > ${WRKSRC}/GIT-VERSION-FILE; ${ECHO} '#!/bin/sh' > ${WRKSRC}/GIT-VERSION-GEN
-.ifndef WITHOUT_GUI
- ${ECHO} "GIT_VERSION = ${GITGUIVERSION}-dirty" > ${WRKSRC}/git-gui/GIT-VERSION-FILE; ${ECHO} '#!/bin/sh' > ${WRKSRC}/git-gui/GIT-VERSION-GEN
+MAKE_ENV+= NO_TCLTK=yes
.endif
post-install:
- ${TEST} -f ${PREFIX}/lib/perl5/${PERL_VERSION}/mach/perllocal.pod && ${RM} -f ${PREFIX}/lib/perl5/${PERL_VERSION}/mach/perllocal.pod
+ -${RM} -f ${PREFIX}/lib/perl5/${PERL_VERSION}/mach/perllocal.pod
${MKDIR} ${PREFIX}/share/emacs/site-lisp/git
${MKDIR} ${PREFIX}/lib/xemacs/site-lisp/git
${INSTALL_DATA} ${WRKSRC}/contrib/emacs/git.el \
diff --git a/devel/git/files/patch-Makefile b/devel/git/files/patch-Makefile
new file mode 100644
index 000000000000..548a6816cf35
--- /dev/null
+++ b/devel/git/files/patch-Makefile
@@ -0,0 +1,34 @@
+--- Makefile Sun May 20 10:40:55 2007
++++ Makefile Sat May 26 20:43:02 2007
+@@ -135,8 +135,8 @@
+
+ # CFLAGS and LDFLAGS are for the users to override from the command line.
+
+-CFLAGS = -g -O2 -Wall
+-LDFLAGS =
++CFLAGS ?= -g -O2 -Wall
++LDFLAGS ?=
+ ALL_CFLAGS = $(CFLAGS)
+ ALL_LDFLAGS = $(LDFLAGS)
+ STRIP ?= strip
+@@ -172,13 +172,13 @@
+
+ export prefix bindir gitexecdir sharedir template_dir sysconfdir
+
+-CC = gcc
+-AR = ar
+-TAR = tar
+-INSTALL = install
+-RPMBUILD = rpmbuild
+-TCL_PATH = tclsh
+-TCLTK_PATH = wish
++CC ?= gcc
++AR ?= ar
++TAR ?= tar
++INSTALL ?= install
++RPMBUILD ?= rpmbuild
++TCL_PATH ?= tclsh
++TCLTK_PATH ?= wish
+
+ export TCL_PATH TCLTK_PATH
+
diff --git a/devel/git/files/patch-gitk b/devel/git/files/patch-gitk
deleted file mode 100644
index 592ad605be6b..000000000000
--- a/devel/git/files/patch-gitk
+++ /dev/null
@@ -1,10 +0,0 @@
---- gitk.orig Tue Feb 7 23:58:47 2006
-+++ gitk Tue Feb 7 23:58:55 2006
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # Tcl ignores the next line -*- tcl -*- \
--exec wish "$0" -- "$@"
-+exec wish8.4 "$0" -- "$@"
-
- # Copyright (C) 2005 Paul Mackerras. All rights reserved.
- # This program is free software; it may be used, copied, modified
diff --git a/devel/git/pkg-plist b/devel/git/pkg-plist
index 0f2d03fea3f2..f8981a9f426c 100644
--- a/devel/git/pkg-plist
+++ b/devel/git/pkg-plist
@@ -142,7 +142,7 @@ bin/git-verify-pack
bin/git-verify-tag
bin/git-whatchanged
bin/git-write-tree
-bin/gitk
+%%GUI%%bin/gitk
%%SITE_PERL%%/Git.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Git/.packlist
lib/xemacs/site-lisp/git/git.el