aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gitaly
diff options
context:
space:
mode:
authormfechner <mfechner@FreeBSD.org>2019-04-23 16:06:26 +0800
committermfechner <mfechner@FreeBSD.org>2019-04-23 16:06:26 +0800
commited02fc9950d3a77a703800601234d982cb210ae1 (patch)
tree2165e3b9dab25c6fab01776194c8016141301e3a /devel/gitaly
parent6f5735a06e1d7947e9a0e49f31b6999bdce20a86 (diff)
downloadfreebsd-ports-gnome-ed02fc9950d3a77a703800601234d982cb210ae1.tar.gz
freebsd-ports-gnome-ed02fc9950d3a77a703800601234d982cb210ae1.tar.zst
freebsd-ports-gnome-ed02fc9950d3a77a703800601234d982cb210ae1.zip
Upgrade to 1.33.0 which is required for Gitlab 11.10 upgrade.
Diffstat (limited to 'devel/gitaly')
-rw-r--r--devel/gitaly/Makefile18
-rw-r--r--devel/gitaly/distinfo6
-rw-r--r--devel/gitaly/files/patch-__support_makegen.go4
-rw-r--r--devel/gitaly/files/patch-config.toml.example2
-rw-r--r--devel/gitaly/files/patch-ruby_Gemfile10
-rw-r--r--devel/gitaly/pkg-plist220
6 files changed, 129 insertions, 131 deletions
diff --git a/devel/gitaly/Makefile b/devel/gitaly/Makefile
index 5c9351059bd2..34ae46c9dc58 100644
--- a/devel/gitaly/Makefile
+++ b/devel/gitaly/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= gitaly
-DISTVERSION= 1.27.1
+DISTVERSION= 1.33.0
PORTREVISION= 1
CATEGORIES= devel
@@ -12,23 +12,23 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
# define dependencies that are required for build and run under MY_DEPENDS
-MY_DEPENDS= git>=2.18:devel/git \
+MY_DEPENDS= git>=2.21:devel/git \
rubygem-bundler>=1.16.5:sysutils/rubygem-bundler \
rubygem-rugged>=0.28.0:devel/rubygem-rugged \
rubygem-github-linguist>=6.1:textproc/rubygem-github-linguist \
- rubygem-gitlab-markup>=1.6.5:textproc/rubygem-gitlab-markup \
- rubygem-gitaly-proto>=1.13.0:net/rubygem-gitaly-proto \
+ rubygem-gitlab-markup>=1.7.0:textproc/rubygem-gitlab-markup \
+ rubygem-gitaly-proto>=1.19.0:net/rubygem-gitaly-proto \
rubygem-activesupport50>=5.0.2:devel/rubygem-activesupport50 \
rubygem-rdoc>=6.0:devel/rubygem-rdoc \
- rubygem-gitlab-gollum-lib>=4.2:www/rubygem-gitlab-gollum-lib \
- rubygem-gitlab-gollum-rugged_adapter>=0.4.4:www/rubygem-gitlab-gollum-rugged_adapter \
+ rubygem-gitlab-gollum-lib>=4.2.7.7:www/rubygem-gitlab-gollum-lib \
+ rubygem-gitlab-gollum-rugged_adapter>=0.4.4.2:www/rubygem-gitlab-gollum-rugged_adapter \
rubygem-grpc>=1.15.0:net/rubygem-grpc \
- rubygem-sentry-raven>=2.7.2:devel/rubygem-sentry-raven \
+ rubygem-sentry-raven>=2.9.0:devel/rubygem-sentry-raven \
rubygem-faraday>=0.12:www/rubygem-faraday \
rubygem-rbtrace>0:devel/rubygem-rbtrace \
rubygem-licensee8>=8.9.0:devel/rubygem-licensee8 \
rubygem-google-protobuf>=3.6:devel/rubygem-google-protobuf
-BUILD_DEPENDS= go>=1.10:lang/go \
+BUILD_DEPENDS= go>=1.11:lang/go \
gem:devel/ruby-gems \
${MY_DEPENDS}
RUN_DEPENDS= ${MY_DEPENDS} \
@@ -40,7 +40,7 @@ USE_RUBY= yes
USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find this here: https://gitlab.com/gitlab-org/gitaly/tags
-GL_COMMIT= a3648fa4ba39e937093c10802ddc26aa00c58e9b
+GL_COMMIT= 800f4ff3272bc519b71cbc7b95d937978d2c53aa
post-patch:
${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|" ${WRKSRC}/config.toml.example
diff --git a/devel/gitaly/distinfo b/devel/gitaly/distinfo
index 175ca3d2c60b..4a6028f69dc2 100644
--- a/devel/gitaly/distinfo
+++ b/devel/gitaly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1553767951
-SHA256 (gitlab-org-gitaly-a3648fa4ba39e937093c10802ddc26aa00c58e9b_GL0.tar.gz) = 672ed410ad0961302a51de833e5247fa8ed55a0c59082e0e1ccede58524eb354
-SIZE (gitlab-org-gitaly-a3648fa4ba39e937093c10802ddc26aa00c58e9b_GL0.tar.gz) = 4691407
+TIMESTAMP = 1555691732
+SHA256 (gitlab-org-gitaly-800f4ff3272bc519b71cbc7b95d937978d2c53aa_GL0.tar.gz) = d38236048e19128ee5ddde0d9c4e2189851e89ebe18bc8ec0c1439286a5b3a25
+SIZE (gitlab-org-gitaly-800f4ff3272bc519b71cbc7b95d937978d2c53aa_GL0.tar.gz) = 4713844
diff --git a/devel/gitaly/files/patch-__support_makegen.go b/devel/gitaly/files/patch-__support_makegen.go
index 463391135c1e..7d3590e0881a 100644
--- a/devel/gitaly/files/patch-__support_makegen.go
+++ b/devel/gitaly/files/patch-__support_makegen.go
@@ -1,4 +1,4 @@
---- _support/makegen.go.orig 2019-03-25 09:02:26 UTC
+--- _support/makegen.go.orig 2019-04-05 16:17:09 UTC
+++ _support/makegen.go
@@ -253,7 +253,7 @@ var templateText = `
# These variables may be overriden at runtime by top-level make
@@ -9,7 +9,7 @@
ASSEMBLY_ROOT ?= {{ .BuildDir }}/assembly
BUILD_TAGS := tracer_static tracer_static_jaeger
-@@ -273,8 +273,8 @@ build: ../.ruby-bundle
+@@ -274,8 +274,8 @@ build: ../.ruby-bundle
# step. Both Omnibus and CNG assume it is in the Gitaly root, not in
# _build. Hence the '../' in front.
../.ruby-bundle: {{ .GitalyRubyDir }}/Gemfile.lock {{ .GitalyRubyDir }}/Gemfile
diff --git a/devel/gitaly/files/patch-config.toml.example b/devel/gitaly/files/patch-config.toml.example
index 4ca9c9401bef..f7620f1f62b0 100644
--- a/devel/gitaly/files/patch-config.toml.example
+++ b/devel/gitaly/files/patch-config.toml.example
@@ -24,7 +24,7 @@
[[storage]]
name = "default"
-path = "/home/git/repositories"
-+path = "/usr/home/git/repositories"
++path = "/usr/local/git/repositories"
# # You can optionally configure more storages for this Gitaly instance to serve up
#
diff --git a/devel/gitaly/files/patch-ruby_Gemfile b/devel/gitaly/files/patch-ruby_Gemfile
index e3b5d6e7f185..719959804fd8 100644
--- a/devel/gitaly/files/patch-ruby_Gemfile
+++ b/devel/gitaly/files/patch-ruby_Gemfile
@@ -1,13 +1,13 @@
---- ruby/Gemfile.orig 2019-03-11 20:46:03 UTC
+--- ruby/Gemfile.orig 2019-04-05 16:17:09 UTC
+++ ruby/Gemfile
@@ -8,7 +8,7 @@ gem 'github-linguist', '~> 6.1', require: 'linguist'
- gem 'gitlab-markup', '~> 1.6.5'
- gem 'gitaly-proto', '~> 1.13.0'
+ gem 'gitlab-markup', '~> 1.7.0'
+ gem 'gitaly-proto', '~> 1.19.0'
gem 'activesupport', '~> 5.0.2'
-gem 'rdoc', '~> 4.2'
+gem 'rdoc', '~> 6.0'
- gem 'gitlab-gollum-lib', '~> 4.2', require: false
- gem 'gitlab-gollum-rugged_adapter', '~> 0.4.4', require: false
+ gem 'gitlab-gollum-lib', '~> 4.2.7.7', require: false
+ gem 'gitlab-gollum-rugged_adapter', '~> 0.4.4.2', require: false
gem 'grpc', '~> 1.15.0'
@@ -22,17 +22,3 @@ gem 'licensee', '~> 8.9.0'
diff --git a/devel/gitaly/pkg-plist b/devel/gitaly/pkg-plist
index f4a72e6a36b0..fb81e1e6d11f 100644
--- a/devel/gitaly/pkg-plist
+++ b/devel/gitaly/pkg-plist
@@ -7,6 +7,111 @@
%%DATADIR%%/ruby/git-hooks/post-receive
%%DATADIR%%/ruby/git-hooks/pre-receive
%%DATADIR%%/ruby/git-hooks/update
+%%DATADIR%%/ruby/gitlab-shell/.codeclimate.yml
+%%DATADIR%%/ruby/gitlab-shell/.gitlab-ci.yml
+%%DATADIR%%/ruby/gitlab-shell/.rubocop.yml
+%%DATADIR%%/ruby/gitlab-shell/.ruby-version
+%%DATADIR%%/ruby/gitlab-shell/CHANGELOG
+%%DATADIR%%/ruby/gitlab-shell/CONTRIBUTING.md
+%%DATADIR%%/ruby/gitlab-shell/Gemfile
+%%DATADIR%%/ruby/gitlab-shell/LICENSE
+%%DATADIR%%/ruby/gitlab-shell/README.md
+%%DATADIR%%/ruby/gitlab-shell/README.orig.md
+%%DATADIR%%/ruby/gitlab-shell/VERSION
+%%DATADIR%%/ruby/gitlab-shell/bin/authorized_keys
+%%DATADIR%%/ruby/gitlab-shell/bin/check
+%%DATADIR%%/ruby/gitlab-shell/bin/compile
+%%DATADIR%%/ruby/gitlab-shell/bin/create-hooks
+%%DATADIR%%/ruby/gitlab-shell/bin/gitlab-keys
+%%DATADIR%%/ruby/gitlab-shell/bin/gitlab-shell-authorized-keys-check
+%%DATADIR%%/ruby/gitlab-shell/bin/gitlab-shell-authorized-principals-check
+%%DATADIR%%/ruby/gitlab-shell/bin/gitlab-shell-ruby
+%%DATADIR%%/ruby/gitlab-shell/bin/install
+%%DATADIR%%/ruby/gitlab-shell/bin/test-logger
+%%DATADIR%%/ruby/gitlab-shell/config.yml.example
+%%DATADIR%%/ruby/gitlab-shell/lib/action.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/action/custom.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_access.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_access_status.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_config.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_custom_hook.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_init.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_keys.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_lfs_authentication.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_logger.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_metrics.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_net.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_net/errors.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_post_receive.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/gitlab_shell.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/hooks_utils.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/http_helper.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/httpunix.rb
+%%DATADIR%%/ruby/gitlab-shell/lib/object_dirs_helper.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_access_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_config_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_custom_hook_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_keys_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_lfs_authentication_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_logger_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_metrics_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_net_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_post_receive_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_shell_authorized_keys_check_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/gitlab_shell_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/hooks_utils_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/httpunix_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/object_dirs_helper_spec.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/spec_helper.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/support/gitlab_shell_setup.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/support/gl_id_test_hook
+%%DATADIR%%/ruby/gitlab-shell/spec/support/hook_fail
+%%DATADIR%%/ruby/gitlab-shell/spec/support/hook_ok
+%%DATADIR%%/ruby/gitlab-shell/spec/support/http_unix_server.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/support/vcr.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/support/webmock.rb
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-pull.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-404-text-html.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-404-text-plain.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-404.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-text-html.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-text-plain.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/allowed-push.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/broadcast_message-none.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/broadcast_message-ok.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/check-ok.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/custom-action-not-ok-json.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/custom-action-not-ok-not-json.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/custom-action-ok-not-json.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/custom-action-ok-with-message.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/custom-action-ok.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/discover-ok.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/http-pull-disabled.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/http-push-disabled.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/lfs-authenticate-ok-download.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/lfs-authenticate-ok-upload.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/notify-post-receive.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/post-receive-not-found.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/post-receive.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/pre-receive-not-found.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/pre-receive.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-key-not-found.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-key-not-implemented.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-key-ok.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-pull-disabled.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-401-text-html.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-401-text-plain.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-401.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-with-user.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-push-disabled.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied-401-text-html.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied-401-text-plain.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied-401.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/two-factor-recovery-codes-fail.yml
+%%DATADIR%%/ruby/gitlab-shell/spec/vcr_cassettes/two-factor-recovery-codes.yml
%%DATADIR%%/ruby/lib/gitaly_server.rb
%%DATADIR%%/ruby/lib/gitaly_server/blob_service.rb
%%DATADIR%%/ruby/lib/gitaly_server/client.rb
@@ -46,7 +151,6 @@
%%DATADIR%%/ruby/lib/gitlab/git/operation_service.rb
%%DATADIR%%/ruby/lib/gitlab/git/path_helper.rb
%%DATADIR%%/ruby/lib/gitlab/git/popen.rb
-%%DATADIR%%/ruby/lib/gitlab/git/raw_diff_change.rb
%%DATADIR%%/ruby/lib/gitlab/git/ref.rb
%%DATADIR%%/ruby/lib/gitlab/git/remote_mirror.rb
%%DATADIR%%/ruby/lib/gitlab/git/remote_repository.rb
@@ -66,7 +170,6 @@
%%DATADIR%%/ruby/lib/gitlab/rails_logger.rb
%%DATADIR%%/ruby/lib/gitlab/ref_matcher.rb
%%DATADIR%%/ruby/lib/gitlab/utils/strong_memoize.rb
-%%DATADIR%%/ruby/lib/gitlab/version_info.rb
%%DATADIR%%/ruby/spec/factories/gitaly/commit.rb
%%DATADIR%%/ruby/spec/factories/gitaly/commit_author.rb
%%DATADIR%%/ruby/spec/factories/sequences.rb
@@ -89,7 +192,6 @@
%%DATADIR%%/ruby/spec/lib/gitlab/git/index_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/lfs_changes_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/popen_spec.rb
-%%DATADIR%%/ruby/spec/lib/gitlab/git/raw_diff_change_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/remote_mirror_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/remote_repository_client_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/remote_repository_spec.rb
@@ -105,7 +207,6 @@
%%DATADIR%%/ruby/spec/lib/gitlab/git/user_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/git/wiki_spec.rb
%%DATADIR%%/ruby/spec/lib/gitlab/ref_matcher_spec.rb
-%%DATADIR%%/ruby/spec/lib/gitlab/version_info_spec.rb
%%DATADIR%%/ruby/spec/spec_helper.rb
%%DATADIR%%/ruby/spec/support/generate-seed-repo-rb
%%DATADIR%%/ruby/spec/support/helpers/certs/gitalycert.pem
@@ -115,116 +216,13 @@
%%DATADIR%%/ruby/spec/support/helpers/seed_repo.rb
%%DATADIR%%/ruby/spec/support/sentry.rb
%%DATADIR%%/ruby/spec/test_repo_helper.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/.codeclimate.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/.gitlab-ci.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/.rubocop.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/.ruby-version
-%%DATADIR%%/ruby/vendor/gitlab-shell/CHANGELOG
-%%DATADIR%%/ruby/vendor/gitlab-shell/CONTRIBUTING.md
-%%DATADIR%%/ruby/vendor/gitlab-shell/Gemfile
-%%DATADIR%%/ruby/vendor/gitlab-shell/LICENSE
-%%DATADIR%%/ruby/vendor/gitlab-shell/README.md
-%%DATADIR%%/ruby/vendor/gitlab-shell/README.orig.md
-%%DATADIR%%/ruby/vendor/gitlab-shell/VERSION
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/authorized_keys
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/check
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/compile
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/create-hooks
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/gitlab-keys
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/gitlab-shell-authorized-keys-check
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/gitlab-shell-authorized-principals-check
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/gitlab-shell-ruby
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/install
-%%DATADIR%%/ruby/vendor/gitlab-shell/bin/test-logger
-%%DATADIR%%/ruby/vendor/gitlab-shell/config.yml.example
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/action.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/action/custom.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_access.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_access_status.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_config.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_custom_hook.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_init.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_keys.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_lfs_authentication.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_logger.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_metrics.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_net.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_net/errors.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_post_receive.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/gitlab_shell.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/hooks_utils.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/http_helper.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/httpunix.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/lib/object_dirs_helper.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_access_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_config_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_custom_hook_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_keys_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_lfs_authentication_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_logger_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_metrics_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_net_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_post_receive_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_shell_authorized_keys_check_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/gitlab_shell_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/hooks_utils_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/httpunix_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/object_dirs_helper_spec.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/spec_helper.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/support/gl_id_test_hook
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/support/hook_fail
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/support/hook_ok
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/support/http_unix_server.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/support/vcr.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/support/webmock.rb
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-pull.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-404-text-html.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-404-text-plain.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-404.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-text-html.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found-text-plain.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push-project-not-found.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/allowed-push.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/broadcast_message-none.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/broadcast_message-ok.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/check-ok.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/custom-action-not-ok-json.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/custom-action-not-ok-not-json.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/custom-action-ok-not-json.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/custom-action-ok-with-message.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/custom-action-ok.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/discover-ok.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/http-pull-disabled.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/http-push-disabled.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/lfs-authenticate-ok-download.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/lfs-authenticate-ok-upload.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/notify-post-receive.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/post-receive-not-found.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/post-receive.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/pre-receive-not-found.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/pre-receive.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-key-not-found.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-key-not-implemented.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-key-ok.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-pull-disabled.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-401-text-html.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-401-text-plain.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-401.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied-with-user.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-pull-project-denied.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-push-disabled.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied-401-text-html.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied-401-text-plain.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied-401.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/ssh-push-project-denied.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/two-factor-recovery-codes-fail.yml
-%%DATADIR%%/ruby/vendor/gitlab-shell/spec/vcr_cassettes/two-factor-recovery-codes.yml
@(,,555) %%DATADIR%%/ruby/git-hooks/gitlab-shell-hook
-@(,,555) %%DATADIR%%/ruby/vendor/gitlab-shell/hooks/post-receive
-@(,,555) %%DATADIR%%/ruby/vendor/gitlab-shell/hooks/pre-receive
-@(,,555) %%DATADIR%%/ruby/vendor/gitlab-shell/hooks/update
+@(,,555) %%DATADIR%%/ruby/gitlab-shell/hooks/post-receive
+@(,,555) %%DATADIR%%/ruby/gitlab-shell/hooks/pre-receive
+@(,,555) %%DATADIR%%/ruby/gitlab-shell/hooks/update
@(,,555) %%DATADIR%%/bin/gitaly
@(,,555) %%DATADIR%%/bin/gitaly-debug
@(,,555) %%DATADIR%%/bin/gitaly-ssh
+@(,,555) %%DATADIR%%/bin/gitaly-wrapper
@(,,555) %%DATADIR%%/bin/praefect
@sample %%DATADIR%%/config.toml.sample