aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glib20/files
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
committermarcus <marcus@FreeBSD.org>2008-03-24 11:52:36 +0800
commit7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3 (patch)
tree862f96db414616c771eb64412d27d795591004f0 /devel/glib20/files
parent6c3349d5db64bb9ea320c30d23ba353e2f013754 (diff)
downloadfreebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.gz
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.tar.zst
freebsd-ports-gnome-7f7d1cea729a5815af0f4db6edfc5ba0f62a57e3.zip
The FreeBSD GNOME team is proud to annunce the release of GNOME 2.22.0 for
FreeBSD. The official GNOME 2.22 release notes can be found at http://library.gnome.org/misc/release-notes/2.22/ . On the FreeBSD front, this release features an updated hal port with support for video4linux devices, DRM (Direct Rendering), and better support of removable media. Work is also underway to tie webkit more closely into GNOME. As part of the GNOME 2.22 upgrade, GStreamer received a rather large upgrade as well. Be sure to consult UPDATING on the proper steps to upgrade all of your GNOME ports. This release would not have been possible without the contributions and testing efforts of the following people: Pawel Worach kan edwin Peter Ulrich Kruppa J. W. Ballantine Yasuda Keisuke Andriy Gapon
Diffstat (limited to 'devel/glib20/files')
-rw-r--r--devel/glib20/files/extra-patch-gthread_gthread-posix.c32
-rw-r--r--devel/glib20/files/patch-ae28
-rw-r--r--devel/glib20/files/patch-ag25
-rw-r--r--devel/glib20/files/patch-ah22
-rw-r--r--devel/glib20/files/patch-config.h.in12
-rw-r--r--devel/glib20/files/patch-gio_glocalfile.c11
-rw-r--r--devel/glib20/files/patch-gio_gunixmount.c21
-rw-r--r--devel/glib20/files/patch-gio_gunixmounts.c148
-rw-r--r--devel/glib20/files/patch-gio_gunixvolume.c17
-rw-r--r--devel/glib20/files/patch-gio_xdgmime_xdgmime.c11
-rw-r--r--devel/glib20/files/patch-gio_xdgmime_xdgmimecache.h12
-rw-r--r--devel/glib20/files/patch-glib::libcharset::Makefile.in27
12 files changed, 293 insertions, 73 deletions
diff --git a/devel/glib20/files/extra-patch-gthread_gthread-posix.c b/devel/glib20/files/extra-patch-gthread_gthread-posix.c
deleted file mode 100644
index bde2862f605e..000000000000
--- a/devel/glib20/files/extra-patch-gthread_gthread-posix.c
+++ /dev/null
@@ -1,32 +0,0 @@
---- gthread/gthread-posix.c.orig Thu Jun 9 11:25:01 2005
-+++ gthread/gthread-posix.c Fri Jun 10 20:23:17 2005
-@@ -115,7 +115,11 @@ static gint priority_normal_value;
- # define PRIORITY_NORMAL_VALUE priority_normal_value
- #endif /* POSIX_MIN_PRIORITY && POSIX_MAX_PRIORITY */
-
-+#define G_THREAD_STACK_SIZE32 (1*1024*1024)
-+#define G_THREAD_STACK_SIZE64 (2*1024*1024)
-+
- static gulong g_thread_min_stack_size = 0;
-+static gulong g_thread_default_stack_size = 0;
-
- #define G_MUTEX_SIZE (sizeof (pthread_mutex_t))
-
-@@ -309,8 +313,16 @@ g_thread_create_posix_impl (GThreadFunc
- stack_size = MAX (g_thread_min_stack_size, stack_size);
- /* No error check here, because some systems can't do it and
- * we simply don't want threads to fail because of that. */
-- pthread_attr_setstacksize (&attr, stack_size);
- }
-+ else
-+ {
-+ if (sizeof(void *) == 8)
-+ g_thread_default_stack_size = G_THREAD_STACK_SIZE64;
-+ else
-+ g_thread_default_stack_size = G_THREAD_STACK_SIZE32;
-+ stack_size = MAX (g_thread_min_stack_size, g_thread_default_stack_size);
-+ }
-+ pthread_attr_setstacksize (&attr, stack_size);
- #endif /* HAVE_PTHREAD_ATTR_SETSTACKSIZE */
-
- #ifdef PTHREAD_SCOPE_SYSTEM
diff --git a/devel/glib20/files/patch-ae b/devel/glib20/files/patch-ae
index 46738f939e1a..2ba6ab189dda 100644
--- a/devel/glib20/files/patch-ae
+++ b/devel/glib20/files/patch-ae
@@ -1,6 +1,28 @@
---- configure.orig Sun Jan 29 13:06:22 2006
-+++ configure Sun Jan 29 13:06:48 2006
-@@ -34462,6 +34461,8 @@
+--- configure.orig 2008-03-17 23:32:05.000000000 -0400
++++ configure 2008-03-18 17:55:42.000000000 -0400
+@@ -32748,6 +32748,12 @@ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+ $ac_includes_default
++#ifdef HAVE_SYS_PARAM_H
++#include <sys/param.h>
++#endif
++#ifdef HAVE_SYS_MOUNT_H
++#include <sys/mount.h>
++#endif
+ int
+ main ()
+ {
+@@ -34051,7 +34057,7 @@ done
+
+
+
+-for ac_func in chown lchown fchmod fchown link statvfs statfs utimes getgrgid getpwuid
++for ac_func in chown lchown fchmod fchown link statvfs statfs utimes getgrgid getpwuid sysctlbyname
+ do
+ as_ac_var=`echo "ac_cv_func_$ac_func" | $as_tr_sh`
+ { echo "$as_me:$LINENO: checking for $ac_func" >&5
+@@ -39139,6 +39145,8 @@ fi
;;
esac
fi
diff --git a/devel/glib20/files/patch-ag b/devel/glib20/files/patch-ag
index 8a89b6e972e9..5ee7fe3d539f 100644
--- a/devel/glib20/files/patch-ag
+++ b/devel/glib20/files/patch-ag
@@ -1,22 +1,21 @@
---- Makefile.in.orig Thu May 3 15:19:30 2007
-+++ Makefile.in Thu May 3 15:19:44 2007
-@@ -248,7 +248,7 @@ target_alias = @target_alias@
-
+--- Makefile.in.orig 2008-02-12 00:16:23.000000000 +0100
++++ Makefile.in 2008-02-12 00:16:23.000000000 +0100
+@@ -338,7 +338,7 @@ EXTRA_DIST = ChangeLog.pre-2-14 ChangeLo
+ gio-2.0-uninstalled.pc.in gio-unix-2.0-uninstalled.pc.in
+ TEST_PROGS =
AUTOMAKE_OPTIONS = 1.7
-
--SUBDIRS = . m4macros glib gobject gmodule gthread tests build po docs
-+SUBDIRS = . m4macros glib gobject gmodule gthread build po docs
-
+-SUBDIRS = . m4macros glib gmodule gthread gobject gio tests po docs
++SUBDIRS = . m4macros glib gmodule gthread gobject gio po docs
+ DIST_SUBDIRS = $(SUBDIRS) build
bin_SCRIPTS = glib-gettextize
-
-@@ -301,8 +301,8 @@ BUILT_EXTRA_DIST = \
+ AM_CPPFLAGS = \
+@@ -356,7 +356,8 @@ BUILT_EXTRA_DIST = \
config.h.win32 \
gtk-doc.make
--
-configexecincludedir = $(libdir)/glib-2.0/include
+glibincludedir = $(includedir)/glib-2.0
+configexecincludedir = $(glibincludedir)
-
+ configexecinclude_DATA = glibconfig.h
CONFIGURE_DEPENDENCIES = acglib.m4
-
+ BUILT_SOURCES = stamp-gc-h #note: not glibconfig.h
diff --git a/devel/glib20/files/patch-ah b/devel/glib20/files/patch-ah
index c339b76e2477..3784d16b8ed2 100644
--- a/devel/glib20/files/patch-ah
+++ b/devel/glib20/files/patch-ah
@@ -1,11 +1,11 @@
---- docs/reference/Makefile.in.orig Fri Oct 24 18:05:32 2003
-+++ docs/reference/Makefile.in Fri Oct 24 18:06:00 2003
-@@ -226,7 +226,7 @@
- sharedstatedir = @sharedstatedir@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
--SUBDIRS = glib gobject
-+SUBDIRS = #glib gobject
- subdir = docs/reference
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = $(top_builddir)/config.h
+--- docs/reference/Makefile.in.orig 2007-12-21 16:54:10.000000000 -0500
++++ docs/reference/Makefile.in 2007-12-21 16:54:40.000000000 -0500
+@@ -268,7 +268,7 @@ GTESTER_REPORT = $(top_builddir)/glib/gt
+ # initialize variables for unconditional += appending
+ EXTRA_DIST =
+ TEST_PROGS =
+-SUBDIRS = glib gobject gio
++SUBDIRS = #glib gobject gio
+ all: all-recursive
+
+ .SUFFIXES:
diff --git a/devel/glib20/files/patch-config.h.in b/devel/glib20/files/patch-config.h.in
new file mode 100644
index 000000000000..3c2bc5d2626f
--- /dev/null
+++ b/devel/glib20/files/patch-config.h.in
@@ -0,0 +1,12 @@
+--- config.h.in.orig 2008-03-18 18:24:24.000000000 -0400
++++ config.h.in 2008-03-18 18:24:59.000000000 -0400
+@@ -197,6 +197,9 @@
+ /* Define to 1 if you have the `getpwuid' function. */
+ #undef HAVE_GETPWUID
+
++/* Define to 1 if you have the `sysctlbyname' function. */
++#undef HAVE_SYSCTLBYNAME
++
+ /* Define if the GNU gettext() function is already present or preinstalled. */
+ #undef HAVE_GETTEXT
+
diff --git a/devel/glib20/files/patch-gio_glocalfile.c b/devel/glib20/files/patch-gio_glocalfile.c
new file mode 100644
index 000000000000..9cf00d383eff
--- /dev/null
+++ b/devel/glib20/files/patch-gio_glocalfile.c
@@ -0,0 +1,11 @@
+--- gio/glocalfile.c.orig 2008-03-10 23:04:57.000000000 -0400
++++ gio/glocalfile.c 2008-03-10 23:05:23.000000000 -0400
+@@ -1001,7 +1001,7 @@ g_local_file_query_filesystem_info (GFil
+ #endif
+ }
+ #ifdef USE_STATFS
+-#if defined(HAVE_STRUCT_STATFS_FS_TYPENAME)
++#if defined(HAVE_STRUCT_STATFS_F_FSTYPENAME)
+ fstype = g_strdup(statfs_buffer.f_fstypename);
+ #else
+ fstype = get_fs_type (statfs_buffer.f_type);
diff --git a/devel/glib20/files/patch-gio_gunixmount.c b/devel/glib20/files/patch-gio_gunixmount.c
new file mode 100644
index 000000000000..b9bfe143ed0c
--- /dev/null
+++ b/devel/glib20/files/patch-gio_gunixmount.c
@@ -0,0 +1,21 @@
+--- gio/gunixmount.c.orig 2007-12-23 15:53:50.000000000 -0500
++++ gio/gunixmount.c 2007-12-23 15:52:52.000000000 -0500
+@@ -372,12 +372,18 @@ g_unix_mount_eject (GMount *
+ gpointer user_data)
+ {
+ GUnixMount *unix_mount = G_UNIX_MOUNT (mount);
++#ifndef __FreeBSD__
+ char *argv[] = {"eject", NULL, NULL};
+
+ if (unix_mount->mount_path != NULL)
+ argv[1] = unix_mount->mount_path;
+ else
+ argv[1] = unix_mount->device_path;
++#else
++ char *argv[] = {"cdcontrol", "-f", NULL, "eject", NULL};
++
++ argv[2] = unix_mount->device_path;
++#endif
+
+ return eject_unmount_do (mount, cancellable, callback, user_data, argv);
+ }
diff --git a/devel/glib20/files/patch-gio_gunixmounts.c b/devel/glib20/files/patch-gio_gunixmounts.c
new file mode 100644
index 000000000000..9b6fa2df36f0
--- /dev/null
+++ b/devel/glib20/files/patch-gio_gunixmounts.c
@@ -0,0 +1,148 @@
+--- ggio/unixmounts.c.orig 2008-03-10 20:31:58.000000000 -0400
++++ gio/gunixmounts.c 2008-03-19 22:31:23.000000000 -0400
+@@ -128,6 +128,9 @@ struct _GUnixMountMonitor {
+
+ GFileMonitor *fstab_monitor;
+ GFileMonitor *mtab_monitor;
++
++ guint mount_poller_source;
++ GList *mount_poller_mounts;
+ };
+
+ struct _GUnixMountMonitorClass {
+@@ -139,6 +142,8 @@ static GUnixMountMonitor *the_mount_moni
+ static GList *_g_get_unix_mounts (void);
+ static GList *_g_get_unix_mount_points (void);
+
++static guint64 mount_poller_time = 0;
++
+ G_DEFINE_TYPE (GUnixMountMonitor, g_unix_mount_monitor, G_TYPE_OBJECT);
+
+ #define MOUNT_POLL_INTERVAL 4000
+@@ -165,6 +170,7 @@ G_DEFINE_TYPE (GUnixMountMonitor, g_unix
+ #endif
+
+ #if defined(HAVE_GETMNTINFO) && defined(HAVE_FSTAB_H) && defined(HAVE_SYS_MOUNT_H)
++#include <sys/param.h>
+ #include <sys/ucred.h>
+ #include <sys/mount.h>
+ #include <fstab.h>
+@@ -215,20 +221,28 @@ g_unix_is_mount_path_system_internal (co
+ "/", /* we already have "Filesystem root" in Nautilus */
+ "/bin",
+ "/boot",
++ "/compat/linux/proc",
++ "/compat/linux/sys",
+ "/dev",
+ "/etc",
+ "/home",
+ "/lib",
+ "/lib64",
++ "/libexec",
+ "/media",
+ "/mnt",
+ "/opt",
++ "/rescue",
+ "/root",
+ "/sbin",
+ "/srv",
+ "/tmp",
+ "/usr",
++ "/usr/X11R6",
+ "/usr/local",
++ "/usr/obj",
++ "/usr/ports",
++ "/usr/src",
+ "/var",
+ "/var/log/audit", /* https://bugzilla.redhat.com/show_bug.cgi?id=333041 */
+ "/var/tmp", /* https://bugzilla.redhat.com/show_bug.cgi?id=335241 */
+@@ -988,6 +1002,10 @@ get_mounts_timestamp (void)
+ if (stat (monitor_file, &buf) == 0)
+ return (guint64)buf.st_mtime;
+ }
++ else
++ {
++ return mount_poller_time;
++ }
+ return 0;
+ }
+
+@@ -1129,6 +1147,13 @@ g_unix_mount_monitor_finalize (GObject *
+ g_object_unref (monitor->mtab_monitor);
+ }
+
++ if (monitor->mount_poller_source > 0)
++ {
++ g_source_remove (monitor->mount_poller_source);
++ g_list_foreach (monitor->mount_poller_mounts, (GFunc)g_unix_mount_free, NULL);
++ g_list_free (monitor->mount_poller_mounts);
++ }
++
+ the_mount_monitor = NULL;
+
+ if (G_OBJECT_CLASS (g_unix_mount_monitor_parent_class)->finalize)
+@@ -1206,6 +1231,51 @@ mtab_file_changed (GFileMonitor *mo
+ g_signal_emit (mount_monitor, signals[MOUNTS_CHANGED], 0);
+ }
+
++static gboolean
++mount_change_poller (gpointer user_data)
++{
++ GUnixMountMonitor *mount_monitor;
++ GList *current_mounts;
++ gboolean has_changed = FALSE;
++
++ mount_monitor = user_data;
++ current_mounts = _g_get_unix_mounts ();
++
++ if (g_list_length (current_mounts) != g_list_length (mount_monitor->mount_poller_mounts))
++ {
++ g_list_foreach (mount_monitor->mount_poller_mounts, (GFunc)g_unix_mount_free, NULL);
++ has_changed = TRUE;
++ }
++ else
++ {
++ int i;
++
++ for (i = 0; i < g_list_length (current_mounts); i++)
++ {
++ GUnixMountEntry *m1;
++ GUnixMountEntry *m2;
++
++ m1 = (GUnixMountEntry *)g_list_nth_data (current_mounts, i);
++ m2 = (GUnixMountEntry *)g_list_nth_data (mount_monitor->mount_poller_mounts, i);
++ if (! has_changed && g_unix_mount_compare (m1, m2) != 0)
++ has_changed = TRUE;
++
++ g_unix_mount_free (m2);
++ }
++ }
++
++ g_list_free (mount_monitor->mount_poller_mounts);
++ mount_monitor->mount_poller_mounts = current_mounts;
++
++ if (has_changed)
++ {
++ mount_poller_time = (guint64)time (NULL);
++ g_signal_emit (mount_monitor, signals[MOUNTS_CHANGED], 0);
++ }
++
++ return TRUE;
++}
++
+ static void
+ g_unix_mount_monitor_init (GUnixMountMonitor *monitor)
+ {
+@@ -1228,6 +1298,12 @@ g_unix_mount_monitor_init (GUnixMountMon
+
+ g_signal_connect (monitor->mtab_monitor, "changed", (GCallback)mtab_file_changed, monitor);
+ }
++ else
++ {
++ monitor->mount_poller_mounts = _g_get_unix_mounts ();
++ mount_poller_time = (guint64)time (NULL);
++ monitor->mount_poller_source = g_timeout_add_seconds (3, (GSourceFunc)mount_change_poller, monitor);
++ }
+ }
+
+ /**
diff --git a/devel/glib20/files/patch-gio_gunixvolume.c b/devel/glib20/files/patch-gio_gunixvolume.c
new file mode 100644
index 000000000000..377a7d6b5686
--- /dev/null
+++ b/devel/glib20/files/patch-gio_gunixvolume.c
@@ -0,0 +1,17 @@
+--- gio/gunixvolume.c.orig 2007-12-23 15:43:17.000000000 -0500
++++ gio/gunixvolume.c 2007-12-23 15:47:08.000000000 -0500
+@@ -387,9 +387,13 @@ g_unix_volume_eject (GVolume *volume,
+ gpointer user_data)
+ {
+ GUnixVolume *unix_volume = G_UNIX_VOLUME (volume);
++#ifdef __FreeBSD__
++ char *argv[] = {"cdcontrol", "-f", NULL, "eject", NULL};
++ argv[2] = unix_volume->device_path;
++#else
+ char *argv[] = {"eject", NULL, NULL};
+-
+ argv[1] = unix_volume->device_path;
++#endif
+
+ eject_mount_do (volume, cancellable, callback, user_data, argv);
+ }
diff --git a/devel/glib20/files/patch-gio_xdgmime_xdgmime.c b/devel/glib20/files/patch-gio_xdgmime_xdgmime.c
new file mode 100644
index 000000000000..8c36dc5d8d4d
--- /dev/null
+++ b/devel/glib20/files/patch-gio_xdgmime_xdgmime.c
@@ -0,0 +1,11 @@
+--- gio/xdgmime/xdgmime.c.orig Mon Nov 8 22:25:27 2004
++++ gio/xdgmime/xdgmime.c Sat Nov 13 10:27:22 2004
+@@ -204,7 +204,7 @@
+
+ xdg_data_dirs = getenv ("XDG_DATA_DIRS");
+ if (xdg_data_dirs == NULL)
+- xdg_data_dirs = "/usr/local/share/:/usr/share/";
++ xdg_data_dirs = "/usr/local/share/";
+
+ ptr = xdg_data_dirs;
+
diff --git a/devel/glib20/files/patch-gio_xdgmime_xdgmimecache.h b/devel/glib20/files/patch-gio_xdgmime_xdgmimecache.h
new file mode 100644
index 000000000000..58aa93037507
--- /dev/null
+++ b/devel/glib20/files/patch-gio_xdgmime_xdgmimecache.h
@@ -0,0 +1,12 @@
+--- gio/xdgmime/xdgmimecache.h.orig 2007-09-13 16:35:37.000000000 -0400
++++ gio/xdgmime/xdgmimecache.h 2007-09-14 00:59:43.000000000 -0400
+@@ -42,6 +42,9 @@ typedef struct _XdgMimeCache XdgMimeCach
+ #define _xdg_mime_cache_list_mime_parents XDG_ENTRY(cache_list_mime_parents)
+ #define _xdg_mime_cache_mime_type_subclass XDG_ENTRY(cache_mime_type_subclass)
+ #define _xdg_mime_cache_unalias_mime_type XDG_ENTRY(cache_unalias_mime_type)
++#define _xdg_mime_cache_is_valid_mime_type XDG_ENTRY(cache_is_valid_mime_type)
++#define _xdg_mime_cache_mime_type_equal XDG_ENTRY(cache_mime_type_equal)
++#define _xdg_mime_cache_media_type_equal XDG_ENTRY(cache_media_type_equal)
+
+ #endif
+
diff --git a/devel/glib20/files/patch-glib::libcharset::Makefile.in b/devel/glib20/files/patch-glib::libcharset::Makefile.in
index 9afd57416296..9cec8906fb28 100644
--- a/devel/glib20/files/patch-glib::libcharset::Makefile.in
+++ b/devel/glib20/files/patch-glib::libcharset::Makefile.in
@@ -1,31 +1,30 @@
---- glib/libcharset/Makefile.in.orig Fri Apr 30 12:10:27 2004
-+++ glib/libcharset/Makefile.in Fri Apr 30 12:12:01 2004
-@@ -225,7 +225,7 @@
- target_alias = @target_alias@
-
+--- glib/libcharset/Makefile.in.orig 2007-12-21 16:55:09.000000000 -0500
++++ glib/libcharset/Makefile.in 2007-12-21 16:56:04.000000000 -0500
+@@ -277,15 +277,15 @@ EXTRA_DIST = README config.charset ref-a
+ codeset.m4 update.sh make-patch.sh libcharset-glib.patch
+ TEST_PROGS =
INCLUDES = \
- -DLIBDIR=\"$(libdir)\" -I$(top_srcdir)
+ -DLIBDIR=\"$(prefix)/libdata\" -I$(top_srcdir)
-
noinst_LTLIBRARIES = libcharset.la
-@@ -246,8 +246,8 @@
- make-patch.sh
-
+ libcharset_la_SOURCES = \
+ libcharset.h \
+ localcharset.c
-charset_alias = $(DESTDIR)$(libdir)/charset.alias
-charset_tmp = $(DESTDIR)$(libdir)/charset.tmp
+charset_alias = $(DESTDIR)$(prefix)/libdata/charset.alias
+charset_tmp = $(DESTDIR)$(prefix)/libdata/charset.tmp
-
SUFFIXES = .sed .sin
+ CLEANFILES = charset.alias ref-add.sed ref-del.sed
+ all: all-am
+@@ -497,7 +497,7 @@ install-data-am:
-@@ -487,7 +487,7 @@
-
- install-data-am:
+ install-dvi: install-dvi-am
-install-exec-am: install-exec-local
+install-exec-am: # install-exec-local
- install-info: install-info-am
+ install-html: install-html-am