aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glib20
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /devel/glib20
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-gnome-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile11
-rw-r--r--devel/glib20/distinfo4
-rw-r--r--devel/glib20/files/extra-patch-gthread_gthread-posix.c14
-rw-r--r--devel/glib20/files/patch-gmodule::gmodule-dl.c1
-rw-r--r--devel/glib20/pkg-plist15
5 files changed, 25 insertions, 20 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 5fc2c11da242..2819fd997a61 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -3,13 +3,14 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/devel/glib20/Makefile,v 1.55 2005/10/03 17:39:56 mezz Exp $
#
PORTNAME= glib
-PORTVERSION= 2.6.6
+PORTVERSION= 2.8.3
CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/2.6,} \
- ftp://ftp.gtk.org/pub/gtk/v2.6/ \
+MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/${PORTNAME}/2.8,} \
+ ftp://ftp.gtk.org/pub/gtk/v2.8/ \
ftp://ftp.gimp.org/pub/%SUBDIR%/ \
ftp://ftp.cs.umn.edu/pub/gimp/%SUBDIR%/ \
http://www.ameth.org/gimp/%SUBDIR%/ \
@@ -24,10 +25,10 @@ LATEST_LINK= glib20
USE_BZIP2= yes
USE_GETTEXT= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-USE_GNOME= gnomehack gnometarget pkgconfig
+USE_GNOME= gnomehack gnometarget pkgconfig ltverhack
USE_GMAKE= yes
USE_PERL5= yes
CONFIGURE_ARGS= --enable-static --with-libiconv=gnu \
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index 7d233fea9ba5..0cca1c837dce 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/glib-2.6.6.tar.bz2) = 6e22b0639d314536f23ee118f29b43de
-SIZE (gnome2/glib-2.6.6.tar.bz2) = 2380899
+MD5 (gnome2/glib-2.8.3.tar.bz2) = 58177fe64c189b86bac1625350512159
+SIZE (gnome2/glib-2.8.3.tar.bz2) = 2564822
diff --git a/devel/glib20/files/extra-patch-gthread_gthread-posix.c b/devel/glib20/files/extra-patch-gthread_gthread-posix.c
index b74c39d48df2..bde2862f605e 100644
--- a/devel/glib20/files/extra-patch-gthread_gthread-posix.c
+++ b/devel/glib20/files/extra-patch-gthread_gthread-posix.c
@@ -1,6 +1,6 @@
---- gthread/gthread-posix.c.orig Thu Jun 9 17:27:13 2005
-+++ gthread/gthread-posix.c Fri Jun 10 22:38:37 2005
-@@ -115,7 +115,11 @@
+--- gthread/gthread-posix.c.orig Thu Jun 9 11:25:01 2005
++++ gthread/gthread-posix.c Fri Jun 10 20:23:17 2005
+@@ -115,7 +115,11 @@ static gint priority_normal_value;
# define PRIORITY_NORMAL_VALUE priority_normal_value
#endif /* POSIX_MIN_PRIORITY && POSIX_MAX_PRIORITY */
@@ -12,18 +12,18 @@
#define G_MUTEX_SIZE (sizeof (pthread_mutex_t))
-@@ -309,8 +313,16 @@
+@@ -309,8 +313,16 @@ g_thread_create_posix_impl (GThreadFunc
stack_size = MAX (g_thread_min_stack_size, stack_size);
/* No error check here, because some systems can't do it and
* we simply don't want threads to fail because of that. */
- pthread_attr_setstacksize (&attr, stack_size);
}
-+ else
++ else
+ {
+ if (sizeof(void *) == 8)
-+ g_thread_default_stack_size = G_THREAD_STACK_SIZE64;
++ g_thread_default_stack_size = G_THREAD_STACK_SIZE64;
+ else
-+ g_thread_default_stack_size = G_THREAD_STACK_SIZE32;
++ g_thread_default_stack_size = G_THREAD_STACK_SIZE32;
+ stack_size = MAX (g_thread_min_stack_size, g_thread_default_stack_size);
+ }
+ pthread_attr_setstacksize (&attr, stack_size);
diff --git a/devel/glib20/files/patch-gmodule::gmodule-dl.c b/devel/glib20/files/patch-gmodule::gmodule-dl.c
index eaa43a74e423..d3c7dc6bf2db 100644
--- a/devel/glib20/files/patch-gmodule::gmodule-dl.c
+++ b/devel/glib20/files/patch-gmodule::gmodule-dl.c
@@ -1,5 +1,6 @@
$FreeBSD$
+ $MCom: ports/devel/glib20/files/patch-gmodule::gmodule-dl.c,v 1.14 2005/06/28 05:40:00 adamw Exp $
--- gmodule/gmodule-dl.c.orig Sat Feb 17 08:28:07 2001
+++ gmodule/gmodule-dl.c Fri Jan 18 09:48:45 2002
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index 11ff429c7984..0cc41e9d3b01 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -26,6 +26,7 @@ include/glib-2.0/glib/gkeyfile.h
include/glib-2.0/glib/glist.h
include/glib-2.0/glib/gmacros.h
include/glib-2.0/glib/gmain.h
+include/glib-2.0/glib/gmappedfile.h
include/glib-2.0/glib/gmarkup.h
include/glib-2.0/glib/gmem.h
include/glib-2.0/glib/gmessages.h
@@ -75,18 +76,19 @@ include/glib-2.0/gobject/gvaluecollector.h
include/glib-2.0/gobject/gvaluetypes.h
lib/libglib-2.0.a
lib/libglib-2.0.so
-lib/libglib-2.0.so.600
+lib/libglib-2.0.so.0
lib/libgmodule-2.0.a
lib/libgmodule-2.0.so
-lib/libgmodule-2.0.so.600
+lib/libgmodule-2.0.so.0
lib/libgobject-2.0.a
lib/libgobject-2.0.so
-lib/libgobject-2.0.so.600
+lib/libgobject-2.0.so.0
lib/libgthread-2.0.a
lib/libgthread-2.0.so
-lib/libgthread-2.0.so.600
+lib/libgthread-2.0.so.0
libdata/pkgconfig/glib-2.0.pc
libdata/pkgconfig/gmodule-2.0.pc
+libdata/pkgconfig/gmodule-export-2.0.pc
libdata/pkgconfig/gmodule-no-export-2.0.pc
libdata/pkgconfig/gobject-2.0.pc
libdata/pkgconfig/gthread-2.0.pc
@@ -155,6 +157,7 @@ share/locale/sr@ije/LC_MESSAGES/glib20.mo
share/locale/sv/LC_MESSAGES/glib20.mo
share/locale/ta/LC_MESSAGES/glib20.mo
share/locale/te/LC_MESSAGES/glib20.mo
+share/locale/th/LC_MESSAGES/glib20.mo
share/locale/tl/LC_MESSAGES/glib20.mo
share/locale/tr/LC_MESSAGES/glib20.mo
share/locale/uk/LC_MESSAGES/glib20.mo
@@ -170,10 +173,10 @@ share/locale/zh_TW/LC_MESSAGES/glib20.mo
@unexec rmdir %D/share/locale/rw 2> /dev/null || true
@unexec rmdir %D/share/locale/sr@ije/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/sr@ije 2> /dev/null || true
-@unexec rmdir %D/share/locale/tl/LC_MESSAGES 2> /dev/null || true
-@unexec rmdir %D/share/locale/tl 2> /dev/null || true
@unexec rmdir %D/share/locale/te/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/te 2> /dev/null || true
+@unexec rmdir %D/share/locale/tl/LC_MESSAGES 2> /dev/null || true
+@unexec rmdir %D/share/locale/tl 2> /dev/null || true
@unexec rmdir %D/share/locale/xh/LC_MESSAGES 2> /dev/null || true
@unexec rmdir %D/share/locale/xh 2> /dev/null || true
@unexec rmdir %D/share/locale/yi/LC_MESSAGES 2> /dev/null || true