aboutsummaryrefslogtreecommitdiffstats
path: root/devel/glib20
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2011-07-30 17:20:22 +0800
committerkwm <kwm@FreeBSD.org>2011-07-30 17:20:22 +0800
commita62cae757688a808afa976415de0ad1de2fca4b9 (patch)
tree3340ef98494c1bf2c67cae30b850dc805e3023d7 /devel/glib20
parentbeda4282e4a11026847c701177b762e2e72244a1 (diff)
downloadfreebsd-ports-gnome-a62cae757688a808afa976415de0ad1de2fca4b9.tar.gz
freebsd-ports-gnome-a62cae757688a808afa976415de0ad1de2fca4b9.tar.zst
freebsd-ports-gnome-a62cae757688a808afa976415de0ad1de2fca4b9.zip
Update the glib and gtk stack to the lastest stable releases.
Add new ports for the new stable releases of gtk+-3.0. Update vala to the newest stable release 0.12.1. Thanks to pav@ for doing multiple exp-runs, and marcus@ for repo-copies. Full contributors acknowledgment will be given in the GNOME 3 import.
Diffstat (limited to 'devel/glib20')
-rw-r--r--devel/glib20/Makefile19
-rw-r--r--devel/glib20/distinfo4
-rw-r--r--devel/glib20/files/patch-glib-2.0.pc.in8
-rw-r--r--devel/glib20/pkg-plist22
4 files changed, 40 insertions, 13 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index 0df7a1d50a04..7385798babf9 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -3,13 +3,13 @@
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/devel/glib20/Makefile,v 1.188 2010/11/15 02:01:55 kwm Exp $
+# $MCom: ports/devel/glib20/Makefile,v 1.209 2011/06/11 19:51:14 mezz Exp $
#
# !! DON'T FORGET ABOUT devel/gio-fam-backend !!
PORTNAME= glib
-PORTVERSION= 2.26.1
-PORTREVISION?= 1
+PORTVERSION= 2.28.8
+PORTREVISION?= 0
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME:S,%SUBDIR%,sources/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/},} \
ftp://ftp.gtk.org/pub/glib/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}/ \
@@ -25,7 +25,7 @@ COMMENT= Some useful routines of C programming (current stable version)
LATEST_LINK= glib20
-USE_BZIP2= yes
+USE_XZ= yes
LICENSE= LGPL20
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -47,8 +47,8 @@ CONFIGURE_ARGS= --enable-static --with-libiconv=gnu \
--disable-dtrace \
--with-pcre=system \
--disable-fam
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
+CPPFLAGS= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lintl" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -57,7 +57,7 @@ OPTIONS= COLLATION_FIX "fix string collation" off
.include <bsd.port.pre.mk>
.if ${ARCH} == powerpc64
-EXTRA_PATCHES= ${.CURDIR}/files/extra-arch-powerpc64
+EXTRA_PATCHES= ${FILESDIR}/extra-arch-powerpc64
.endif
# Let glib use asm code for implementing atomic ops on i386 and amd64.
@@ -83,8 +83,9 @@ CONFIGURE_ARGS+= --enable-debug=yes
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' \
- ${WRKSRC}/glib/gutils.c
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
+ s|/usr/share/locale/locale|${LOCALBASE}/share/locale/locale|g' \
+ ${WRKSRC}/glib/gutils.c
@${REINPLACE_CMD} -e 's|/lib/dbus/machine-id|/db/dbus/machine-id|g' \
${WRKSRC}/gio/gdbusaddress.c ${WRKSRC}/gio/gdbusprivate.c \
${WRKSRC}/po/*.po
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index 0ef45aba0485..93d831f49734 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/glib-2.26.1.tar.bz2) = 7a74ff12b6b9dee1f2d0e520b56b68b621920c4f4250bdf23468e515625c28d5
-SIZE (gnome2/glib-2.26.1.tar.bz2) = 6704686
+SHA256 (gnome2/glib-2.28.8.tar.xz) = 4d7ca95dbde8e8f60ab428c765b0dbb8a44be9eb9316491803ce5ee7b4748353
+SIZE (gnome2/glib-2.28.8.tar.xz) = 5223564
diff --git a/devel/glib20/files/patch-glib-2.0.pc.in b/devel/glib20/files/patch-glib-2.0.pc.in
new file mode 100644
index 000000000000..f714b6f6eb02
--- /dev/null
+++ b/devel/glib20/files/patch-glib-2.0.pc.in
@@ -0,0 +1,8 @@
+--- glib-2.0.pc.in.orig 2011-01-06 07:29:30.000000000 +0000
++++ glib-2.0.pc.in 2011-01-06 07:29:41.000000000 +0000
+@@ -12,4 +12,4 @@
+ Version: @VERSION@
+ Libs: -L${libdir} -lglib-2.0 @INTLLIBS@
+ Libs.private: @ICONV_LIBS@
+-Cflags: -I${includedir}/glib-2.0 -I${libdir}/glib-2.0/include @GLIB_EXTRA_CFLAGS@
++Cflags: -I${includedir}/glib-2.0 @GLIB_EXTRA_CFLAGS@
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index d25cc3afcee1..e3b7ff0f2eaa 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -20,7 +20,11 @@ include/gio-unix-2.0/gio/gunixinputstream.h
include/gio-unix-2.0/gio/gunixmounts.h
include/gio-unix-2.0/gio/gunixoutputstream.h
include/gio-unix-2.0/gio/gunixsocketaddress.h
+include/glib-2.0/gio/gaction.h
+include/glib-2.0/gio/gactiongroup.h
include/glib-2.0/gio/gappinfo.h
+include/glib-2.0/gio/gapplication.h
+include/glib-2.0/gio/gapplicationcommandline.h
include/glib-2.0/gio/gasyncinitable.h
include/glib-2.0/gio/gasyncresult.h
include/glib-2.0/gio/gbufferedinputstream.h
@@ -84,10 +88,14 @@ include/glib-2.0/gio/gnetworkaddress.h
include/glib-2.0/gio/gnetworkservice.h
include/glib-2.0/gio/goutputstream.h
include/glib-2.0/gio/gpermission.h
+include/glib-2.0/gio/gpollableinputstream.h
+include/glib-2.0/gio/gpollableoutputstream.h
include/glib-2.0/gio/gproxy.h
include/glib-2.0/gio/gproxyaddress.h
include/glib-2.0/gio/gproxyaddressenumerator.h
include/glib-2.0/gio/gproxyresolver.h
+include/glib-2.0/gio/gsimpleaction.h
+include/glib-2.0/gio/gsimpleactiongroup.h
include/glib-2.0/gio/gresolver.h
include/glib-2.0/gio/gseekable.h
include/glib-2.0/gio/gsettings.h
@@ -105,8 +113,14 @@ include/glib-2.0/gio/gsocketlistener.h
include/glib-2.0/gio/gsocketservice.h
include/glib-2.0/gio/gsrvtarget.h
include/glib-2.0/gio/gtcpconnection.h
+include/glib-2.0/gio/gtcpwrapperconnection.h
include/glib-2.0/gio/gthemedicon.h
include/glib-2.0/gio/gthreadedsocketservice.h
+include/glib-2.0/gio/gtlsbackend.h
+include/glib-2.0/gio/gtlscertificate.h
+include/glib-2.0/gio/gtlsclientconnection.h
+include/glib-2.0/gio/gtlsconnection.h
+include/glib-2.0/gio/gtlsserverconnection.h
include/glib-2.0/gio/gvfs.h
include/glib-2.0/gio/gvolume.h
include/glib-2.0/gio/gvolumemonitor.h
@@ -319,6 +333,7 @@ share/locale/th/LC_MESSAGES/glib20.mo
share/locale/tl/LC_MESSAGES/glib20.mo
share/locale/tr/LC_MESSAGES/glib20.mo
share/locale/tt/LC_MESSAGES/glib20.mo
+share/locale/ug/LC_MESSAGES/glib20.mo
share/locale/uk/LC_MESSAGES/glib20.mo
share/locale/vi/LC_MESSAGES/glib20.mo
share/locale/wa/LC_MESSAGES/glib20.mo
@@ -328,8 +343,9 @@ share/locale/zh_CN/LC_MESSAGES/glib20.mo
share/locale/zh_HK/LC_MESSAGES/glib20.mo
share/locale/zh_TW/LC_MESSAGES/glib20.mo
@exec mkdir -p %D/share/glib-2.0/schemas
-@dirrmtry share/GConf/gsettings
-@dirrmtry share/GConf
+@exec mkdir -p %D/share/GConf/gsettings
+@dirrm share/GConf/gsettings
+@dirrm share/GConf
@exec glib-compile-schemas --uninstall %D/share/glib-2.0/schemas
@dirrm share/glib-2.0/schemas
@dirrm share/glib-2.0/gettext/po
@@ -352,6 +368,8 @@ share/locale/zh_TW/LC_MESSAGES/glib20.mo
@dirrmtry share/locale/yi
@dirrmtry share/locale/xh/LC_MESSAGES
@dirrmtry share/locale/xh
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
@dirrmtry share/locale/tt/LC_MESSAGES
@dirrmtry share/locale/tt
@dirrmtry share/locale/tl/LC_MESSAGES