aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnomebuild
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-07 03:06:30 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-07 03:06:30 +0800
commit36b31b42049a60a73e23655795087c6726f532c5 (patch)
treeba0554be0ac5de3ad2b75f88cef13595aaae59be /devel/gnomebuild
parent75faf75eaa69adad9c3c515dfa0d56b012fc7935 (diff)
downloadfreebsd-ports-gnome-36b31b42049a60a73e23655795087c6726f532c5.tar.gz
freebsd-ports-gnome-36b31b42049a60a73e23655795087c6726f532c5.tar.zst
freebsd-ports-gnome-36b31b42049a60a73e23655795087c6726f532c5.zip
Use USE_GNOMENG.
Diffstat (limited to 'devel/gnomebuild')
-rw-r--r--devel/gnomebuild/Makefile12
-rw-r--r--devel/gnomebuild/files/patch-ltmain.sh28
2 files changed, 5 insertions, 35 deletions
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 0505ea17116f..d8280e1edbc5 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -18,17 +18,15 @@ LIB_DEPENDS= gdl.0:${PORTSDIR}/x11-toolkits/gdl
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= yes
-GNU_CONFIGURE= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomevfs bonobo libglade gal gtkhtml
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/devel/gnomebuild/files/patch-ltmain.sh b/devel/gnomebuild/files/patch-ltmain.sh
deleted file mode 100644
index 98cb05e4ddb3..000000000000
--- a/devel/gnomebuild/files/patch-ltmain.sh
+++ /dev/null
@@ -1,28 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh 2001/08/27 09:51:26 1.1
-+++ ltmain.sh 2001/08/27 09:51:42
-@@ -2408,6 +2408,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4175,10 +4178,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"