aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnomevfs2/Makefile
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2001-10-01 14:37:30 +0800
committersobomax <sobomax@FreeBSD.org>2001-10-01 14:37:30 +0800
commit08434272169087c73440b190527977358a69a7a8 (patch)
treeb402b70ba4928a1371e94a2f7625c87c0d7ce1f1 /devel/gnomevfs2/Makefile
parentfc822deb2877da949318294b37d50a9db48cdbcd (diff)
downloadfreebsd-ports-gnome-08434272169087c73440b190527977358a69a7a8.tar.gz
freebsd-ports-gnome-08434272169087c73440b190527977358a69a7a8.tar.zst
freebsd-ports-gnome-08434272169087c73440b190527977358a69a7a8.zip
Update to 1.0.2.
Diffstat (limited to 'devel/gnomevfs2/Makefile')
-rw-r--r--devel/gnomevfs2/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 40048717a24f..86fa388befa2 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnomevfs
-PORTVERSION= 1.0.1
+PORTVERSION= 1.0.2
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/gnome-vfs
@@ -14,6 +14,7 @@ DISTNAME= gnome-vfs-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
+BUILD_DEPENDS= msgfmt-new:${PORTSDIR}/devel/gettext-devel
LIB_DEPENDS= gconf-1.1:${PORTSDIR}/devel/gconf
.if !exists(/usr/bin/bzip2)
LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
@@ -22,20 +23,29 @@ LIB_DEPENDS+= bz2.1:${PORTSDIR}/archivers/bzip2
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOMELIBS= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LIBS="-L${LOCALBASE}/lib" \
+ MSGFMT=${LOCALBASE}/bin/msgfmt-new \
+ XGETTEXT=${LOCALBASE}/bin/xgettext-new
MAN5= gnome-vfs-mime.5
pre-patch:
@${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
@find ${WRKSRC} -name 'xml-i18n-*' | xargs ${PERL} -pi -e \
's|/usr/local/bin/perl|${PERL}|g'
+post-install:
+ @if [ -L ${PREFIX}/include/libgnomevfs ]; then \
+ ${RM} -f ${PREFIX}/include/libgnomevfs; \
+ fi
+ ${LN} -sf ${PREFIX}/include/gnome-vfs-1.0/libgnomevfs \
+ ${PREFIX}/include/libgnomevfs
+
.include <bsd.port.mk>