aboutsummaryrefslogtreecommitdiffstats
path: root/devel/grv
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-06-29 11:51:13 +0800
committertobik <tobik@FreeBSD.org>2019-06-29 11:51:13 +0800
commit01937667a99ad7ce0fe80e148aef97dd7683f94c (patch)
tree8c7c440762c72012824110ba9cdd44c8c1765017 /devel/grv
parent388b5eef103bfb24dd783b7f2c5dd9f7cf45e08a (diff)
downloadfreebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.tar.gz
freebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.tar.zst
freebsd-ports-gnome-01937667a99ad7ce0fe80e148aef97dd7683f94c.zip
Convert all Go ports to USES=go
This allows for port testing with lang/go-devel via GO_PORT, setting up the Go build environment in a single place, and is step one in simplifying Go ports that often define too complicated do-build targets themselves. USES=go gains new arguments 'run' to add lang/go to RUN_DEPENDS and 'no_targets' for ports with composite builds that call 'go' themselves and do not need the do-build/do-install targets of USES=go. PR: 238849 Submitted by: dg@syrec.org (also D20745) Reviewed by: mat, tobik Exp-run by: antoine Differential Revision: https://reviews.freebsd.org/D20746
Diffstat (limited to 'devel/grv')
-rw-r--r--devel/grv/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/devel/grv/Makefile b/devel/grv/Makefile
index d10d3581a827..d44cfe712a6d 100644
--- a/devel/grv/Makefile
+++ b/devel/grv/Makefile
@@ -12,10 +12,9 @@ COMMENT= Terminal interface for viewing git repositories
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= go:lang/go
LIB_DEPENDS= libgit2.so:devel/libgit2
-USES= ncurses pkgconfig readline:port
+USES= go ncurses pkgconfig readline:port
USE_GITHUB= yes
GH_ACCOUNT= rgburke
GH_SUBDIR= src/github.com/rgburke/grv