aboutsummaryrefslogtreecommitdiffstats
path: root/devel/guichan
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2006-09-29 20:58:48 +0800
committerrafan <rafan@FreeBSD.org>2006-09-29 20:58:48 +0800
commit7055b25c3bfd6e08d8c7300dcd62b9328533093d (patch)
treef5a3d42f8c013b73d11a9464bf382ce0a0d2cb57 /devel/guichan
parentbe18abc9433feb7fdd94ec18d9840901b081b3dc (diff)
downloadfreebsd-ports-gnome-7055b25c3bfd6e08d8c7300dcd62b9328533093d.tar.gz
freebsd-ports-gnome-7055b25c3bfd6e08d8c7300dcd62b9328533093d.tar.zst
freebsd-ports-gnome-7055b25c3bfd6e08d8c7300dcd62b9328533093d.zip
- Update to 0.5.0
- OPTIONS'ify PR: ports/103710 Submitted by: Marcus von Appen <mva at sysfault.org> (maintainer)
Diffstat (limited to 'devel/guichan')
-rw-r--r--devel/guichan/Makefile64
-rw-r--r--devel/guichan/distinfo6
-rw-r--r--devel/guichan/files/patch-configure40
-rw-r--r--devel/guichan/files/patch-include__guichan__sdl__Makefile.in12
-rw-r--r--devel/guichan/files/patch-src__sdl__sdlimageloader.cpp11
-rw-r--r--devel/guichan/pkg-plist52
6 files changed, 86 insertions, 99 deletions
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index 7c418eb136a0..6f5d3afdbada 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= guichan
-PORTVERSION= 0.4.0
-PORTREVISION= 4
+PORTVERSION= 0.5.0
CATEGORIES= devel games
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,22 +15,55 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= mva@sysfault.org
COMMENT= A small, efficient C++ GUI library designed for games
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-
-USE_SDL= sdl image
USE_GMAKE= yes
USE_GCC= 3.2+
-USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --disable-allegro
-INSTALLS_SHLIB= yes
-LDCONFIG_DIRS= %%LOCALBASE%%/lib
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib ${PTHREAD_LIBS}"
+
+OPTIONS= SDL "Enable SDL support" On \
+ ALLEGRO "Enable Allegro support" Off \
+ GL "Enable OpenGL support" On \
+ GLUT "Enable Glut support" Off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_SDL)
+USE_SDL+= sdl image
+CONFIGURE_ARGS+=--enable-sdl --enable-sdlimage
+PLIST_SUB+= SDL=""
+.else
+CONFIGURE_ARGS+=--disable-sdl --disable-sdlimage
+PLIST_SUB+= SDL="@comment "
+.endif
+
+.if defined(WITH_ALLEGRO)
+LIB_DEPENDS+= alleg.42:${PORTSDIR}/devel/allegro
+CONFIGURE_ARGS+=--enable-allegro
+PLIST_SUB+= ALLEGRO=""
+.else
+CONFIGURE_ARGS+=--disable-allegro
+PLIST_SUB+= ALLEGRO="@comment "
+.endif
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/SDL \
- -I${X11BASE}/include" LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib \
- ${PTHREAD_LIBS}"
+.if !defined(WITHOUT_GL)
+USE_GL= yes
+CONFIGURE_ARGS+=--enable-opengl
+PLIST_SUB+= GL=""
+.else
+CONFIGURE_ARGS+=--disable-opengl
+PLIST_SUB+= GL="@comment "
+.endif
-post-patch:
- @${REINPLACE_CMD} -e "s|%%SDL_CONFIG_ONLY%%|${SDL_CONFIG:S/${PREFIX}\/bin\///}|g" \
- -e "s|%%SDL_CONFIG%%|${SDL_CONFIG}|g" ${WRKSRC}/configure
+.if defined(WITH_GLUT)
+CONFIGURE_ARGS+=--enable-glut
+LIB_DEPENDS+= glut.4:${PORTSDIR}/graphics/libglut
+PLIST_SUB+= GLUT=""
+.else
+CONFIGURE_ARGS+=--disable-glut
+PLIST_SUB+= GLUT="@comment "
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/devel/guichan/distinfo b/devel/guichan/distinfo
index 17415b61ba2b..54a0d40b07ca 100644
--- a/devel/guichan/distinfo
+++ b/devel/guichan/distinfo
@@ -1,3 +1,3 @@
-MD5 (guichan-0.4.0-src.tar.gz) = f68b6c603c4fb3d70a8737f916214a35
-SHA256 (guichan-0.4.0-src.tar.gz) = 202a4cecbfd16c27cfe754ed9effcbfff7b771d456e436cccd3d93182f02734c
-SIZE (guichan-0.4.0-src.tar.gz) = 1274735
+MD5 (guichan-0.5.0-src.tar.gz) = c9fcbcb360105247da06afc5c643e664
+SHA256 (guichan-0.5.0-src.tar.gz) = cdc44871704b3954d9a16d75c81e2f23aa4ee32e745138aa3edcbd104fdf0bff
+SIZE (guichan-0.5.0-src.tar.gz) = 1492575
diff --git a/devel/guichan/files/patch-configure b/devel/guichan/files/patch-configure
deleted file mode 100644
index 84cbf8615b5a..000000000000
--- a/devel/guichan/files/patch-configure
+++ /dev/null
@@ -1,40 +0,0 @@
---- configure.orig Tue May 17 16:23:18 2005
-+++ configure Thu Oct 13 14:33:11 2005
-@@ -20037,7 +20037,7 @@
- {
- SDLIMAGE="yes"
- SDL_LIBS="$SDL_LIBS -lSDL_image"
-- CPPFLAGS="$CPPFLAGS `sdl-config --cflags`"
-+ CPPFLAGS="$CPPFLAGS `%%SDL_CONFIG%% --cflags`"
- }
-
- ForceSDLImage()
-@@ -20338,7 +20338,7 @@
- if test x$enable_sdlimage = xyes; then
- if test x$enable_force_sdlimage = xno; then
-
--for ac_header in SDL/SDL_image.h
-+for ac_header in SDL_image.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -20790,7 +20790,7 @@
- if test x$enable_sdl = xyes; then
- if test x$enable_force_sdl = xno; then
-
--for ac_header in SDL/SDL.h
-+for ac_header in SDL.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -20939,8 +20939,8 @@
-
- done
-
-- # Extract the first word of "sdl-config", so it can be a program name with args.
--set dummy sdl-config; ac_word=$2
-+ # Extract the first word of "%%SDL_CONFIG_ONLY%%", so it can be a program name with args.
-+set dummy %%SDL_CONFIG_ONLY%%; ac_word=$2
- echo "$as_me:$LINENO: checking for $ac_word" >&5
- echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
- if test "${ac_cv_prog_HAVE_SDL+set}" = set; then
diff --git a/devel/guichan/files/patch-include__guichan__sdl__Makefile.in b/devel/guichan/files/patch-include__guichan__sdl__Makefile.in
deleted file mode 100644
index 930432aebff3..000000000000
--- a/devel/guichan/files/patch-include__guichan__sdl__Makefile.in
+++ /dev/null
@@ -1,12 +0,0 @@
---- include/guichan/sdl/Makefile.in.orig Tue May 17 16:23:16 2005
-+++ include/guichan/sdl/Makefile.in Fri Apr 28 21:07:32 2006
-@@ -184,7 +184,8 @@
- libguichaninclude_HEADERS = \
- sdlgraphics.hpp \
- sdlimageloader.hpp \
-- sdlinput.hpp
-+ sdlinput.hpp \
-+ sdlpixel.hpp
-
- all: all-am
-
diff --git a/devel/guichan/files/patch-src__sdl__sdlimageloader.cpp b/devel/guichan/files/patch-src__sdl__sdlimageloader.cpp
deleted file mode 100644
index f907e449829b..000000000000
--- a/devel/guichan/files/patch-src__sdl__sdlimageloader.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/sdl/sdlimageloader.cpp.orig Tue Oct 11 21:58:04 2005
-+++ src/sdl/sdlimageloader.cpp Tue Oct 11 21:58:18 2005
-@@ -56,7 +56,7 @@
- * For comments regarding functions please see the header file.
- */
-
--#include <SDL/SDL_image.h>
-+#include <SDL_image.h>
-
- #include "guichan/sdl/sdlimageloader.hpp"
- #include "guichan/exception.hpp"
diff --git a/devel/guichan/pkg-plist b/devel/guichan/pkg-plist
index d5aaed307557..aa6120086c47 100644
--- a/devel/guichan/pkg-plist
+++ b/devel/guichan/pkg-plist
@@ -10,6 +10,7 @@ include/guichan/focushandler.hpp
include/guichan/font.hpp
include/guichan/graphics.hpp
include/guichan/gui.hpp
+include/guichan/glut.hpp
include/guichan/image.hpp
include/guichan/imagefont.hpp
include/guichan/imageloader.hpp
@@ -21,15 +22,9 @@ include/guichan/listmodel.hpp
include/guichan/mouseinput.hpp
include/guichan/mouselistener.hpp
include/guichan/opengl.hpp
-include/guichan/opengl/openglgraphics.hpp
-include/guichan/opengl/openglimageloader.hpp
include/guichan/platform.hpp
include/guichan/rectangle.hpp
include/guichan/sdl.hpp
-include/guichan/sdl/sdlgraphics.hpp
-include/guichan/sdl/sdlimageloader.hpp
-include/guichan/sdl/sdlinput.hpp
-include/guichan/sdl/sdlpixel.hpp
include/guichan/widget.hpp
include/guichan/widgets/button.hpp
include/guichan/widgets/checkbox.hpp
@@ -45,19 +40,42 @@ include/guichan/widgets/textbox.hpp
include/guichan/widgets/textfield.hpp
include/guichan/widgets/window.hpp
include/guichan/x.hpp
+%%ALLEGRO%%include/guichan/allegro/allegrographics.hpp
+%%ALLEGRO%%include/guichan/allegro/allegroimage.hpp
+%%ALLEGRO%%include/guichan/allegro/allegroimageloader.hpp
+%%ALLEGRO%%include/guichan/allegro/allegroinput.hpp
+%%GLUT%%include/guichan/glut/glutinput.hpp
+%%GL%%include/guichan/opengl/openglgraphics.hpp
+%%GL%%include/guichan/opengl/openglimage.hpp
+%%GL%%include/guichan/opengl/openglsdlimageloader.hpp
+%%SDL%%include/guichan/sdl/sdlgraphics.hpp
+%%SDL%%include/guichan/sdl/sdlimage.hpp
+%%SDL%%include/guichan/sdl/sdlimageloader.hpp
+%%SDL%%include/guichan/sdl/sdlinput.hpp
+%%SDL%%include/guichan/sdl/sdlpixel.hpp
lib/libguichan.a
lib/libguichan.la
-lib/libguichan.so
lib/libguichan.so.0
-lib/libguichan_opengl.a
-lib/libguichan_opengl.la
-lib/libguichan_opengl.so
-lib/libguichan_opengl.so.0
-lib/libguichan_sdl.a
-lib/libguichan_sdl.la
-lib/libguichan_sdl.so
-lib/libguichan_sdl.so.0
+lib/libguichan.so
+%%ALLEGRO%%lib/libguichan_allegro.a
+%%ALLEGRO%%lib/libguichan_allegro.la
+%%ALLEGRO%%lib/libguichan_allegro.so
+%%ALLEGRO%%lib/libguichan_allegro.so.0
+%%GLUT%%lib/libguichan_glut.a
+%%GLUT%%lib/libguichan_glut.la
+%%GLUT%%lib/libguichan_glut.so
+%%GLUT%%lib/libguichan_glut.so.0
+%%GL%%lib/libguichan_opengl.a
+%%GL%%lib/libguichan_opengl.la
+%%GL%%lib/libguichan_opengl.so
+%%GL%%lib/libguichan_opengl.so.0
+%%SDL%%lib/libguichan_sdl.a
+%%SDL%%lib/libguichan_sdl.la
+%%SDL%%lib/libguichan_sdl.so
+%%SDL%%lib/libguichan_sdl.so.0
+%%ALLEGRO%%@dirrm include/guichan/allegro
+%%GLUT%%@dirrm include/guichan/glut
+%%GL%%@dirrm include/guichan/opengl
+%%SDL%%@dirrm include/guichan/sdl
@dirrm include/guichan/widgets
-@dirrm include/guichan/sdl
-@dirrm include/guichan/opengl
@dirrm include/guichan