aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-gio
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-05-09 03:11:09 +0800
committerashish <ashish@FreeBSD.org>2011-05-09 03:11:09 +0800
commit0a845902488260448c6a10f408e3fa3b9aac40ad (patch)
treed4bcb590b2fe3726cc84fa68dacadc99b9baa86e /devel/hs-gio
parent8ae4c1eb069fe467fccd349f877a295374b67dae (diff)
downloadfreebsd-ports-gnome-0a845902488260448c6a10f408e3fa3b9aac40ad.tar.gz
freebsd-ports-gnome-0a845902488260448c6a10f408e3fa3b9aac40ad.tar.zst
freebsd-ports-gnome-0a845902488260448c6a10f408e3fa3b9aac40ad.zip
GIO is striving to provide a modern, easy-to-use VFS API that sits at the right
level in the library stack. The goal is to overcome the shortcomings of GnomeVFS and provide an API that is so good that developers prefer it over raw POSIX calls. Among other things that means using GObject. It also means not cloning the POSIX API, but providing higher-level, document-centric interfaces. WWW: http://www.haskell.org/gtk2hs/ Approved by: pgj (mentor) Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-gio')
-rw-r--r--devel/hs-gio/Makefile24
-rw-r--r--devel/hs-gio/distinfo2
-rw-r--r--devel/hs-gio/pkg-descr7
3 files changed, 33 insertions, 0 deletions
diff --git a/devel/hs-gio/Makefile b/devel/hs-gio/Makefile
new file mode 100644
index 000000000000..3b628ddbf896
--- /dev/null
+++ b/devel/hs-gio/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: hs-gio
+# Date created: March 13, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gio
+PORTVERSION= 0.12.0
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Binding to the GIO
+
+LICENSE= LGPL21
+FILE_LICENSE= COPYING
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= glib>=0.12.0 mtl
+
+PORTDATA= *
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-gio/distinfo b/devel/hs-gio/distinfo
new file mode 100644
index 000000000000..2aaa2cb7a8f7
--- /dev/null
+++ b/devel/hs-gio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/gio-0.12.0.tar.gz) = 2c3c60a63251d08c35abae6fe22c04de585f54e07f8a97d1f1835d42e6f3b25c
+SIZE (cabal/gio-0.12.0.tar.gz) = 76629
diff --git a/devel/hs-gio/pkg-descr b/devel/hs-gio/pkg-descr
new file mode 100644
index 000000000000..9a0716ee8194
--- /dev/null
+++ b/devel/hs-gio/pkg-descr
@@ -0,0 +1,7 @@
+GIO is striving to provide a modern, easy-to-use VFS API that sits at the right
+level in the library stack. The goal is to overcome the shortcomings of
+GnomeVFS and provide an API that is so good that developers prefer it over raw
+POSIX calls. Among other things that means using GObject. It also means not
+cloning the POSIX API, but providing higher-level, document-centric interfaces.
+
+WWW: http://www.haskell.org/gtk2hs/