aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-hat
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2002-08-21 23:28:54 +0800
committerobraun <obraun@FreeBSD.org>2002-08-21 23:28:54 +0800
commitedce368ce8c1250792e5d3903a97aa47691bfeba (patch)
tree4f20682ae87260cc71fcaba82788e9437aa3a41d /devel/hs-hat
parent2f3369b4f61e25333148536d39bc779177a335d8 (diff)
downloadfreebsd-ports-gnome-edce368ce8c1250792e5d3903a97aa47691bfeba.tar.gz
freebsd-ports-gnome-edce368ce8c1250792e5d3903a97aa47691bfeba.tar.zst
freebsd-ports-gnome-edce368ce8c1250792e5d3903a97aa47691bfeba.zip
Change MAINTAINER to my FreeBSD address.
Do not allow building with ghc-5.04 due to errors. Add patch to fix build on bento. PR: ports/40828 Approved by: dwcjr (mentor)
Diffstat (limited to 'devel/hs-hat')
-rw-r--r--devel/hs-hat/Makefile15
-rw-r--r--devel/hs-hat/files/patch-script::harch13
2 files changed, 25 insertions, 3 deletions
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 140c6477ee27..204daf5bb5b5 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -10,7 +10,15 @@ PORTVERSION= 2.00
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cs.york.ac.uk/pub/haskell/${PORTNAME}/
-MAINTAINER= obraun@informatik.unibw-muenchen.de
+MAINTAINER= obraun@FreeBSD.org
+
+.if defined(WITHOUT_NHC98)
+FORBIDDEN= does not build with ghc-5.04 for the time being
+.endif
+
+.if defined(WITH_GHC)
+.undef WITH_GHC
+.endif
.if !defined(WITHOUT_NHC98)
BUILD_DEPENDS= nhc98:${PORTSDIR}/lang/nhc98
@@ -63,8 +71,9 @@ pre-everything::
@${ECHO_CMD} " HAT will be built and installed for ghc only."
.else
@${ECHO_CMD} " HAT will be built and installed for nhc98 only."
- @${ECHO_CMD} " Define WITH_GHC to install for ghc, too."
- @${ECHO_CMD} " Define WITHOUT_NHC98 to install for ghc only."
+# @${ECHO_CMD} " Define WITH_GHC to install for ghc, too."
+# @${ECHO_CMD} " Define WITHOUT_NHC98 to install for ghc only."
+ @${ECHO_CMD} " HAT does not build with ghc-5.04 for the time being."
.endif
@${ECHO_CMD} ""
diff --git a/devel/hs-hat/files/patch-script::harch b/devel/hs-hat/files/patch-script::harch
new file mode 100644
index 000000000000..df33c71c6959
--- /dev/null
+++ b/devel/hs-hat/files/patch-script::harch
@@ -0,0 +1,13 @@
+--- script/harch.orig Mon May 27 10:30:55 2002
++++ script/harch Mon May 27 10:31:11 2002
+@@ -13,8 +13,8 @@
+
+ if uname >/dev/null 2>&1
+ then
+- if uname -p >/dev/null 2>&1
+- then PROCESSOR=`uname -p`
++ if uname -m >/dev/null 2>&1
++ then PROCESSOR=`uname -m`
+ case "$PROCESSOR" in
+ unknown|*\ *)
+ PROCESSOR=`uname -m`