aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-hoogle
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
committerAshish SHUKLA <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
commit0c76a8384fc1de4958eb1228befbee727f00c596 (patch)
tree28680b3da252da7f45a2d25108e4e2a6e41a77e5 /devel/hs-hoogle
parentf2febc81eeab0d296325ecc49e1825762e5cd5d7 (diff)
downloadfreebsd-ports-gnome-0c76a8384fc1de4958eb1228befbee727f00c596.tar.gz
freebsd-ports-gnome-0c76a8384fc1de4958eb1228befbee727f00c596.tar.zst
freebsd-ports-gnome-0c76a8384fc1de4958eb1228befbee727f00c596.zip
- Please welcome GHC 7.0.3
GHC in the ports tree has been updated to 7.0.3 and all other Haskell ports are also updated to their corresponding Haskell Platform versions, or latest versions. We would like to acknowledge the support of the FreeBSD Donations Team and Eotvos Lorand University, Faculty of Informatics who contributed to the server that we used for testing. We would also like to thank all the testers who tested FreeBSD Haskell ports and provided their feedback. PR: ports/156642 Approved by: tabthorpe (mentor) Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-hoogle')
-rw-r--r--devel/hs-hoogle/Makefile10
-rw-r--r--devel/hs-hoogle/distinfo5
-rw-r--r--devel/hs-hoogle/files/patch-hoogle.cabal22
-rw-r--r--devel/hs-hoogle/files/patch-src__General__Web.hs11
-rw-r--r--devel/hs-hoogle/files/patch-src__Web__Server.hs11
-rw-r--r--devel/hs-hoogle/pkg-plist4
6 files changed, 52 insertions, 11 deletions
diff --git a/devel/hs-hoogle/Makefile b/devel/hs-hoogle/Makefile
index 475d35d72874..73e7a3c82e0f 100644
--- a/devel/hs-hoogle/Makefile
+++ b/devel/hs-hoogle/Makefile
@@ -6,17 +6,19 @@
#
PORTNAME= hoogle
-PORTVERSION= 4.0.7
-PORTREVISION= 1
+PORTVERSION= 4.2.1
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Haskell API Search
+LICENSE= GPLv2
+
CABAL_SETUP= Setup.hs
-USE_HACKAGE= safe uniplate
+USE_CABAL= binary blaze-builder>=0.2 cmdargs>=0.6 enumerator>=0.4 \
+ haskell-src-exts>=1.9 parsec safe tagsoup>=0.11 \
+ transformers>=0.2 uniplate>=1.6 wai>=0.3 warp>=0.3
-STANDALONE= yes
EXECUTABLE= hoogle
PORTDATA= *
diff --git a/devel/hs-hoogle/distinfo b/devel/hs-hoogle/distinfo
index 6ec5b70027f7..f539de4b20e0 100644
--- a/devel/hs-hoogle/distinfo
+++ b/devel/hs-hoogle/distinfo
@@ -1,3 +1,2 @@
-MD5 (cabal/hoogle-4.0.7.tar.gz) = 903f96c6b25796c4e7290e0c134486d1
-SHA256 (cabal/hoogle-4.0.7.tar.gz) = 3d757c4c0897deae18cc6fa1db26e27025f452f4a4f117c55c675695c424640d
-SIZE (cabal/hoogle-4.0.7.tar.gz) = 1763525
+SHA256 (cabal/hoogle-4.2.1.tar.gz) = 7bacacc4783ee4df825eaf3ce46ffcfcf5e277fc2d0969fedd5c2093ecd7808c
+SIZE (cabal/hoogle-4.2.1.tar.gz) = 107296
diff --git a/devel/hs-hoogle/files/patch-hoogle.cabal b/devel/hs-hoogle/files/patch-hoogle.cabal
new file mode 100644
index 000000000000..902a40039146
--- /dev/null
+++ b/devel/hs-hoogle/files/patch-hoogle.cabal
@@ -0,0 +1,22 @@
+--- ./hoogle.cabal.orig 2011-01-26 12:16:52.000000000 +0100
++++ ./hoogle.cabal 2011-03-13 06:06:29.686517189 +0100
+@@ -35,7 +35,7 @@
+ array, bytestring, containers, directory, filepath, process, random,
+ safe,
+ binary,
+- parsec == 2.1.*,
++ parsec,
+ transformers == 0.2.*,
+ uniplate == 1.6.*,
+ haskell-src-exts >= 1.9 && < 1.11
+@@ -108,8 +108,8 @@
+ tagsoup >= 0.11 && < 0.13,
+ enumerator == 0.4.*,
+ blaze-builder == 0.2.*,
+- wai == 0.3.0,
+- warp == 0.3.0,
++ wai == 0.3.*,
++ warp == 0.3.*,
+ Cabal >= 1.8 && < 1.11
+
+ other-modules:
diff --git a/devel/hs-hoogle/files/patch-src__General__Web.hs b/devel/hs-hoogle/files/patch-src__General__Web.hs
new file mode 100644
index 000000000000..b4a2697497f9
--- /dev/null
+++ b/devel/hs-hoogle/files/patch-src__General__Web.hs
@@ -0,0 +1,11 @@
+--- ./src/General/Web.hs.orig 2011-01-26 12:16:52.000000000 +0100
++++ ./src/General/Web.hs 2011-03-13 06:06:29.688516885 +0100
+@@ -15,7 +15,7 @@
+
+ import General.System
+ import General.Base
+-import Network.Wai
++import Network.Wai hiding(statusOK)
+ import Blaze.ByteString.Builder(toLazyByteString)
+ import Data.Enumerator.List(consume)
+ import qualified Data.ByteString.Lazy.Char8 as LBS
diff --git a/devel/hs-hoogle/files/patch-src__Web__Server.hs b/devel/hs-hoogle/files/patch-src__Web__Server.hs
new file mode 100644
index 000000000000..22ce4419a216
--- /dev/null
+++ b/devel/hs-hoogle/files/patch-src__Web__Server.hs
@@ -0,0 +1,11 @@
+--- ./src/Web/Server.hs.orig 2011-01-26 12:16:52.000000000 +0100
++++ ./src/Web/Server.hs 2011-03-13 06:06:43.636623976 +0100
+@@ -10,7 +10,7 @@
+ import General.System
+ import Control.Concurrent
+
+-import Network.Wai
++import Network.Wai hiding(statusOK)
+ import Network.Wai.Handler.Warp
+ import qualified Data.ByteString.Lazy.Char8 as LBS
+ import qualified Data.ByteString.Char8 as BS
diff --git a/devel/hs-hoogle/pkg-plist b/devel/hs-hoogle/pkg-plist
deleted file mode 100644
index e5508266df85..000000000000
--- a/devel/hs-hoogle/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-@comment $FreeBSD$
-bin/hoogle
-%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
-%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%