aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-mueval
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-04 05:53:10 +0800
committerpgj <pgj@FreeBSD.org>2012-06-04 05:53:10 +0800
commit6a485260b26868965d205d0d83ebfc80723f7627 (patch)
tree70095afedd71c8de9d1deec887807f052c93f5e2 /devel/hs-mueval
parent0e73dff368757fbb4473b320700e72ec992ce76a (diff)
downloadfreebsd-ports-gnome-6a485260b26868965d205d0d83ebfc80723f7627.tar.gz
freebsd-ports-gnome-6a485260b26868965d205d0d83ebfc80723f7627.tar.zst
freebsd-ports-gnome-6a485260b26868965d205d0d83ebfc80723f7627.zip
- Update to 0.8.2
Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-mueval')
-rw-r--r--devel/hs-mueval/Makefile3
-rw-r--r--devel/hs-mueval/distinfo4
-rw-r--r--devel/hs-mueval/files/patch-Mueval__Interpreter.hs11
-rw-r--r--devel/hs-mueval/files/patch-mueval.cabal11
-rw-r--r--devel/hs-mueval/pkg-descr24
5 files changed, 12 insertions, 41 deletions
diff --git a/devel/hs-mueval/Makefile b/devel/hs-mueval/Makefile
index 7eebdc93445f..327fa62d432e 100644
--- a/devel/hs-mueval/Makefile
+++ b/devel/hs-mueval/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= mueval
-PORTVERSION= 0.8.1
-PORTREVISION= 4
+PORTVERSION= 0.8.2
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
diff --git a/devel/hs-mueval/distinfo b/devel/hs-mueval/distinfo
index 4645993df23e..a0d1ae7ba25b 100644
--- a/devel/hs-mueval/distinfo
+++ b/devel/hs-mueval/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cabal/mueval-0.8.1.tar.gz) = 41c6ab1d0f406106061322ae98aecc8bd650b2c41ae1a32abdbaad00513646a5
-SIZE (cabal/mueval-0.8.1.tar.gz) = 14744
+SHA256 (cabal/mueval-0.8.2.tar.gz) = b8e515cbe56a0c64f1768420d621704ad16f4ede3046ef124e12545d3e684dab
+SIZE (cabal/mueval-0.8.2.tar.gz) = 14906
diff --git a/devel/hs-mueval/files/patch-Mueval__Interpreter.hs b/devel/hs-mueval/files/patch-Mueval__Interpreter.hs
deleted file mode 100644
index 45f0a82a44a9..000000000000
--- a/devel/hs-mueval/files/patch-Mueval__Interpreter.hs
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Mueval/Interpreter.hs.orig 2011-01-11 21:24:11.000000000 +0100
-+++ ./Mueval/Interpreter.hs 2011-03-13 14:28:39.132489232 +0100
-@@ -120,7 +120,7 @@
- exceptionMsg = "*Exception: "
-
- -- | Renders the input String including its exceptions using @exceptionMsg@
--render :: (Control.Monad.Trans.MonadIO m)
-+render :: (Functor m, Control.Monad.Trans.MonadIO m)
- => Int -- ^ max number of characters to include
- -> String -- ^ input
- -> m (String, Bool) -- ^ ( output, @True@ if we found an exception )
diff --git a/devel/hs-mueval/files/patch-mueval.cabal b/devel/hs-mueval/files/patch-mueval.cabal
deleted file mode 100644
index 50590a6efa02..000000000000
--- a/devel/hs-mueval/files/patch-mueval.cabal
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./mueval.cabal.orig 2011-01-11 21:24:11.000000000 +0100
-+++ ./mueval.cabal 2011-03-13 14:27:32.901910764 +0100
-@@ -31,7 +31,7 @@
- library
- exposed-modules: Mueval.Parallel, Mueval.Context, Mueval.Interpreter,
- Mueval.ArgsParse, Mueval.Resources
-- build-depends: base>=4 && < 5, containers, directory, mtl<1.2, filepath, unix, process,
-+ build-depends: base>=4 && < 5, containers, directory, mtl, filepath, unix, process,
- hint>=0.3.1, show>=0.3, utf8-string, Cabal, extensible-exceptions
- ghc-options: -Wall -static -O2
-
diff --git a/devel/hs-mueval/pkg-descr b/devel/hs-mueval/pkg-descr
index 0733f6109464..60bbcf5eadde 100644
--- a/devel/hs-mueval/pkg-descr
+++ b/devel/hs-mueval/pkg-descr
@@ -1,15 +1,9 @@
-Mueval is a Haskell interpreter. It uses the GHC API to evaluate
-arbitrary Haskell expressions.
-
-Importantly, mueval takes many precautions to defang and avoid
-"evil" code. It uses resource limits, whitelisted modules, special
-Show instances for IO, threads, processes, changes of directory, and
-so on to sandbox the Haskell code.
-
-It is, in short, intended to be a standalone version of Lambdabot's
-famous evaluation functionality. For examples and explanations, please
-see the README file.
-
-Mueval is POSIX-only.
-
-WWW: http://code.haskell.org/mubot/
+Mueval is a Haskell interpreter. It uses the GHC API to evaluate arbitrary
+Haskell expressions. Importantly, mueval takes many precautions to defang
+and avoid "evil" code. It uses resource limits, whitelisted modules,
+special Show instances for IO, threads, processes, changes of directory,
+and so on to sandbox the Haskell code. It is, in short, intended to be a
+standalone version of Lambdabot's famous evaluation functionality. For
+examples and explanations, please see the README file. Mueval is POSIX-only.
+
+WWW: http://code.haskell.org/mubot/