aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-system-fileio
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2012-06-24 17:53:26 +0800
committerpgj <pgj@FreeBSD.org>2012-06-24 17:53:26 +0800
commita87262d2254c435fb78b4ec99c46a59fdb7db0c7 (patch)
treea84853fe238bec4a12094e000060f8635ed421ce /devel/hs-system-fileio
parentf4e4a75573fa88bdbce7bfe63d6662d2767954c7 (diff)
downloadfreebsd-ports-gnome-a87262d2254c435fb78b4ec99c46a59fdb7db0c7.tar.gz
freebsd-ports-gnome-a87262d2254c435fb78b4ec99c46a59fdb7db0c7.tar.zst
freebsd-ports-gnome-a87262d2254c435fb78b4ec99c46a59fdb7db0c7.zip
This is a small wrapper around the "directory", "unix", and "Win32"
packages, for use with "system-filepath". It provides a consistent API to the various versions of these packages distributed with different versions of GHC. In particular, this library supports working with POSIX files that have paths which can't be decoded in the current locale encoding. WWW: https://john-millikin.com/software/haskell-filesystem/ Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-system-fileio')
-rw-r--r--devel/hs-system-fileio/Makefile23
-rw-r--r--devel/hs-system-fileio/distinfo2
-rw-r--r--devel/hs-system-fileio/pkg-descr8
3 files changed, 33 insertions, 0 deletions
diff --git a/devel/hs-system-fileio/Makefile b/devel/hs-system-fileio/Makefile
new file mode 100644
index 000000000000..27b89aed3840
--- /dev/null
+++ b/devel/hs-system-fileio/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: hs-system-fileio
+# Date created: June 10, 2012
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= system-fileio
+PORTVERSION= 0.3.7
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Consistent filesystem interaction across GHC versions
+
+LICENSE= MIT
+FILE_LICENSE= license.txt
+
+CABAL_SETUP= Setup.hs
+
+USE_CABAL= system-filepath>=0.3.1 text>=0.7.1
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-system-fileio/distinfo b/devel/hs-system-fileio/distinfo
new file mode 100644
index 000000000000..a9f36e9fc44e
--- /dev/null
+++ b/devel/hs-system-fileio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/system-fileio-0.3.7.tar.gz) = 207afc466175b5a546950d44e3c295594b60e6e5e38ee7b4564203ec86bd526e
+SIZE (cabal/system-fileio-0.3.7.tar.gz) = 14845
diff --git a/devel/hs-system-fileio/pkg-descr b/devel/hs-system-fileio/pkg-descr
new file mode 100644
index 000000000000..3d14d899d707
--- /dev/null
+++ b/devel/hs-system-fileio/pkg-descr
@@ -0,0 +1,8 @@
+This is a small wrapper around the "directory", "unix", and "Win32"
+packages, for use with "system-filepath". It provides a consistent API
+to the various versions of these packages distributed with different
+versions of GHC. In particular, this library supports working with
+POSIX files that have paths which can't be decoded in the current locale
+encoding.
+
+WWW: https://john-millikin.com/software/haskell-filesystem/