aboutsummaryrefslogtreecommitdiffstats
path: root/devel/hs-vector-algorithms
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
committerashish <ashish@FreeBSD.org>2011-05-09 13:28:57 +0800
commitc7a47a981222b062ac48e4edc5cae32fbed2b9c7 (patch)
treea1af1f5739f0a44d179f6f44b2ea70e07401da25 /devel/hs-vector-algorithms
parent63b87600f00dd6e3a998a1862f7c209aa5e62523 (diff)
downloadfreebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.tar.gz
freebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.tar.zst
freebsd-ports-gnome-c7a47a981222b062ac48e4edc5cae32fbed2b9c7.zip
- Please welcome GHC 7.0.3
GHC in the ports tree has been updated to 7.0.3 and all other Haskell ports are also updated to their corresponding Haskell Platform versions, or latest versions. We would like to acknowledge the support of the FreeBSD Donations Team and Eotvos Lorand University, Faculty of Informatics who contributed to the server that we used for testing. We would also like to thank all the testers who tested FreeBSD Haskell ports and provided their feedback. PR: ports/156642 Approved by: tabthorpe (mentor) Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel/hs-vector-algorithms')
-rw-r--r--devel/hs-vector-algorithms/Makefile6
-rw-r--r--devel/hs-vector-algorithms/distinfo5
-rw-r--r--devel/hs-vector-algorithms/pkg-plist26
3 files changed, 6 insertions, 31 deletions
diff --git a/devel/hs-vector-algorithms/Makefile b/devel/hs-vector-algorithms/Makefile
index 0c6fae6db97e..0848ffb4d23f 100644
--- a/devel/hs-vector-algorithms/Makefile
+++ b/devel/hs-vector-algorithms/Makefile
@@ -6,13 +6,15 @@
#
PORTNAME= vector-algorithms
-PORTVERSION= 0.3.2
+PORTVERSION= 0.4
CATEGORIES= devel haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Efficient algorithms for vector arrays
-USE_HACKAGE= primitive>=0.2 vector>=0.5
+LICENSE= BSD
+
+USE_CABAL= primitive>=0.3 vector>=0.6
.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
.include <bsd.port.mk>
diff --git a/devel/hs-vector-algorithms/distinfo b/devel/hs-vector-algorithms/distinfo
index 66ac173fef17..c50ab4ac9732 100644
--- a/devel/hs-vector-algorithms/distinfo
+++ b/devel/hs-vector-algorithms/distinfo
@@ -1,3 +1,2 @@
-MD5 (cabal/vector-algorithms-0.3.2.tar.gz) = 47b39bda964ac39b380e6d7a73a24302
-SHA256 (cabal/vector-algorithms-0.3.2.tar.gz) = ac9e6c125d8e56f8d5c22bb593d93f23a97993e62ca915dc8019dacda0bcafe3
-SIZE (cabal/vector-algorithms-0.3.2.tar.gz) = 19361
+SHA256 (cabal/vector-algorithms-0.4.tar.gz) = 080a410c608e1c6fbb9b80a4ca330c6d0cafd39dc896cf20af82d437fa122f12
+SIZE (cabal/vector-algorithms-0.4.tar.gz) = 19882
diff --git a/devel/hs-vector-algorithms/pkg-plist b/devel/hs-vector-algorithms/pkg-plist
deleted file mode 100644
index 06bb9603059c..000000000000
--- a/devel/hs-vector-algorithms/pkg-plist
+++ /dev/null
@@ -1,26 +0,0 @@
-@comment $FreeBSD$
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/include/vector.h
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Combinators.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Common.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Insertion.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Intro.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Merge.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Optimal.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Radix.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/Search.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms/TriHeap.hi
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/HS%%PORTNAME%%-%%PORTVERSION%%.o
-%%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/libHS%%PORTNAME%%-%%PORTVERSION%%.a
-%%LIBDIR_REL%%/register.sh
-%%NOPORTDOCS%%%%DOCSDIR%%/LICENSE
-%%NOPORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector/Algorithms
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data/Vector
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/Data
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%/include
-@dirrm %%LIBDIR_REL%%/ghc-%%GHC_VERSION%%
-@dirrm %%LIBDIR_REL%%
-@exec /bin/sh %D/%%LIBDIR_REL%%/register.sh
-@exec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old
-@unexec %D/bin/ghc-pkg unregister %%PORTNAME%%-%%PORTVERSION%%
-@unexec /bin/rm -f %D/lib/ghc-%%GHC_VERSION%%/package.conf.old