aboutsummaryrefslogtreecommitdiffstats
path: root/devel/imake
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2011-12-03 00:04:12 +0800
committerdinoex <dinoex@FreeBSD.org>2011-12-03 00:04:12 +0800
commitca83fa57f796d45b7a1f0eca1ead7b3d67b2d6e8 (patch)
tree96eeaf9d9cc14bdb67ca6894ebaa10b010c3c20b /devel/imake
parent5863e8cc3de43c73061e57b6b0bbb26805546c91 (diff)
downloadfreebsd-ports-gnome-ca83fa57f796d45b7a1f0eca1ead7b3d67b2d6e8.tar.gz
freebsd-ports-gnome-ca83fa57f796d45b7a1f0eca1ead7b3d67b2d6e8.tar.zst
freebsd-ports-gnome-ca83fa57f796d45b7a1f0eca1ead7b3d67b2d6e8.zip
- fix scripts when build with clang
Approved by: eadler Obtained from: NetBSD Feature safe: yes
Diffstat (limited to 'devel/imake')
-rw-r--r--devel/imake/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/devel/imake/Makefile b/devel/imake/Makefile
index fa9ac23f4f43..d4d95da49a57 100644
--- a/devel/imake/Makefile
+++ b/devel/imake/Makefile
@@ -39,4 +39,16 @@ MAN1= ccmakedep.1 \
post-patch:
@${PERL} -pi -e 's,^#!/usr/bin/perl,#!${PERL},' ${WRKSRC}/mkhtmlindex.pl
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
+# which is fatal for imake.
+.if defined(CC) && ${CC} == "clang"
+RUN_DEPENDS+= ucpp:{PORTSDIR}/devel/ucpp
+CONFIGURE_ENV+= ac_cv_path_RAWCPP="ucpp -s"
+
+post-build:
+ ${REINPLACE_CMD} -e 's|^configdirspec= *|configdirspec=|' ${WRKSRC}/xmkmf
+.endif
+
+.include <bsd.port.post.mk>