aboutsummaryrefslogtreecommitdiffstats
path: root/devel/jna
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2013-10-05 19:34:59 +0800
committerolgeni <olgeni@FreeBSD.org>2013-10-05 19:34:59 +0800
commit3df182248292c6d2981c0f97872835779d8a3f42 (patch)
treedca3aa90ab0046ace2311fac79582eebd3d74686 /devel/jna
parentbf9b7c5dfc065616f1c84e97103d1ca2167590c0 (diff)
downloadfreebsd-ports-gnome-3df182248292c6d2981c0f97872835779d8a3f42.tar.gz
freebsd-ports-gnome-3df182248292c6d2981c0f97872835779d8a3f42.tar.zst
freebsd-ports-gnome-3df182248292c6d2981c0f97872835779d8a3f42.zip
Fix loading of libc.so after r251668 ("turn libc.so into an ld script.")
Submitted by: jkim
Diffstat (limited to 'devel/jna')
-rw-r--r--devel/jna/Makefile1
-rw-r--r--devel/jna/files/patch-src__com__sun__jna__NativeLibrary.java29
2 files changed, 30 insertions, 0 deletions
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index 00cf14449a35..336c1076b60c 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -2,6 +2,7 @@
PORTNAME= jna
PORTVERSION= 4.0
+PORTREVISION= 1
CATEGORIES= devel java
MASTER_SITES= GH
diff --git a/devel/jna/files/patch-src__com__sun__jna__NativeLibrary.java b/devel/jna/files/patch-src__com__sun__jna__NativeLibrary.java
new file mode 100644
index 000000000000..ceff137a216c
--- /dev/null
+++ b/devel/jna/files/patch-src__com__sun__jna__NativeLibrary.java
@@ -0,0 +1,29 @@
+--- src/com/sun/jna/NativeLibrary.java.orig 2013-07-04 14:42:30.000000000 -0400
++++ src/com/sun/jna/NativeLibrary.java 2013-10-04 17:28:07.000000000 -0400
+@@ -203,7 +203,7 @@
+ }
+ catch(UnsatisfiedLinkError e2) { e = e2; }
+ }
+- else if (Platform.isLinux()) {
++ else if (Platform.isLinux() || Platform.isFreeBSD()) {
+ //
+ // Failed to load the library normally - try to match libfoo.so.*
+ //
+@@ -382,7 +382,7 @@
+
+ // Use current process to load libraries we know are already
+ // loaded by the VM to ensure we get the correct version
+- if ((Platform.isLinux() || Platform.isAIX())
++ if ((Platform.isLinux() || Platform.isFreeBSD() || Platform.isAIX())
+ && Platform.C_LIBRARY_NAME.equals(libraryName)) {
+ libraryName = null;
+ }
+@@ -702,7 +702,7 @@
+ }
+ return name;
+ }
+- else if (Platform.isLinux()) {
++ else if (Platform.isLinux() || Platform.isFreeBSD()) {
+ if (isVersionedName(libName) || libName.endsWith(".so")) {
+ // A specific version was requested - use as is for search
+ return libName;