aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kdesdk4
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
committermakc <makc@FreeBSD.org>2013-03-22 22:18:02 +0800
commitcdb81da9cb2b58e688594b552337d1c9bfc47e96 (patch)
treeda82a32e8ce2ded995ae7ba320231491c35220ac /devel/kdesdk4
parent904fc890d1dc712abfaeaddde7864519df50915c (diff)
downloadfreebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.gz
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.tar.zst
freebsd-ports-gnome-cdb81da9cb2b58e688594b552337d1c9bfc47e96.zip
Mk/bsd.kde4.mk:
- Don't set CMAKE_BUILD_TYPE for debug builds (cmake.mk already handles it) - Don't set WITH_DEBUG for unstable branch (KDE4_BRANCH) - Remove now useless KDE4_BUILDENV KDE SC ports: - Chase KDE4_BUILDENV removal: replace 'KDE4_BUILDENV= yes' with 'USES= cmake:outsource' and add USE_LDCONFIG if needed
Diffstat (limited to 'devel/kdesdk4')
-rw-r--r--devel/kdesdk4/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/devel/kdesdk4/Makefile b/devel/kdesdk4/Makefile
index 5e9c983a9e4f..3b6546694845 100644
--- a/devel/kdesdk4/Makefile
+++ b/devel/kdesdk4/Makefile
@@ -26,12 +26,13 @@ USE_XZ= yes
USE_GNOME= libxml2 libxslt
USE_KDE4= kdehier kdelibs kdeprefix libkonq pimlibs sharedmime \
akonadi automoc4 qimageblitz_build strigi
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_PERL5= yes
USE_QT4= dbus designer gui qt3support \
script scripttools sql svg xml \
qmake_build moc_build rcc_build uic_build uic3_build
USE_GMAKE= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
CMAKE_ARGS+= -DCMAKE_REQUIRED_INCLUDES:STRING="${LOCALBASE}/include"