aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kdesdk
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-01-11 14:17:04 +0800
committerwill <will@FreeBSD.org>2002-01-11 14:17:04 +0800
commit5edfd4ef75e361115ce9d12b911ba357a816b0cf (patch)
treeefda22b51aaeafff725beac075dd2b198e154b85 /devel/kdesdk
parentb8330606cf2bc2e9a56f78cbd9128728df91a0d0 (diff)
downloadfreebsd-ports-gnome-5edfd4ef75e361115ce9d12b911ba357a816b0cf.tar.gz
freebsd-ports-gnome-5edfd4ef75e361115ce9d12b911ba357a816b0cf.tar.zst
freebsd-ports-gnome-5edfd4ef75e361115ce9d12b911ba357a816b0cf.zip
Bring in a few changes to the KDE ports infrastructure, and some fixes.
- Move all stuff specific to kde core ports to x11/kde2/Makefile.kde. + Default to compile optimized for speed, not debugging, in ports builds, not just packages. We don't really get that many backtraces or debugging information, and there's a better way to provide these things to people willing to spend some time working on KDE. It's at (as announced before): http://freebsd.kde.org/. - Remove teTeX dependency for kdegraphics2 upon request, and being unable to find any reason not to. Apparently, kdegraphics still compiles libkdvi and kdvi -- I guess dvips is merely a runtime dependency. Therefore to enable its use one just needs to add the teTeX package. Bump PORTREVISION to reflect dependency change. - Fix koffice port by removing PYTHON_VERSION, which is unnecessary. PR: 33650 (part of) Submitted by: John Merryweather Cooper <jmcoopr@johncoop.MSHOME.bmi.net> Reviewed by: kde-freebsd@lists.csociety.org (teTeX dep removal, and optimizing for speed, not debugging capability)
Diffstat (limited to 'devel/kdesdk')
-rw-r--r--devel/kdesdk/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/devel/kdesdk/Makefile b/devel/kdesdk/Makefile
index c868afb51829..a9785ad8cca5 100644
--- a/devel/kdesdk/Makefile
+++ b/devel/kdesdk/Makefile
@@ -16,27 +16,14 @@ MAINTAINER= kde@FreeBSD.org
BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
automake14:${PORTSDIR}/devel/automake14
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-BUILD_DEPENDS+= objprelink:${PORTSDIR}/devel/objprelink
-.endif
LIB_DEPENDS= db2.0:${PORTSDIR}/databases/db
USE_KDEBASE_VER=2
USE_BZIP2= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS?=
-.if ${MACHINE_ARCH} == "i386" && !defined(NO_KDE_OBJPRELINK)
-CONFIGURE_ARGS+=--enable-objprelink
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_FINAL)
-CONFIGURE_ARGS+=--enable-final
-.endif
-.if defined(PARALLEL_PACKAGE_BUILD) || defined(WANT_KDE_NDEBUG)
-CONFIGURE_ARGS+=--disable-debug
-.else
-CONFIGURE_ARGS+=--enable-debug
-STRIP=''
-.endif
+
+.include "${.CURDIR}/../../x11/kde2/Makefile.kde"
+
USE_GMAKE= yes
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= %%PREFIX%%/lib %%PREFIX%%/lib/kde2