aboutsummaryrefslogtreecommitdiffstats
path: root/devel/kyua
diff options
context:
space:
mode:
authorJulio Merino <jmmv@FreeBSD.org>2014-01-25 03:46:56 +0800
committerJulio Merino <jmmv@FreeBSD.org>2014-01-25 03:46:56 +0800
commit9ab656e6034fdea75c60c70ecd3820e0e8eb436b (patch)
tree325a3f721a93b700567c20bf7822e8ba1298fc41 /devel/kyua
parentacbb962c29793ffa927ff78ec1a58995b73b4559 (diff)
downloadfreebsd-ports-gnome-9ab656e6034fdea75c60c70ecd3820e0e8eb436b.tar.gz
freebsd-ports-gnome-9ab656e6034fdea75c60c70ecd3820e0e8eb436b.tar.zst
freebsd-ports-gnome-9ab656e6034fdea75c60c70ecd3820e0e8eb436b.zip
Add staging support to kyua* and lutok.
While doing this, consolidate file handling into pkg-plist (instead of the previous split between the Makefile and the pkg-plist) for simplicity. Reviewed by: asomers (ex-maintainer) Approved by: bdrewery (ports)
Diffstat (limited to 'devel/kyua')
-rw-r--r--devel/kyua/Makefile17
-rw-r--r--devel/kyua/pkg-plist36
2 files changed, 39 insertions, 14 deletions
diff --git a/devel/kyua/Makefile b/devel/kyua/Makefile
index 7bd21a382c85..a21894fc926b 100644
--- a/devel/kyua/Makefile
+++ b/devel/kyua/Makefile
@@ -28,13 +28,13 @@ SUB_FILES= kyua.conf
SUB_LIST= TESTS_USER=${TESTS_USER}
OPTIONS_DEFINE= DOCS EXAMPLES
-NO_STAGE= yes
.include <bsd.port.options.mk>
CONFIGURE_ARGS+= --without-doxygen
CONFIGURE_ARGS+= --docdir=${DOCSDIR}
# TODO: install the tests, once FreeBSD has a system for ports to install tests
CONFIGURE_ARGS+= --without-atf
+MAKE_FLAGS+= examplesdir=${EXAMPLESDIR}
MAKE_FLAGS+= pkgdatadir=${DATADIR}
.if ! ${PORT_OPTIONS:MDOCS}
@@ -43,20 +43,9 @@ MAKE_FLAGS+= doc_DATA=
.if ! ${PORT_OPTIONS:MEXAMPLES}
MAKE_FLAGS+= dist_examples_DATA=
.endif
-PLIST_FILES= bin/kyua
-PLIST_DIRS= etc/kyua
-PLIST_FILES+= etc/kyua/kyua.conf
-
-PORTDATA= misc store examples
-PORTDOCS= AUTHORS COPYING NEWS README
-MAN1= kyua-about.1 kyua-config.1 kyua-db-exec.1 kyua-db-migrate.1
-MAN1+= kyua-debug.1 kyua-help.1 kyua-list.1 kyua-report-html.1
-MAN1+= kyua-report.1 kyua-test.1 kyua.1
-MAN5= kyua.conf.5 kyuafile.5
-MAN7= kyua-build-root.7 kyua-test-filters.7
post-install:
- ${MKDIR} ${PREFIX}/etc/kyua/
- ${INSTALL_DATA} ${WRKDIR}/kyua.conf ${PREFIX}/etc/kyua/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/kyua/
+ ${INSTALL_DATA} ${WRKDIR}/kyua.conf ${STAGEDIR}${PREFIX}/etc/kyua/
.include <bsd.port.mk>
diff --git a/devel/kyua/pkg-plist b/devel/kyua/pkg-plist
new file mode 100644
index 000000000000..1898b1bdaebe
--- /dev/null
+++ b/devel/kyua/pkg-plist
@@ -0,0 +1,36 @@
+@comment $FreeBSD$
+bin/kyua
+etc/kyua/kyua.conf
+man/man1/kyua-about.1.gz
+man/man1/kyua-config.1.gz
+man/man1/kyua-db-exec.1.gz
+man/man1/kyua-db-migrate.1.gz
+man/man1/kyua-debug.1.gz
+man/man1/kyua-help.1.gz
+man/man1/kyua-list.1.gz
+man/man1/kyua-report-html.1.gz
+man/man1/kyua-report.1.gz
+man/man1/kyua-test.1.gz
+man/man1/kyua.1.gz
+man/man5/kyua.conf.5.gz
+man/man5/kyuafile.5.gz
+man/man7/kyua-build-root.7.gz
+man/man7/kyua-test-filters.7.gz
+%%DATADIR%%/misc/context.html
+%%DATADIR%%/misc/index.html
+%%DATADIR%%/misc/report.css
+%%DATADIR%%/misc/test_result.html
+%%DATADIR%%/store/migrate_v1_v2.sql
+%%DATADIR%%/store/schema_v2.sql
+%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/NEWS
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Kyuafile.top
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/kyua.conf
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%/store
+@dirrm %%DATADIR%%/misc
+@dirrm %%DATADIR%%
+@dirrm etc/kyua