aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libcii
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-11-23 05:24:55 +0800
committershaun <shaun@FreeBSD.org>2006-11-23 05:24:55 +0800
commite761d407da1ac27e524e6620f42b762210fc23b4 (patch)
tree1402f7a776959304c5f9c7b69c297e2da1f1dd93 /devel/libcii
parent105ba17a7c4ef3a1eb30ffb7c8c40bcf122c4420 (diff)
downloadfreebsd-ports-gnome-e761d407da1ac27e524e6620f42b762210fc23b4.tar.gz
freebsd-ports-gnome-e761d407da1ac27e524e6620f42b762210fc23b4.tar.zst
freebsd-ports-gnome-e761d407da1ac27e524e6620f42b762210fc23b4.zip
Fix build on !i386.
Diffstat (limited to 'devel/libcii')
-rw-r--r--devel/libcii/Makefile25
-rw-r--r--devel/libcii/pkg-plist6
2 files changed, 24 insertions, 7 deletions
diff --git a/devel/libcii/Makefile b/devel/libcii/Makefile
index 167ceac0408a..7b7027ae69fa 100644
--- a/devel/libcii/Makefile
+++ b/devel/libcii/Makefile
@@ -17,7 +17,7 @@ COMMENT= Library from "C Interfaces and Implementations" by David Hanson
NO_WRKSUBDIR= yes
MAKEFILE= makefile
-MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DMAXALIGH=8 -Iinclude" \
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -DMAXALIGN=8 -Iinclude" \
AS="${CC} -c -x assembler-with-cpp -traditional" \
LD="${CC}" LDFLAGS="" EXTRAS="" BUILDDIR=${PKGNAME}
PLIST_SUB= CIIMAJOR="${CIIMAJOR}"
@@ -27,12 +27,24 @@ CIIMAJOR= 1
CIIDEST= ${PREFIX}/lib/cii
SAMPLES= double calc ids mpcalc wf xref cref iref kref \
- idents words basename dirname sort spin sieve
+ idents words basename dirname
+I386_SAMPLES= sort spin sieve
.include <bsd.port.pre.mk>
-.if ${ARCH} != "i386" && ${ARCH} != "alpha"
-BROKEN= "Does not compile on !i386 and !alpha"
+.if ${ARCH} != "i386"
+MAKE_ARGS+= "THREADS="
+PLIST_SUB+= NOTI386="@comment "
+.else
+PLIST_SUB+= NOTI386=""
+.endif
+
+post-patch:
+.if ${ARCH} != "i386"
+. for i in ${I386_SAMPLES}
+ @${REINPLACE_CMD} -e 's/^ *\$$B${i}\$$E *\\\{0,1\}//' \
+ ${WRKSRC}/makefile
+. endfor
.endif
pre-build:
@@ -61,6 +73,11 @@ do-install:
.for a in ${SAMPLES}
${INSTALL_PROGRAM} ${CIIBUILD}/${a} ${CIIDEST}/${CIIMAJOR}/examples
.endfor
+.if ${ARCH} == "i386"
+. for a in ${I386_SAMPLES}
+ ${INSTALL_PROGRAM} ${CIIBUILD}/${a} ${CIIDEST}/${CIIMAJOR}/examples
+. endfor
+.endif
##
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/cii
diff --git a/devel/libcii/pkg-plist b/devel/libcii/pkg-plist
index f06df5abdce4..e0a1bff7d552 100644
--- a/devel/libcii/pkg-plist
+++ b/devel/libcii/pkg-plist
@@ -11,9 +11,9 @@ lib/cii/%%CIIMAJOR%%/examples/idents
lib/cii/%%CIIMAJOR%%/examples/words
lib/cii/%%CIIMAJOR%%/examples/basename
lib/cii/%%CIIMAJOR%%/examples/dirname
-lib/cii/%%CIIMAJOR%%/examples/sort
-lib/cii/%%CIIMAJOR%%/examples/spin
-lib/cii/%%CIIMAJOR%%/examples/sieve
+%%NOTI386%%lib/cii/%%CIIMAJOR%%/examples/sort
+%%NOTI386%%lib/cii/%%CIIMAJOR%%/examples/spin
+%%NOTI386%%lib/cii/%%CIIMAJOR%%/examples/sieve
lib/cii/%%CIIMAJOR%%/include/ap.h
lib/cii/%%CIIMAJOR%%/include/arena.h
lib/cii/%%CIIMAJOR%%/include/arith.h