aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdbusmenu-qt
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2018-12-17 00:49:17 +0800
committerrene <rene@FreeBSD.org>2018-12-17 00:49:17 +0800
commit4909b0f811cf5ad505666da55a2655041c78e236 (patch)
tree892baa84cc0c67b08795b6576e985d83e5a8f6d1 /devel/libdbusmenu-qt
parent0a0c9722087f1a9b6e1d4506eed21bd6d9b3bcb5 (diff)
downloadfreebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.tar.gz
freebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.tar.zst
freebsd-ports-gnome-4909b0f811cf5ad505666da55a2655041c78e236.zip
Use regular DEPRECATED and EXPIRATION_DATE variables in an "if FLAVOR" block
instead of flavoring the variables themselves. This caused too much hassle for Tools/scripts/rmport. Discussed with: tcberner
Diffstat (limited to 'devel/libdbusmenu-qt')
-rw-r--r--devel/libdbusmenu-qt/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/libdbusmenu-qt/Makefile b/devel/libdbusmenu-qt/Makefile
index e5a090ef3126..7dee2aa9964b 100644
--- a/devel/libdbusmenu-qt/Makefile
+++ b/devel/libdbusmenu-qt/Makefile
@@ -18,13 +18,12 @@ LICENSE= LGPL20
FLAVORS= qt5 qt4
FLAVOR?= ${FLAVORS:[1]}
-qt4_DEPRECATED= Qt4 has been EOL since december 2015
-qt4_EXPIRATION_DATE= 2019-03-15
-
USES= compiler:c++11-lib cmake:outsource
USE_LDCONFIG= yes
. if ${FLAVOR} == qt4
+DEPRECATED= Qt4 has been EOL since december 2015
+EXPIRATION_DATE=2019-03-15
USES+= qt:4
USE_QT= corelib dbus gui \
moc_build qmake_build rcc_build uic_build