aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libdsp
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-08-31 16:55:42 +0800
committerchinsan <chinsan@FreeBSD.org>2008-08-31 16:55:42 +0800
commita122d9b36a115582348e89884c8cedb1dcb6a1c6 (patch)
tree6300c2aa46e2f3955ea1eaf58e87dc3a0b0e2f13 /devel/libdsp
parent3b233fe329e043eb3ece6cb2da3eb64c19569406 (diff)
downloadfreebsd-ports-gnome-a122d9b36a115582348e89884c8cedb1dcb6a1c6.tar.gz
freebsd-ports-gnome-a122d9b36a115582348e89884c8cedb1dcb6a1c6.tar.zst
freebsd-ports-gnome-a122d9b36a115582348e89884c8cedb1dcb6a1c6.zip
- Update to 5.0.0
Diffstat (limited to 'devel/libdsp')
-rw-r--r--devel/libdsp/Makefile12
-rw-r--r--devel/libdsp/distinfo6
-rw-r--r--devel/libdsp/files/patch-Makefile.BSD (renamed from devel/libdsp/files/patch-Makefile.FreeBSD)25
-rw-r--r--devel/libdsp/pkg-plist9
4 files changed, 23 insertions, 29 deletions
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 96fcf3561d81..0ece54d0bf1f 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -7,25 +7,23 @@
#
PORTNAME= libdsp
-PORTVERSION= 4.6.0
-PORTREVISION= 2
+PORTVERSION= 5.0.0
CATEGORIES= devel audio
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ class library of common digital signal processing functions
-WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
+WRKSRC= ${WRKDIR}/libdsp-src-${PORTVERSION}/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
USE_AUTOTOOLS= libtool:15:env
USE_GMAKE= yes
MAKE_ENV= MKDIR="${MKDIR}" INLINE_VER="${INLINE_VER}"
-MAKEFILE= Makefile.FreeBSD
+MAKEFILE= Makefile.BSD
USE_LDCONFIG= yes
-INLINE_VER= 1.2.5
+INLINE_VER= 1.2.8
do-configure:
@${DO_NADA}
diff --git a/devel/libdsp/distinfo b/devel/libdsp/distinfo
index 7c26d6c03d47..4d56611814d6 100644
--- a/devel/libdsp/distinfo
+++ b/devel/libdsp/distinfo
@@ -1,3 +1,3 @@
-MD5 (libdsp-src-4.6.0.tar.gz) = a3cd88faaf307aa9b727a4cbbf39a151
-SHA256 (libdsp-src-4.6.0.tar.gz) = 1244aa2611dda799b42414e55ce7d90c8f78cfff01ac348670c3fe53a3b5fbbe
-SIZE (libdsp-src-4.6.0.tar.gz) = 340653
+MD5 (libdsp-src-5.0.0.tar.gz) = 5fd3eae3e8637ec0ee3b833549cd27e9
+SHA256 (libdsp-src-5.0.0.tar.gz) = 1d5e32ff9be98160f71453b2b18b2d44e5a7ea22e376b95be59f420c141d1662
+SIZE (libdsp-src-5.0.0.tar.gz) = 219755
diff --git a/devel/libdsp/files/patch-Makefile.FreeBSD b/devel/libdsp/files/patch-Makefile.BSD
index 1733140d6251..0bdc098c9a3c 100644
--- a/devel/libdsp/files/patch-Makefile.FreeBSD
+++ b/devel/libdsp/files/patch-Makefile.BSD
@@ -1,5 +1,5 @@
---- Makefile.FreeBSD.bak Mon Jun 16 23:46:56 2003
-+++ Makefile.FreeBSD Tue Jun 17 07:59:44 2003
+--- Makefile.BSD.orig 2008-08-31 16:19:03.000000000 +0800
++++ Makefile.BSD 2008-08-31 16:22:54.000000000 +0800
@@ -17,15 +17,8 @@
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
#
@@ -17,7 +17,7 @@
# BSD system
DEFS += -DBSDSYS
# define if your compiler/c-library is ISO C 9x standard compliant
-@@ -37,15 +30,15 @@
+@@ -35,15 +28,14 @@
# x86 architecture specific optimizations
#DEFS += -DDSP_X86
@@ -25,7 +25,6 @@
+INCS = -I. -I../Inlines-${INLINE_VER}
-LDFLAGS = -pthread #-g
-+#LDFLAGS = -pthread #-g
LIBS = -lm #-ldrfftw -ldfftw
@@ -34,9 +33,9 @@
-PREFIX = /usr/local
+PREFIX ?= /usr/local
- VERSION = 5:0:4
+ VERSION = 9:0:8
-@@ -143,35 +136,35 @@
+@@ -137,34 +129,34 @@
$(LIBTOOL) --mode=link $(CXX) $(LDFLAGS) -rpath $(PREFIX)/lib -version-info $(VERSION) -o libdsp.la $(LOBJS) $(LIBS)
install: libdsp.la
@@ -44,25 +43,24 @@
- install -m 644 dsp/DSPConfig.hh $(PREFIX)/include/dsp
- install -m 644 dsp/DSPOp.hh $(PREFIX)/include/dsp
- install -m 644 dsp/DSPVector.hh $(PREFIX)/include/dsp
-- install -m 644 dsp/Decimator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FFTDecimator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FFTInterpolator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FFTMultiRate.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Filter.hh $(PREFIX)/include/dsp
-- install -m 644 dsp/Filter2.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FIRDecimator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FIRInterpolator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/FIRMultiRate.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/FlipBand.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Hankel.hh $(PREFIX)/include/dsp
- install -m 644 dsp/IIRCascade.hh $(PREFIX)/include/dsp
- install -m 644 dsp/IIRDecimator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/IIRInterpolator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/IIRMultiRate.hh $(PREFIX)/include/dsp
- install -m 644 dsp/ReBuffer.hh $(PREFIX)/include/dsp
-- install -m 644 dsp/ReBuffer2.hh $(PREFIX)/include/dsp
-- install -m 644 dsp/ReBuffer3.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/ReBufferT.hh $(PREFIX)/include/dsp
- install -m 644 dsp/RecDecimator.hh $(PREFIX)/include/dsp
- install -m 644 dsp/RecInterpolator.hh $(PREFIX)/include/dsp
+- install -m 644 dsp/RingBuffer.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Transform4.hh $(PREFIX)/include/dsp
- install -m 644 dsp/Transform8.hh $(PREFIX)/include/dsp
- install -m 644 dsp/TransformS.hh $(PREFIX)/include/dsp
@@ -73,25 +71,24 @@
+ ${BSD_INSTALL_DATA} dsp/DSPConfig.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/DSPOp.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/DSPVector.hh $(PREFIX)/include/dsp
-+ ${BSD_INSTALL_DATA} dsp/Decimator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FFTDecimator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FFTInterpolator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FFTMultiRate.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Filter.hh $(PREFIX)/include/dsp
-+ ${BSD_INSTALL_DATA} dsp/Filter2.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FIRDecimator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FIRInterpolator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/FIRMultiRate.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/FlipBand.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Hankel.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/IIRCascade.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/IIRDecimator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/IIRInterpolator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/IIRMultiRate.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/ReBuffer.hh $(PREFIX)/include/dsp
-+ ${BSD_INSTALL_DATA} dsp/ReBuffer2.hh $(PREFIX)/include/dsp
-+ ${BSD_INSTALL_DATA} dsp/ReBuffer3.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/ReBufferT.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/RecDecimator.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/RecInterpolator.hh $(PREFIX)/include/dsp
++ ${BSD_INSTALL_DATA} dsp/RingBuffer.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Transform4.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/Transform8.hh $(PREFIX)/include/dsp
+ ${BSD_INSTALL_DATA} dsp/TransformS.hh $(PREFIX)/include/dsp
diff --git a/devel/libdsp/pkg-plist b/devel/libdsp/pkg-plist
index b4f140bfd66b..35cb174146c0 100644
--- a/devel/libdsp/pkg-plist
+++ b/devel/libdsp/pkg-plist
@@ -1,7 +1,6 @@
include/dsp/DSPConfig.hh
include/dsp/DSPOp.hh
include/dsp/DSPVector.hh
-include/dsp/Decimator.hh
include/dsp/FFTDecimator.hh
include/dsp/FFTInterpolator.hh
include/dsp/FFTMultiRate.hh
@@ -9,17 +8,17 @@ include/dsp/FIRDecimator.hh
include/dsp/FIRInterpolator.hh
include/dsp/FIRMultiRate.hh
include/dsp/Filter.hh
-include/dsp/Filter2.hh
+include/dsp/FlipBand.hh
include/dsp/Hankel.hh
include/dsp/IIRCascade.hh
include/dsp/IIRDecimator.hh
include/dsp/IIRInterpolator.hh
include/dsp/IIRMultiRate.hh
include/dsp/ReBuffer.hh
-include/dsp/ReBuffer2.hh
-include/dsp/ReBuffer3.hh
+include/dsp/ReBufferT.hh
include/dsp/RecDecimator.hh
include/dsp/RecInterpolator.hh
+include/dsp/RingBuffer.hh
include/dsp/Transform4.hh
include/dsp/Transform8.hh
include/dsp/TransformS.hh
@@ -29,5 +28,5 @@ include/dsp/dsptypes.h
lib/libdsp.a
lib/libdsp.la
lib/libdsp.so
-lib/libdsp.so.5
+lib/libdsp.so.9
@dirrm include/dsp