aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libe
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-09-23 09:32:01 +0800
committerswills <swills@FreeBSD.org>2018-09-23 09:32:01 +0800
commit82fa8015ac83162796821c41006db65d69f46264 (patch)
treeaa199b62a957da9760dda07691cb05fd726e60ca /devel/libe
parent67183bbff562e612c8be091bd8816fe502005105 (diff)
downloadfreebsd-ports-gnome-82fa8015ac83162796821c41006db65d69f46264.tar.gz
freebsd-ports-gnome-82fa8015ac83162796821c41006db65d69f46264.tar.zst
freebsd-ports-gnome-82fa8015ac83162796821c41006db65d69f46264.zip
devel/libe: update to release 0.11.0
While here, pass maintainership to submitter PR: 231102 Submitted by: Vinícius Zavam <egypcio@googlemail.com>
Diffstat (limited to 'devel/libe')
-rw-r--r--devel/libe/Makefile20
-rw-r--r--devel/libe/distinfo5
-rw-r--r--devel/libe/files/patch-configure.ac11
-rw-r--r--devel/libe/files/patch-garbage_collector.cc11
-rw-r--r--devel/libe/pkg-plist10
5 files changed, 33 insertions, 24 deletions
diff --git a/devel/libe/Makefile b/devel/libe/Makefile
index 9ce474444611..2b67b2c26968 100644
--- a/devel/libe/Makefile
+++ b/devel/libe/Makefile
@@ -1,24 +1,28 @@
# Created by: Veniamin Gvozdikov <vg@FreeBSD.org>
# $FreeBSD$
-PORTNAME= libe
-PORTVERSION= 0.7.0
-PORTREVISION= 1
-CATEGORIES= devel
-MASTER_SITES= http://hyperdex.org/src/
+PORTNAME= libe
+PORTVERSION= 0.11.0
+DISTVERSIONPREFIX= releases/
+CATEGORIES= devel
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= egypcio@googlemail.com
COMMENT= High-performance datastructures and utilities for C++
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
+ONLY_FOR_ARCHS= amd64
+
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libpo6.pc:devel/libpo6
GNU_CONFIGURE= yes
-USES= gmake libtool pathfix pkgconfig
+
+USES= autoreconf gmake libtool pathfix pkgconfig
+USE_GITHUB= yes
USE_LDCONFIG= yes
-ONLY_FOR_ARCHS= amd64
+GH_ACCOUNT= rescrv
+GH_PROJECT= e
.include <bsd.port.mk>
diff --git a/devel/libe/distinfo b/devel/libe/distinfo
index 9dbd378972ca..8df474f74fc2 100644
--- a/devel/libe/distinfo
+++ b/devel/libe/distinfo
@@ -1,2 +1,3 @@
-SHA256 (libe-0.7.0.tar.gz) = 2ae0ad14d9c7576531d38a8ed8034e34933f626556742f7ee74a39cefcbfb7a7
-SIZE (libe-0.7.0.tar.gz) = 401370
+TIMESTAMP = 1535833568
+SHA256 (rescrv-e-releases-0.11.0_GH0.tar.gz) = 6eb66c4bcc3f5597c35470dd8262f60d8999040f256fd6b581a7a763d21e9db3
+SIZE (rescrv-e-releases-0.11.0_GH0.tar.gz) = 68510
diff --git a/devel/libe/files/patch-configure.ac b/devel/libe/files/patch-configure.ac
new file mode 100644
index 000000000000..75a986bb50d5
--- /dev/null
+++ b/devel/libe/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2018-09-01 20:42:04 UTC
++++ configure.ac
+@@ -13,7 +13,7 @@ AM_INIT_AUTOMAKE(foreign serial_tests su
+ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+ LT_PREREQ([2.2])
+ LT_INIT
+-AC_CONFIG_SRCDIR([e/buffer.h])
++AC_CONFIG_SRCDIR([e])
+ AC_CONFIG_HEADERS([config.h])
+ AC_CONFIG_MACRO_DIR([m4])
+
diff --git a/devel/libe/files/patch-garbage_collector.cc b/devel/libe/files/patch-garbage_collector.cc
deleted file mode 100644
index ecaee46199cd..000000000000
--- a/devel/libe/files/patch-garbage_collector.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- garbage_collector.cc.orig 2014-05-03 22:16:07.000000000 +0400
-+++ garbage_collector.cc 2015-02-21 16:58:28.000000000 +0300
-@@ -30,6 +30,8 @@
- // e
- #include "e/garbage_collector.h"
-
-+#include <algorithm>
-+
- using e::garbage_collector;
-
- class garbage_collector::thread_state_node
diff --git a/devel/libe/pkg-plist b/devel/libe/pkg-plist
index c32de14ef587..1edd19917424 100644
--- a/devel/libe/pkg-plist
+++ b/devel/libe/pkg-plist
@@ -1,4 +1,5 @@
include/e/ao_hash_map.h
+include/e/arena.h
include/e/array_ptr.h
include/e/atomic.h
include/e/bitsteal.h
@@ -8,6 +9,7 @@ include/e/convert.h
include/e/endian.h
include/e/envconfig.h
include/e/error.h
+include/e/flagfd.h
include/e/garbage_collector.h
include/e/guard.h
include/e/hazard_ptrs.h
@@ -15,6 +17,7 @@ include/e/intrusive_ptr.h
include/e/lockfree_fifo.h
include/e/lockfree_hash_map.h
include/e/lockfree_hash_set.h
+include/e/lockfree_mpsc_fifo.h
include/e/locking_fifo.h
include/e/lookup3.h
include/e/nonblocking_bounded_fifo.h
@@ -22,16 +25,17 @@ include/e/nwf_hash_map.h
include/e/popt.h
include/e/pow2.h
include/e/safe_math.h
+include/e/seqno_collector.h
+include/e/serialization.h
include/e/slice.h
include/e/strescape.h
include/e/striped_lock.h
include/e/subcommand.h
include/e/time.h
include/e/tuple_compare.h
-include/e/unpacker.h
include/e/varint.h
lib/libe.a
lib/libe.so
-lib/libe.so.1
-lib/libe.so.1.1.0
+lib/libe.so.5
+lib/libe.so.5.0.0
libdata/pkgconfig/libe.pc