aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libmcs
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2007-03-01 05:00:27 +0800
committeroliver <oliver@FreeBSD.org>2007-03-01 05:00:27 +0800
commitafa3eb06fb6e99eb55bc8f507398509b3806a896 (patch)
tree3c96be67d40b616736e52a114cf7a9b9c56b3128 /devel/libmcs
parentc93fcba6941e1fb23321751c409dca39ea036312 (diff)
downloadfreebsd-ports-gnome-afa3eb06fb6e99eb55bc8f507398509b3806a896.tar.gz
freebsd-ports-gnome-afa3eb06fb6e99eb55bc8f507398509b3806a896.tar.zst
freebsd-ports-gnome-afa3eb06fb6e99eb55bc8f507398509b3806a896.zip
mcs is a library and set of userland tools which abstract the storage of
configuration settings away from userland applications. It is hoped that by using mcs, that the applications which use it will generally have a more congruent feeling in regards to settings. There have been other projects like this before (such as GConf), but unlike those projects, mcs strictly handles abstraction. It does not impose any specific data storage requirement, nor is it tied to any desktop environment or software suite. Because mcs is licenced under the BSD licence, it is hoped that many applications will adopt it's use. WWW: http://sacredspiral.co.uk/~nenolod/mcs/
Diffstat (limited to 'devel/libmcs')
-rw-r--r--devel/libmcs/Makefile24
-rw-r--r--devel/libmcs/distinfo3
-rw-r--r--devel/libmcs/pkg-descr15
-rw-r--r--devel/libmcs/pkg-plist13
4 files changed, 55 insertions, 0 deletions
diff --git a/devel/libmcs/Makefile b/devel/libmcs/Makefile
new file mode 100644
index 000000000000..aed1a5dc3d64
--- /dev/null
+++ b/devel/libmcs/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: libmcs
+# Date created: 27th February 2007
+# Whom: Oliver Lehmann <oliver@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmcs
+PORTVERSION= 0.4.0
+CATEGORIES= devel
+MASTER_SITES= http://sacredspiral.co.uk/~nenolod/mcs/
+DISTNAME= mcs-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= oliver@FreeBSD.org
+COMMENT= A BSD licenced configuration database system
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|$$(LIBDIR)|$$(prefix)/libdata|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/devel/libmcs/distinfo b/devel/libmcs/distinfo
new file mode 100644
index 000000000000..c5225ae5e632
--- /dev/null
+++ b/devel/libmcs/distinfo
@@ -0,0 +1,3 @@
+MD5 (mcs-0.4.0.tgz) = e8fbbb756af0d6ab6da3be7934861c5e
+SHA256 (mcs-0.4.0.tgz) = 42cf4bc97887da13df7fb8da38adfc7470f10ce5bd2b062b556c28dde854a715
+SIZE (mcs-0.4.0.tgz) = 62913
diff --git a/devel/libmcs/pkg-descr b/devel/libmcs/pkg-descr
new file mode 100644
index 000000000000..33800ec325ba
--- /dev/null
+++ b/devel/libmcs/pkg-descr
@@ -0,0 +1,15 @@
+mcs is a library and set of userland tools which abstract the storage of
+configuration settings away from userland applications.
+
+It is hoped that by using mcs, that the applications which use it will
+generally have a more congruent feeling in regards to settings.
+
+There have been other projects like this before (such as GConf), but unlike
+those projects, mcs strictly handles abstraction. It does not impose any
+specific data storage requirement, nor is it tied to any desktop environment
+or software suite.
+
+Because mcs is licenced under the BSD licence, it is hoped that many
+applications will adopt it's use.
+
+WWW: http://sacredspiral.co.uk/~nenolod/mcs/
diff --git a/devel/libmcs/pkg-plist b/devel/libmcs/pkg-plist
new file mode 100644
index 000000000000..dd35381d9a13
--- /dev/null
+++ b/devel/libmcs/pkg-plist
@@ -0,0 +1,13 @@
+bin/mcs-getconfval
+bin/mcs-info
+bin/mcs-query-backends
+bin/mcs-setconfval
+include/libmcs/mcs.h
+include/libmcs/mcs_config.h
+lib/libmcs.so
+lib/libmcs.so.1
+lib/libmcs.so.1.0.0
+lib/mcs/libkeyfile.so
+libdata/pkgconfig/libmcs.pc
+@dirrm include/libmcs
+@dirrm lib/mcs