aboutsummaryrefslogtreecommitdiffstats
path: root/devel/liboil
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-07-06 13:45:15 +0800
committermarcus <marcus@FreeBSD.org>2006-07-06 13:45:15 +0800
commitf3d9113d57d97e7e6d2849e040706e70a24362fb (patch)
tree0e13ca9a4efc8820f59affc1324e1afcd85993da /devel/liboil
parentd5a8ae939180fc0b293c92cbc0b274c54ad2f76b (diff)
downloadfreebsd-ports-gnome-f3d9113d57d97e7e6d2849e040706e70a24362fb.tar.gz
freebsd-ports-gnome-f3d9113d57d97e7e6d2849e040706e70a24362fb.tar.zst
freebsd-ports-gnome-f3d9113d57d97e7e6d2849e040706e70a24362fb.zip
Add a RUN_DEPENDS on gcc34 (yuck!) for 5.X since liboil links to libgcc_s.so
which is not installed by the base gcc for some reason. Without this fix binaries that link to liboil would fail to load.
Diffstat (limited to 'devel/liboil')
-rw-r--r--devel/liboil/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/liboil/Makefile b/devel/liboil/Makefile
index 320b8f88bbd5..f624c48111cc 100644
--- a/devel/liboil/Makefile
+++ b/devel/liboil/Makefile
@@ -7,6 +7,7 @@
PORTNAME= liboil
PORTVERSION= 0.3.9
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://liboil.freedesktop.org/download/ \
${MASTER_SITE_LOCAL}
@@ -26,6 +27,7 @@ CFLAGS+= -O2
.if ${OSVERSION} < 600000 && ${OSVERSION} > 500000
#USE_GCC= 3.4
BUILD_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
+RUN_DEPENDS+= gcc34:${PORTSDIR}/lang/gcc34
CC:= gcc34
CXX:= g++34
.endif