aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libsoup22
diff options
context:
space:
mode:
authoradamw <adamw@FreeBSD.org>2005-12-25 00:55:31 +0800
committeradamw <adamw@FreeBSD.org>2005-12-25 00:55:31 +0800
commit9d47881b320b31296125519e8871dc2897e97d5b (patch)
tree0ee3a4b7e962b952608a5c92b41eaa4676f6e405 /devel/libsoup22
parent265a8c0b99c3ec4d1c54863e790634a10391bd40 (diff)
downloadfreebsd-ports-gnome-9d47881b320b31296125519e8871dc2897e97d5b.tar.gz
freebsd-ports-gnome-9d47881b320b31296125519e8871dc2897e97d5b.tar.zst
freebsd-ports-gnome-9d47881b320b31296125519e8871dc2897e97d5b.zip
Add PTHREAD_CFLAGS/LIBS to CONFIGURE_ENV, and make LDFLAGS actually
be a part of CONFIGURE_ENV.
Diffstat (limited to 'devel/libsoup22')
-rw-r--r--devel/libsoup22/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/libsoup22/Makefile b/devel/libsoup22/Makefile
index 2eff113b564e..ab80e23e0f9e 100644
--- a/devel/libsoup22/Makefile
+++ b/devel/libsoup22/Makefile
@@ -25,8 +25,8 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc \
--disable-gtk-doc
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
-LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
PLIST_SUB= VERSION="2.2"