aboutsummaryrefslogtreecommitdiffstats
path: root/devel/libvirt
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2014-03-08 06:34:55 +0800
committerjgh <jgh@FreeBSD.org>2014-03-08 06:34:55 +0800
commitaa7107a299e9600ba1f6afe9f2acfc5bbbdfe548 (patch)
tree21502c02f52715e28ccacd62552b630cfbe91fec /devel/libvirt
parentc7f96db5d34feec99076ad40505d6fddc29c5515 (diff)
downloadfreebsd-ports-gnome-aa7107a299e9600ba1f6afe9f2acfc5bbbdfe548.tar.gz
freebsd-ports-gnome-aa7107a299e9600ba1f6afe9f2acfc5bbbdfe548.tar.zst
freebsd-ports-gnome-aa7107a299e9600ba1f6afe9f2acfc5bbbdfe548.zip
- update libvirt to 1.2.2
- fix qemu when not enabled, and disable linux containers [1] - update libvirt-glib to 0.1.8 Changes: http://libvirt.org/news.html Submitted by: roman@ [1]
Diffstat (limited to 'devel/libvirt')
-rw-r--r--devel/libvirt/Makefile4
-rw-r--r--devel/libvirt/distinfo4
-rw-r--r--devel/libvirt/files/patch-src__Makefile.in25
-rw-r--r--devel/libvirt/pkg-plist2
4 files changed, 29 insertions, 6 deletions
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 16811b39ae94..1f3eb3c8f818 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libvirt
-PORTVERSION= 1.2.1
-PORTREVISION= 1
+PORTVERSION= 1.2.2
CATEGORIES= devel
MASTER_SITES= http://libvirt.org/sources/ \
ftp://libvirt.org/libvirt/
@@ -45,6 +44,7 @@ CONFIGURE_ARGS= --without-sasl \
--without-netcf \
--without-network \
--without-sysctl \
+ --without-lxc \
--with-ssh2
# workaround to override pkg-config calls
diff --git a/devel/libvirt/distinfo b/devel/libvirt/distinfo
index 2594ce6a0b47..e2f8d4d27a59 100644
--- a/devel/libvirt/distinfo
+++ b/devel/libvirt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libvirt-1.2.1.tar.gz) = bc29b5751bf36753c17e2fdbb75e70c7b07df3d9527586d3426e90f5f4abb898
-SIZE (libvirt-1.2.1.tar.gz) = 27228694
+SHA256 (libvirt-1.2.2.tar.gz) = a48377e307c5c21b67e43db99af909a23c33aff8cbbaa3361fd389eb047cbbc3
+SIZE (libvirt-1.2.2.tar.gz) = 28340039
diff --git a/devel/libvirt/files/patch-src__Makefile.in b/devel/libvirt/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..0fc4507281ba
--- /dev/null
+++ b/devel/libvirt/files/patch-src__Makefile.in
@@ -0,0 +1,25 @@
+--- ./src/Makefile.in.orig 2014-03-07 08:08:47.000000000 -0800
++++ ./src/Makefile.in 2014-03-07 08:10:53.000000000 -0800
+@@ -288,9 +288,9 @@
+ @WITH_LIBVIRTD_TRUE@am__append_159 = lockd.la
+ @WITH_LIBVIRTD_TRUE@am__append_160 = locking/libvirt_lockd.aug \
+ @WITH_LIBVIRTD_TRUE@ locking/virtlockd.aug
+-@WITH_LIBVIRTD_TRUE@am__append_161 = test_libvirt_lockd.aug \
+-@WITH_LIBVIRTD_TRUE@ test_virtlockd.aug
+-@WITH_LIBVIRTD_TRUE@am__append_162 = test_libvirt_lockd.aug
++@WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_161 = test_libvirt_lockd.aug \
++@WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@ test_virtlockd.aug
++@WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_162 = test_libvirt_lockd.aug
+ @WITH_DTRACE_PROBES_TRUE@@WITH_LIBVIRTD_TRUE@am__append_163 = libvirt_probes.lo
+ @WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_164 = locking/qemu-lockd.conf
+ @WITH_LIBVIRTD_TRUE@@WITH_QEMU_TRUE@am__append_165 = locking/qemu-lockd.conf
+@@ -9678,6 +9678,8 @@
+ @WITH_QEMU_TRUE@ locking/qemu-lockd.conf $(AUG_GENTEST)
+ @WITH_QEMU_TRUE@ $(AM_V_GEN)$(AUG_GENTEST) locking/qemu-lockd.conf $< $@
+
++@WITH_QEMU_FALSE@test_libvirt_lockd.aug:
++
+ test_virtlockd.aug: locking/test_virtlockd.aug.in \
+ locking/virtlockd.conf $(AUG_GENTEST)
+ $(AM_V_GEN)$(AUG_GENTEST) $(srcdir)/locking/virtlockd.conf $< $@
+
diff --git a/devel/libvirt/pkg-plist b/devel/libvirt/pkg-plist
index 4857005bf56c..2187faa5f245 100644
--- a/devel/libvirt/pkg-plist
+++ b/devel/libvirt/pkg-plist
@@ -47,9 +47,7 @@ share/augeas/lenses/libvirt_lockd.aug
share/augeas/lenses/libvirtd.aug
share/augeas/lenses/virtlockd.aug
%%QEMU%%share/augeas/lenses/libvirtd_qemu.aug
-share/augeas/lenses/tests/test_libvirt_lockd.aug
share/augeas/lenses/tests/test_libvirtd.aug
-share/augeas/lenses/tests/test_virtlockd.aug
%%QEMU%%share/augeas/lenses/tests/test_libvirtd_qemu.aug
%%DOCSDIR%%%%PORTVERSION%%/html/32favicon.png
%%DOCSDIR%%%%PORTVERSION%%/html/404.html