aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux-glib2
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
committernetchild <netchild@FreeBSD.org>2005-06-18 06:59:29 +0800
commit8d63fa8ce3e1cb7a464d405732fcf971c5848297 (patch)
treebef012ab5e448ce5c144b7bb40139ba1dfd902a6 /devel/linux-glib2
parent5f5845bb3ad1db90d601456aaaea7343c4dabfc6 (diff)
downloadfreebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.gz
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.tar.zst
freebsd-ports-gnome-8d63fa8ce3e1cb7a464d405732fcf971c5848297.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Diffstat (limited to 'devel/linux-glib2')
-rw-r--r--devel/linux-glib2/Makefile2
-rw-r--r--devel/linux-glib2/pkg-plist24
2 files changed, 25 insertions, 1 deletions
diff --git a/devel/linux-glib2/Makefile b/devel/linux-glib2/Makefile
index 84da08785493..6167073aac7c 100644
--- a/devel/linux-glib2/Makefile
+++ b/devel/linux-glib2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= glib2
PORTVERSION= 2.2.1
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/devel/linux-glib2/pkg-plist b/devel/linux-glib2/pkg-plist
index deed898fe114..cb5d711bbf3d 100644
--- a/devel/linux-glib2/pkg-plist
+++ b/devel/linux-glib2/pkg-plist
@@ -53,3 +53,27 @@ usr/share/locale/vi/LC_MESSAGES/glib20.mo
usr/share/locale/zh_CN/LC_MESSAGES/glib20.mo
usr/share/locale/zh_TW/LC_MESSAGES/glib20.mo
@dirrm usr/share/doc/glib2-2.2.1
+@unexec rmdir %D/usr/share/locale/am/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/am 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/az/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/az 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/bg/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/bg 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/bn/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/bn 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/eu/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/eu 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/hi/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/hi 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/mn/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/mn 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/ms/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/ms 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/nn/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/nn 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/sq/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/sq 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/ta/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/ta 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/vi/LC_MESSAGES 2>&1 >/dev/null || true
+@unexec rmdir %D/usr/share/locale/vi 2>&1 >/dev/null || true