aboutsummaryrefslogtreecommitdiffstats
path: root/devel/linux_devtools
diff options
context:
space:
mode:
authorsheldonh <sheldonh@FreeBSD.org>2000-08-15 18:22:36 +0800
committersheldonh <sheldonh@FreeBSD.org>2000-08-15 18:22:36 +0800
commit9fbc9e359af19834125374d2442d3c31a91a5300 (patch)
treed28e5432981eb7be66d2f6c188b16bbd246c12dc /devel/linux_devtools
parentd0818ca799b0c5faf2ed63b4544f1cf526fd1eb4 (diff)
downloadfreebsd-ports-gnome-9fbc9e359af19834125374d2442d3c31a91a5300.tar.gz
freebsd-ports-gnome-9fbc9e359af19834125374d2442d3c31a91a5300.tar.zst
freebsd-ports-gnome-9fbc9e359af19834125374d2442d3c31a91a5300.zip
Do not rely on the linux(8) shell script. Instead, use an INSTALL
script so that the behaviour of a package installation matches that of a port installation identically. Note that, in the package case, we already have a valid run-time linker hints file for Linux.
Diffstat (limited to 'devel/linux_devtools')
-rw-r--r--devel/linux_devtools/Makefile13
-rw-r--r--devel/linux_devtools/pkg-install17
2 files changed, 20 insertions, 10 deletions
diff --git a/devel/linux_devtools/Makefile b/devel/linux_devtools/Makefile
index 05d0506c512e..ec843b794b92 100644
--- a/devel/linux_devtools/Makefile
+++ b/devel/linux_devtools/Makefile
@@ -91,17 +91,10 @@ NEEDLOADLINK= true
do-patch:
@${DO_NADA}
+pre-install:
+ @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+
do-install:
- @if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then \
- ${ECHO} 'Linux mode is not enabled.\
- Loading linux kernel module...' | fmt; \
- linux || { \
- ${ECHO} 'The linux kernel module could not be loaded.\
- Please manually load the module and retry.\
- See "man linux" for details.' | fmt; \
- ${FALSE}; \
- };\
- fi
#
# Setup a chroot'able environment
#
diff --git a/devel/linux_devtools/pkg-install b/devel/linux_devtools/pkg-install
new file mode 100644
index 000000000000..957ee313fa57
--- /dev/null
+++ b/devel/linux_devtools/pkg-install
@@ -0,0 +1,17 @@
+#!/bin/sh
+# an installation script for linux_devtools
+
+case "$2" in
+PRE-INSTALL)
+ if [ -z "`kldstat -v | ${GREP} -E 'linux(aout|elf)'`" ]; then
+ echo 'Linux mode is not enabled.'
+ echo 'Loading linux kernel module now...'
+ if ! kldload linux; then
+ echo 'The linux kernel module could not be loaded.'
+ echo 'Please enable linux mode manually and retry.'
+ exit 1
+ fi
+ ;;
+esac
+
+exit 0