aboutsummaryrefslogtreecommitdiffstats
path: root/devel/llvm60
diff options
context:
space:
mode:
authorbrooks <brooks@FreeBSD.org>2019-02-19 05:52:49 +0800
committerbrooks <brooks@FreeBSD.org>2019-02-19 05:52:49 +0800
commita73b2d6b0c4df7541cf15cfd15ab0365a1d40555 (patch)
tree7b44459079222e9502fb7566d2f8625e14df9f44 /devel/llvm60
parent640c62f9715906a393ffe6eaed7445d86eb49dd0 (diff)
downloadfreebsd-ports-gnome-a73b2d6b0c4df7541cf15cfd15ab0365a1d40555.tar.gz
freebsd-ports-gnome-a73b2d6b0c4df7541cf15cfd15ab0365a1d40555.tar.zst
freebsd-ports-gnome-a73b2d6b0c4df7541cf15cfd15ab0365a1d40555.zip
Don't override the compiler on armv7.
The base system compiler is now sufficent to build and link. No version bump. While technically required for armv7, forcing everyone to rebuild for this minor change that doesn't effect actual use is not justifiable. PR: 235282 Submitted by: jbeich
Diffstat (limited to 'devel/llvm60')
-rw-r--r--devel/llvm60/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/llvm60/Makefile b/devel/llvm60/Makefile
index a6dd6f6bc592..04e1b966ddea 100644
--- a/devel/llvm60/Makefile
+++ b/devel/llvm60/Makefile
@@ -345,7 +345,7 @@ PORTDOCS+= lld
CXXFLAGS+= -D_GLIBCXX_USE_C99
.endif
-.if ${ARCH} == "armv6" || ${ARCH} == "armv7"
+.if ${ARCH} == "armv6"
BUILD_DEPENDS+= ${LOCALBASE}/bin/ld:devel/binutils
CONFIGURE_ENV+= COMPILER_PATH=${LOCALBASE}/bin
MAKE_ENV+= COMPILER_PATH=${LOCALBASE}/bin