aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mate-common
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-11-23 19:39:07 +0800
committerkwm <kwm@FreeBSD.org>2013-11-23 19:39:07 +0800
commit7bca6ea6f563c85388f53d6aa74a11e52672425f (patch)
tree000a9ce64a1e669ce72ebf4b639d75f2ef29c214 /devel/mate-common
parent9a25b340e90f1811045215d11f228f12434fa124 (diff)
downloadfreebsd-ports-gnome-7bca6ea6f563c85388f53d6aa74a11e52672425f.tar.gz
freebsd-ports-gnome-7bca6ea6f563c85388f53d6aa74a11e52672425f.tar.zst
freebsd-ports-gnome-7bca6ea6f563c85388f53d6aa74a11e52672425f.zip
Say hello to Mate 1.6.
Mate is a lite desktop forked from gnome2. Most of the work is done by Jeremy Messenger (mezz@). The only thing I did was update a few ports to later 1.6 release and attempting to keep up with ports infra changes. Resulting bugs are all mine. Mate is a sort of replacement for Gnome 2. So people wanting to keep a Gnome 2 like desktop should switch. Gnome 2 will be replaced by Gnome 3 in the near future. This switch will be announce with a transition time so people have more time to switch if they haven't already. This release was made possible by everyone that send friendly pokes to keep mate on my mind. Approved by: portmgr (bapt)
Diffstat (limited to 'devel/mate-common')
-rw-r--r--devel/mate-common/Makefile21
-rw-r--r--devel/mate-common/distinfo2
-rw-r--r--devel/mate-common/files/patch-macros_mate-autogen35
-rw-r--r--devel/mate-common/pkg-descr4
-rw-r--r--devel/mate-common/pkg-plist10
5 files changed, 72 insertions, 0 deletions
diff --git a/devel/mate-common/Makefile b/devel/mate-common/Makefile
new file mode 100644
index 000000000000..6cd9aa17b97a
--- /dev/null
+++ b/devel/mate-common/Makefile
@@ -0,0 +1,21 @@
+#Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mate-common
+PORTVERSION= 1.6.2
+CATEGORIES= devel mate
+MASTER_SITES= MATE
+DIST_SUBDIR= mate
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Common automake macros for MATE
+
+PORTSCOUT= limitw:1,even
+
+USES= gmake pkgconfig:both
+USE_XZ= yes
+USE_MATE= autogen
+USE_AUTOTOOLS= aclocal:env autoconf:env automake:env
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/mate-common/distinfo b/devel/mate-common/distinfo
new file mode 100644
index 000000000000..be261317fc5b
--- /dev/null
+++ b/devel/mate-common/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mate/mate-common-1.6.2.tar.xz) = d7aafd79d98cdc22d4425baf49c39c16bc702d2c3d1065cc14d63718214a2059
+SIZE (mate/mate-common-1.6.2.tar.xz) = 66876
diff --git a/devel/mate-common/files/patch-macros_mate-autogen b/devel/mate-common/files/patch-macros_mate-autogen
new file mode 100644
index 000000000000..5f379b25633a
--- /dev/null
+++ b/devel/mate-common/files/patch-macros_mate-autogen
@@ -0,0 +1,35 @@
+https://bugs.gentoo.org/show_bug.cgi?id=427432
+https://bugzilla.gnome.org/show_bug.cgi?id=680363
+
+--- macros/mate-autogen.orig 2009-05-27 23:29:07.000000000 +0200
++++ macros/mate-autogen 2012-07-24 10:29:13.064750613 +0200
+@@ -77,6 +77,7 @@
+ vc_min_version=$4
+ vc_source=$5
+ vc_status=1
++ vc_option="--version"
+
+ vc_checkprog=`eval echo "\\$$vc_variable"`
+ if [ -n "$vc_checkprog" ]; then
+@@ -89,11 +90,19 @@
+ else
+ vc_comparator=">="
+ fi
++ # The most reliable way to check pkg-config version is to query the actual
++ # virtual
++ # pkg-config package entry's modversion. This works in all known
++ # implementations.
++
++ if test "x$vc_package" = "xpkg-config"; then
++ vc_option="--modversion pkg-config"
++ fi
+ printbold "checking for $vc_package $vc_comparator $vc_min_version..."
+ for vc_checkprog in $vc_checkprogs; do
+ echo $ECHO_N " testing $vc_checkprog... " $ECHO_C
+- if $vc_checkprog --version < /dev/null > /dev/null 2>&1; then
+- vc_actual_version=`$vc_checkprog --version | head -n 1 | \
++ if $vc_checkprog $vc_option < /dev/null > /dev/null 2>&1; then
++ vc_actual_version=`$vc_checkprog $vc_option | head -n 1 | \
+ sed 's/^.*[ ]\([0-9.]*[a-z]*\).*$/\1/'`
+ if compare_versions $vc_min_version $vc_actual_version; then
+ echo "found $vc_actual_version"
diff --git a/devel/mate-common/pkg-descr b/devel/mate-common/pkg-descr
new file mode 100644
index 000000000000..cc145d2aabc7
--- /dev/null
+++ b/devel/mate-common/pkg-descr
@@ -0,0 +1,4 @@
+This is a collection of automake macros used for developing new MATE
+applications.
+
+WWW: http://mate-desktop.org/
diff --git a/devel/mate-common/pkg-plist b/devel/mate-common/pkg-plist
new file mode 100644
index 000000000000..b6246e585cb1
--- /dev/null
+++ b/devel/mate-common/pkg-plist
@@ -0,0 +1,10 @@
+bin/mate-autogen
+bin/mate-doc-common
+man/man1/mate-autogen.1.gz
+man/man1/mate-doc-common.1.gz
+share/aclocal/mate-common.m4
+share/aclocal/mate-compiler-flags.m4
+%%DATADIR%%/data/omf.make
+%%DATADIR%%/data/xmldocs.make
+@dirrm %%DATADIR%%/data
+@dirrm %%DATADIR%%