aboutsummaryrefslogtreecommitdiffstats
path: root/devel/mk/files
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2003-10-19 16:59:55 +0800
committerkris <kris@FreeBSD.org>2003-10-19 16:59:55 +0800
commit2b4d3637bf519720dede1024e33a037ebaa6ab03 (patch)
treeba7356273e6203ae040fb22311736d5ac60d3126 /devel/mk/files
parent8b3f89e06dd5c0e73dee77fc583a8ce69e302108 (diff)
downloadfreebsd-ports-gnome-2b4d3637bf519720dede1024e33a037ebaa6ab03.tar.gz
freebsd-ports-gnome-2b4d3637bf519720dede1024e33a037ebaa6ab03.tar.zst
freebsd-ports-gnome-2b4d3637bf519720dede1024e33a037ebaa6ab03.zip
Respect CC and CFLAGS
Diffstat (limited to 'devel/mk/files')
-rw-r--r--devel/mk/files/patch-lib::9::Makefile11
-rw-r--r--devel/mk/files/patch-lib::bio::Makefile11
-rw-r--r--devel/mk/files/patch-lib::regexp::Makefile11
-rw-r--r--devel/mk/files/patch-src::Makefile11
4 files changed, 44 insertions, 0 deletions
diff --git a/devel/mk/files/patch-lib::9::Makefile b/devel/mk/files/patch-lib::9::Makefile
new file mode 100644
index 000000000000..afbee6123466
--- /dev/null
+++ b/devel/mk/files/patch-lib::9::Makefile
@@ -0,0 +1,11 @@
+--- lib/9/Makefile.orig Sun Oct 19 01:51:44 2003
++++ lib/9/Makefile Sun Oct 19 01:51:50 2003
+@@ -16,7 +16,7 @@
+ newprint.o
+
+ TARG=../lib9.a
+-CFLAGS=-g -I../../include
++CFLAGS+=-g -I../../include
+
+ all: $(TARG)
+
diff --git a/devel/mk/files/patch-lib::bio::Makefile b/devel/mk/files/patch-lib::bio::Makefile
new file mode 100644
index 000000000000..4d8fc3abc2d8
--- /dev/null
+++ b/devel/mk/files/patch-lib::bio::Makefile
@@ -0,0 +1,11 @@
+--- lib/bio/Makefile.orig Sun Oct 19 01:51:44 2003
++++ lib/bio/Makefile Sun Oct 19 01:51:55 2003
+@@ -12,7 +12,7 @@
+ OFILES=bflush.o bgetc.o bgetrune.o binit.o bprint.o bputc.o bwrite.o
+
+ TARG=../libbio.a
+-CFLAGS=-g -I../../include
++CFLAGS+=-g -I../../include
+
+ all: $(TARG)
+
diff --git a/devel/mk/files/patch-lib::regexp::Makefile b/devel/mk/files/patch-lib::regexp::Makefile
new file mode 100644
index 000000000000..61593dd658b6
--- /dev/null
+++ b/devel/mk/files/patch-lib::regexp::Makefile
@@ -0,0 +1,11 @@
+--- lib/regexp/Makefile.orig Sun Oct 19 01:51:44 2003
++++ lib/regexp/Makefile Sun Oct 19 01:51:59 2003
+@@ -8,7 +8,7 @@
+ OFILES=regaux.o regcomp.o regexec.o regsub.o
+
+ TARG=../libregexp.a
+-CFLAGS=-g -I../../include
++CFLAGS+=-g -I../../include
+
+ all: $(TARG)
+
diff --git a/devel/mk/files/patch-src::Makefile b/devel/mk/files/patch-src::Makefile
new file mode 100644
index 000000000000..a2c23537184d
--- /dev/null
+++ b/devel/mk/files/patch-src::Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig Sun Oct 19 01:50:46 2003
++++ src/Makefile Sun Oct 19 01:50:14 2003
+@@ -5,7 +5,7 @@
+
+
+ TARG=../mk
+-CFLAGS=-g -I../include
++CFLAGS+=-g -I../include
+
+ $(TARG): $(OFILES) ../lib/libregexp.a ../lib/libbio.a ../lib/lib9.a
+ $(CC) -o $(TARG) $(OFILES) -L../lib -lregexp -lbio -l9