aboutsummaryrefslogtreecommitdiffstats
path: root/devel/msp430-binutils
diff options
context:
space:
mode:
authorlev <lev@FreeBSD.org>2003-08-01 21:28:11 +0800
committerlev <lev@FreeBSD.org>2003-08-01 21:28:11 +0800
commiteb62ac394d0e07c92f241e9df8971acc02b6223f (patch)
tree50484c98efeb900238a1038045fc35d20d704b6d /devel/msp430-binutils
parent1c98c9b64fca85f9cfbaa4f2e51324dd0e90f9e0 (diff)
downloadfreebsd-ports-gnome-eb62ac394d0e07c92f241e9df8971acc02b6223f.tar.gz
freebsd-ports-gnome-eb62ac394d0e07c92f241e9df8971acc02b6223f.tar.zst
freebsd-ports-gnome-eb62ac394d0e07c92f241e9df8971acc02b6223f.zip
Add workaround for hardware bug of some MSP430 units.
Obtained from: Target maintainers.
Diffstat (limited to 'devel/msp430-binutils')
-rw-r--r--devel/msp430-binutils/Makefile1
-rw-r--r--devel/msp430-binutils/files/patch-gas::config::tc-msp430.c37
2 files changed, 38 insertions, 0 deletions
diff --git a/devel/msp430-binutils/Makefile b/devel/msp430-binutils/Makefile
index 6f0fd7512072..17c1201b0e5f 100644
--- a/devel/msp430-binutils/Makefile
+++ b/devel/msp430-binutils/Makefile
@@ -7,6 +7,7 @@
PORTNAME= binutils
PORTVERSION= ${BINUTILVERSION}
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEWARE}
MASTER_SITE_SUBDIR= binutils/releases
diff --git a/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c b/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c
new file mode 100644
index 000000000000..562176091af7
--- /dev/null
+++ b/devel/msp430-binutils/files/patch-gas::config::tc-msp430.c
@@ -0,0 +1,37 @@
+--- gas/config/tc-msp430.c.orig Fri Aug 1 16:52:38 2003
++++ gas/config/tc-msp430.c Fri Aug 1 17:00:31 2003
+@@ -186,6 +186,8 @@
+ " msp430x1101 msp430x1111\n"
+ " msp430x1121 msp430x1122 msp430x1132\n"
+ " msp430x122 msp430x123\n"
++ " msp430x1222 msp430x1232\n"
++ " msp430x133 msp430x135\n"
+ " msp430x1331 msp430x1351\n"
+ " msp430x147 msp430x148 msp430x149\n"
+ " msp430x155 msp430x156 msp430x157\n"
+@@ -979,11 +981,7 @@
+ else if (x == 4)
+ {
+ #ifdef PUSH_1X_WORKAROUND
+- if (bin == 0x1200
+- && (msp430_mcu->isa == MSP430_ISA_11
+- || msp430_mcu->isa == MSP430_ISA_12
+- || msp430_mcu->isa == MSP430_ISA_13
+- || msp430_mcu->isa == MSP430_ISA_14))
++ if (bin == 0x1200)
+ {
+ /* Remove warning as confusing.
+ as_warn(_("Hardware push bug workaround")); */
+@@ -1000,11 +998,7 @@
+ else if (x == 8)
+ {
+ #ifdef PUSH_1X_WORKAROUND
+- if (bin == 0x1200
+- && (msp430_mcu->isa == MSP430_ISA_11
+- || msp430_mcu->isa == MSP430_ISA_12
+- || msp430_mcu->isa == MSP430_ISA_13
+- || msp430_mcu->isa == MSP430_ISA_14))
++ if (bin == 0x1200)
+ {
+ /* Remove warning as confusing.
+ as_warn(_("Hardware push bug workaround")); */