aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ncurses
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-03-31 15:26:11 +0800
committerrafan <rafan@FreeBSD.org>2008-03-31 15:26:11 +0800
commit1cf0e51a2b287e3d2b8d8b035464a8f784981bc7 (patch)
treeb4a57bba312981a8e37ddf46316699e6aead3faa /devel/ncurses
parent166a344a615684d1bdacea22eed8dc67c5da2123 (diff)
downloadfreebsd-ports-gnome-1cf0e51a2b287e3d2b8d8b035464a8f784981bc7.tar.gz
freebsd-ports-gnome-1cf0e51a2b287e3d2b8d8b035464a8f784981bc7.tar.zst
freebsd-ports-gnome-1cf0e51a2b287e3d2b8d8b035464a8f784981bc7.zip
- Really fix build when WRKDIRPREFIX [1]
I don't know why the current approach works in my previous test. Now really fix the build by changing to .CURDIR (where the port lives). Note that I use .CURDIR instead of PORTSDIR/PKGORIGIN as the port may live outside somewhere else. - Respect PORTEXAMPLES - Add trailing slash for destination directory PR: ports/117643 [1] Submitted by: Stefan Sperling <stsp at stsp.name> [1]
Diffstat (limited to 'devel/ncurses')
-rw-r--r--devel/ncurses/Makefile32
1 files changed, 19 insertions, 13 deletions
diff --git a/devel/ncurses/Makefile b/devel/ncurses/Makefile
index 38d6f049d4b5..1b286a241b9c 100644
--- a/devel/ncurses/Makefile
+++ b/devel/ncurses/Makefile
@@ -55,6 +55,7 @@ PLIST_SUB+= PORTVERSION=${RELEASE} \
NOWIDEC_EXAMPLESDIR=${NOWIDEC_EXAMPLESDIR:S,${PREFIX}/,,}
PORTDOCS= *
+PORTEXAMPLES= *
DOCS= ANNOUNCE INSTALL NEWS README TO-DO doc/html/announce.html \
doc/hackguide.doc doc/html/hackguide.html \
@@ -120,7 +121,8 @@ post-patch:
post-configure:
.if !defined(WITHOUT_WIDEC)
- ${MAKE} ${.MAKEFLAGS} CONFIGURE_WRKSRC=${WIDEC_WRKSRC} \
+ cd ${.CURDIR} && \
+ ${MAKE} ${.MAKEFLAGS} CONFIGURE_WRKSRC=${WIDEC_WRKSRC} \
CONFIGURE_ARGS="${CONFIGURE_ARGS} --enable-widec" \
do-configure
.endif
@@ -133,24 +135,28 @@ post-configure:
post-build:
.if !defined(WITHOUT_WIDEC)
- ${MAKE} ${.MAKEFLAGS} BUILD_WRKSRC=${WIDEC_WRKSRC} do-build
+ cd ${.CURDIR} && \
+ ${MAKE} ${.MAKEFLAGS} BUILD_WRKSRC=${WIDEC_WRKSRC} do-build
.endif
post-install:
.if !defined(WITHOUT_WIDEC)
- ${MAKE} ${.MAKEFLAGS} INSTALL_WRKSRC=${WIDEC_WRKSRC} do-install
+ cd ${.CURDIR} && \
+ ${MAKE} ${.MAKEFLAGS} INSTALL_WRKSRC=${WIDEC_WRKSRC} do-install
.endif
-.for i in ${EXAMPLES_TARGETS}
+.if !defined(NOPORTEXAMPLES)
+. for i in ${EXAMPLES_TARGETS}
${MKDIR} ${${i}_EXAMPLESDIR}/c++
-.for f in ${EXAMPLES}
- ${INSTALL_DATA} ${${i}_WRKSRC}/test/${f} ${${i}_EXAMPLESDIR}
-.endfor
- ${INSTALL_SCRIPT} ${${i}_WRKSRC}/test/tracemunch ${${i}_EXAMPLESDIR}
-.for f in ${EXAMPLES_CPP}
- ${INSTALL_DATA} ${${i}_WRKSRC}/c++/${f} ${${i}_EXAMPLESDIR}/c++
-.endfor
-.endfor
+. for f in ${EXAMPLES}
+ ${INSTALL_DATA} ${${i}_WRKSRC}/test/${f} ${${i}_EXAMPLESDIR}/
+. endfor
+ ${INSTALL_SCRIPT} ${${i}_WRKSRC}/test/tracemunch ${${i}_EXAMPLESDIR}/
+. for f in ${EXAMPLES_CPP}
+ ${INSTALL_DATA} ${${i}_WRKSRC}/c++/${f} ${${i}_EXAMPLESDIR}/c++/
+. endfor
+. endfor
+.endif
.if !defined(WITHOUT_TERMINFO)
${FIND} ${PREFIX}/share/misc -name "*.terminfo" -print0 | \
@@ -160,7 +166,7 @@ post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
. for f in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
. endfor
.endif