aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ocaml-cfg
diff options
context:
space:
mode:
authoraraujo <araujo@FreeBSD.org>2012-12-20 13:45:04 +0800
committeraraujo <araujo@FreeBSD.org>2012-12-20 13:45:04 +0800
commit0550414dbabde30b8d0a52b3a383261df04fef70 (patch)
tree7a78e6708c74fccb3a27b59021b0a0862be225d2 /devel/ocaml-cfg
parent204b88f19c073f59351e40c5ffabe0cdf702472d (diff)
downloadfreebsd-ports-gnome-0550414dbabde30b8d0a52b3a383261df04fef70.tar.gz
freebsd-ports-gnome-0550414dbabde30b8d0a52b3a383261df04fef70.tar.zst
freebsd-ports-gnome-0550414dbabde30b8d0a52b3a383261df04fef70.zip
- Update to 2.0.1
- Add LICENSE. - Trim header. PR: ports/172225 Submitted by: KATO Tsuguru <tkato432@yahoo.com>
Diffstat (limited to 'devel/ocaml-cfg')
-rw-r--r--devel/ocaml-cfg/Makefile67
-rw-r--r--devel/ocaml-cfg/distinfo4
-rw-r--r--devel/ocaml-cfg/pkg-descr2
3 files changed, 35 insertions, 38 deletions
diff --git a/devel/ocaml-cfg/Makefile b/devel/ocaml-cfg/Makefile
index d35c411833e9..1ef08bb77ca3 100644
--- a/devel/ocaml-cfg/Makefile
+++ b/devel/ocaml-cfg/Makefile
@@ -2,58 +2,55 @@
# $FreeBSD$
PORTNAME= cfg
-PORTVERSION= 1.7.4
-PORTREVISION= 2
+PORTVERSION= 2.0.1
CATEGORIES= devel
-MASTER_SITES= http://www.ocaml.info/ocaml_sources/
+MASTER_SITES= http://cdn.bitbucket.org/mmottl/cfg/downloads/
PKGNAMEPREFIX= ocaml-
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for manipulation of context-free grammars
-DEPRECATED= No more public distfiles
-EXPIRATION_DATE= 2012-11-26
+LICENSE= LGPL21
+
+BUILD_DEPENDS= menhir:${PORTSDIR}/devel/menhir
+
+OPTIONS_DEFINE= DOCS EXAMPLES
-USE_BZIP2= yes
-USE_GMAKE= yes
USE_OCAML= yes
USE_OCAML_FINDLIB=yes
+USE_OCAMLFIND_PLIST=yes
USE_OCAML_WASH= yes
-MAKE_JOBS_UNSAFE= yes
-DOCS= README
-DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --prefix ${PREFIX} --disable-docs --disable-examples
+MAKE_JOBS_UNSAFE=yes
+
+DOCSDIR= ${OCAML_DOCSDIR}/${PORTNAME}
+EXAMPLESDIR= ${OCAML_EXAMPLESDIR}/${PORTNAME}
+
+PORTDOCS= *
+PORTEXAMPLES= *
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-post-extract:
-# For nonstandard prefixes
-.if !exists(${OCAMLFIND_DESTDIR})
- ${MKDIR} ${OCAMLFIND_DESTDIR}
+.if ${PORT_OPTIONS:MDOCS}
+PLIST_DIRSTRY+= ${OCAML_DOCSDIR:S,^${PREFIX}/,,}
+.endif
+
+.if ${PORT_OPTIONS:MEXAMPLES}
+PLIST_DIRSTRY+= ${OCAML_EXAMPLESDIR:S,^${PREFIX}/,,}
.endif
post-install:
- @${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
+.for i in AUTHORS.txt CHANGES.txt README.md
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${DOCSDIR})
+.endfor
+.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
- @${FIND} ${EXAMPLESDIR}/ ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR}/ ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-# XXX: temporary workaround for non-standard PREFIX
- @${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
- >> ${TMPPLIST}
- @${ECHO_CMD} "@unexec rmdir %D/share/examples/ocaml 2>/dev/null||true" \
- >> ${TMPPLIST}
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ocaml-cfg/distinfo b/devel/ocaml-cfg/distinfo
index 985064196cb0..de1247a6b565 100644
--- a/devel/ocaml-cfg/distinfo
+++ b/devel/ocaml-cfg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cfg-1.7.4.tar.bz2) = 380119cc3f110d2b602ad63500f0478a63f4ac9064abf3ea3355094d818ae0c3
-SIZE (cfg-1.7.4.tar.bz2) = 24278
+SHA256 (cfg-2.0.1.tar.gz) = 55ef3d99914891eaeee5db542eb709c59b07720ccc7f67927e04c811f537283f
+SIZE (cfg-2.0.1.tar.gz) = 57253
diff --git a/devel/ocaml-cfg/pkg-descr b/devel/ocaml-cfg/pkg-descr
index 754d83af91f1..7bc61ed2e272 100644
--- a/devel/ocaml-cfg/pkg-descr
+++ b/devel/ocaml-cfg/pkg-descr
@@ -2,4 +2,4 @@ This OCaml-library consists of a set of modules which implement functions
for manipulating context-free grammars (CFGs) in a purely functional way.
Author: Markus Mottl <markus.mottl@gmail.com>
-WWW: http://www.ocaml.info/home/ocaml_sources.html
+WWW: https://bitbucket.org/mmottl/cfg