aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ocaml-pomap
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-08-04 19:41:30 +0800
committergabor <gabor@FreeBSD.org>2007-08-04 19:41:30 +0800
commit1f31ff34b514d77244257a9a94391d3aae8edab0 (patch)
treea676504f8edaca31196a243aa7393f33f26078fa /devel/ocaml-pomap
parentfb4c30cf2c9bc123dc0c05a0e070f2c48e83be57 (diff)
downloadfreebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.tar.gz
freebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.tar.zst
freebsd-ports-gnome-1f31ff34b514d77244257a9a94391d3aae8edab0.zip
- Remove the DESTDIR modifications from individual ports as we have a new,
fully chrooted DESTDIR, which does not need such any more. Sponsored by: Google Summer of Code 2007 Approved by: portmgr (pav)
Diffstat (limited to 'devel/ocaml-pomap')
-rw-r--r--devel/ocaml-pomap/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/devel/ocaml-pomap/Makefile b/devel/ocaml-pomap/Makefile
index 8ba3bd1b51ac..6c759c78f898 100644
--- a/devel/ocaml-pomap/Makefile
+++ b/devel/ocaml-pomap/Makefile
@@ -23,8 +23,8 @@ USE_OCAML_FINDLIB=yes
USE_OCAML_WASH= yes
DOCS= README
-DOCSDIR= ${TARGETDIR}/share/doc/ocaml/${PORTNAME}
-EXAMPLESDIR= ${TARGETDIR}/share/examples/ocaml/${PORTNAME}
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/ocaml/${PORTNAME}
.include <bsd.port.pre.mk>
@@ -36,20 +36,20 @@ post-extract:
post-install:
@${FIND} ${OCAMLFIND_DESTDIR}/${PORTNAME} -type f | \
- ${SED} "s,^${TARGETDIR}/,," >> ${TMPPLIST}
+ ${SED} "s,^${PREFIX}/,," >> ${TMPPLIST}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DOCS:S,^,${WRKSRC}/,} ${DOCSDIR}/
@${MKDIR} ${EXAMPLESDIR}
@(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}/)
@${FIND} ${EXAMPLESDIR}/ ! -type d | \
- ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${EXAMPLESDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
@${FIND} ${DOCSDIR}/ ! -type d | \
- ${SED} 's,^${TARGETDIR}/,,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
@${FIND} ${DOCSDIR}/ -type d | ${SORT} -r | \
- ${SED} 's,^${TARGETDIR}/,@dirrm ,' >> ${TMPPLIST}
+ ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
# XXX: temporary workaround for non-standard PREFIX
@${ECHO_CMD} "@unexec rmdir %D/share/doc/ocaml 2>/dev/null || true" \
>> ${TMPPLIST}