aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ode
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2006-09-02 22:26:29 +0800
committeracm <acm@FreeBSD.org>2006-09-02 22:26:29 +0800
commit8628caa8a1f9817c9d3f4b91f7d35f6aecbc2880 (patch)
tree64918efe554e7805654d4264c17fb8b4a77be82d /devel/ode
parentb22342e754af4cdc683d2b444bf9dcb4ee0eb841 (diff)
downloadfreebsd-ports-gnome-8628caa8a1f9817c9d3f4b91f7d35f6aecbc2880.tar.gz
freebsd-ports-gnome-8628caa8a1f9817c9d3f4b91f7d35f6aecbc2880.tar.zst
freebsd-ports-gnome-8628caa8a1f9817c9d3f4b91f7d35f6aecbc2880.zip
- Fix build on 4.x [1]
- Bump PORTREVISION Reported by: kris [1] Approved by: garga (mentor)
Diffstat (limited to 'devel/ode')
-rw-r--r--devel/ode/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/devel/ode/Makefile b/devel/ode/Makefile
index 2ad6b50c1034..3be1175fdbd9 100644
--- a/devel/ode/Makefile
+++ b/devel/ode/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ode
PORTVERSION= 0.6
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -24,7 +25,7 @@ USE_GL= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --program-prefix=${PREFIX}
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL
CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
LIBS="-L${X11BASE}/lib"
@@ -54,8 +55,10 @@ post-patch:
-e 's|__isnanf||g; s|__isnan||g' -e 's|-lpthread|-pthread|g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^traplib_PROGRAMS / d' ${WRKSRC}/ode/src/Makefile.in
- @${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | xargs -0 ${REINPLACE_CMD} \
+ @${FIND} ${WRKSRC} -type f -name Makefile.in -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
-e '/^DEFAULT_INCLUDES/ s|$$| -I$$(top_builddir)/include|' \
-e '/CFLAGS/ s|-O[12]||'
+ @${FIND} ${WRKSRC} -type f -name "*.h" -print0 | ${XARGS} -0 ${REINPLACE_CMD} \
+ -i "" -e 's|<malloc.h>|<stdlib.h>|g'
.include <bsd.port.post.mk>