aboutsummaryrefslogtreecommitdiffstats
path: root/devel/ossp-ex/Makefile
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2003-02-01 04:21:24 +0800
committeralane <alane@FreeBSD.org>2003-02-01 04:21:24 +0800
commit9be4a5192a97fffba55108544a345071d961ab4c (patch)
treea5cd6b9b82a1f3a1f38b8f3eeb9053e6c3909b97 /devel/ossp-ex/Makefile
parent314ca05c1ce1b074007f21af04dd32b93058c993 (diff)
downloadfreebsd-ports-gnome-9be4a5192a97fffba55108544a345071d961ab4c.tar.gz
freebsd-ports-gnome-9be4a5192a97fffba55108544a345071d961ab4c.tar.zst
freebsd-ports-gnome-9be4a5192a97fffba55108544a345071d961ab4c.zip
OSSP ex is a small ISO-C++ style exception handling library for use in the
ISO-C language. It allows you to use the paradigm of throwing and catching exceptions in order to reduce the amount of error handling code without making your program less robust. By Ralf Engelschall. His s***'s not ****ed up.
Diffstat (limited to 'devel/ossp-ex/Makefile')
-rw-r--r--devel/ossp-ex/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/ossp-ex/Makefile b/devel/ossp-ex/Makefile
new file mode 100644
index 000000000000..3598a3393e1b
--- /dev/null
+++ b/devel/ossp-ex/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8 -*-mode: makefile-*-
+#
+# New ports collection makefile for: ossp-mm
+# Date created: 2003-01-31
+# Whom: Alan Eldridge <alane@geeksrus.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ex
+PORTVERSION= 1.0.2
+PORTREVISION= 0
+PORTEPOCH= 0
+CATEGORIES= devel
+MASTER_SITES= ftp://ftp.ossp.org/pkg/lib/ex/
+PKGNAMEPREFIX= ossp-
+
+MAINTAINER= alane@FreeBSD.org
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+.include "${FILESDIR}/manpages.mk"
+.include <bsd.port.post.mk>
+
+#EOF