aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-Algorithm-ChooseSubsets
diff options
context:
space:
mode:
authorflz <flz@FreeBSD.org>2005-03-11 22:49:35 +0800
committerflz <flz@FreeBSD.org>2005-03-11 22:49:35 +0800
commitfabce2bb72cc6e6579d4efc4af14ce1072a10bd9 (patch)
treef572ab24b3637b2fd26f7e045a6d3fb815b47af3 /devel/p5-Algorithm-ChooseSubsets
parent29cef995de435ed1b27daf38c0538cbdc5c0c44e (diff)
downloadfreebsd-ports-gnome-fabce2bb72cc6e6579d4efc4af14ce1072a10bd9.tar.gz
freebsd-ports-gnome-fabce2bb72cc6e6579d4efc4af14ce1072a10bd9.tar.zst
freebsd-ports-gnome-fabce2bb72cc6e6579d4efc4af14ce1072a10bd9.zip
- Add p5-Algorithm-ChooseSubsets 0.01, Perl algorithm to iterate through subsets of a list.
PR: ports/78422 Submitted by: Lars Eggert <lars.eggert@gmx.net> Approved by: pav (mentor)
Diffstat (limited to 'devel/p5-Algorithm-ChooseSubsets')
-rw-r--r--devel/p5-Algorithm-ChooseSubsets/Makefile28
-rw-r--r--devel/p5-Algorithm-ChooseSubsets/distinfo2
-rw-r--r--devel/p5-Algorithm-ChooseSubsets/pkg-descr12
-rw-r--r--devel/p5-Algorithm-ChooseSubsets/pkg-plist5
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/p5-Algorithm-ChooseSubsets/Makefile b/devel/p5-Algorithm-ChooseSubsets/Makefile
new file mode 100644
index 000000000000..6955aa18a78a
--- /dev/null
+++ b/devel/p5-Algorithm-ChooseSubsets/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Algorithm::ChooseSubsets
+# Date created: 04 Mar 2005
+# Whom: lars.eggert@gmx.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-ChooseSubsets
+PORTVERSION= 0.01
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars.eggert@gmx.net
+COMMENT= Perl algorithm to iterate through subsets of a list
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::ChooseSubsets.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= "Needs perl 5.6.0 or higher, install lang/perl5.6 and try again"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-ChooseSubsets/distinfo b/devel/p5-Algorithm-ChooseSubsets/distinfo
new file mode 100644
index 000000000000..d42529fa255c
--- /dev/null
+++ b/devel/p5-Algorithm-ChooseSubsets/distinfo
@@ -0,0 +1,2 @@
+MD5 (Algorithm-ChooseSubsets-0.01.tar.gz) = cf3f0e764ee048872c1888d5a2898223
+SIZE (Algorithm-ChooseSubsets-0.01.tar.gz) = 2785
diff --git a/devel/p5-Algorithm-ChooseSubsets/pkg-descr b/devel/p5-Algorithm-ChooseSubsets/pkg-descr
new file mode 100644
index 000000000000..c55b830eb83e
--- /dev/null
+++ b/devel/p5-Algorithm-ChooseSubsets/pkg-descr
@@ -0,0 +1,12 @@
+Perl algorithm to iterate through subsets of a list.
+
+"Subsets" in this context refers to lists with elements taken
+from the original list, and in the same order as the elements in the
+original list. After creating the object, subsequent calls to next()
+will return the next such list in lexicographic order (where the alphabet
+is the original list).
+
+WWW: http://search.cpan.org/~bduggan/Algorithm-ChooseSubsets/
+
+- Brian Duggan
+bduggan@matatu.org
diff --git a/devel/p5-Algorithm-ChooseSubsets/pkg-plist b/devel/p5-Algorithm-ChooseSubsets/pkg-plist
new file mode 100644
index 000000000000..3d91514a836b
--- /dev/null
+++ b/devel/p5-Algorithm-ChooseSubsets/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Algorithm/ChooseSubsets.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/ChooseSubsets/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/ChooseSubsets
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true