aboutsummaryrefslogtreecommitdiffstats
path: root/devel/p5-App-CLI
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-12-27 17:26:13 +0800
committertobez <tobez@FreeBSD.org>2005-12-27 17:26:13 +0800
commit5c4551c6230917a276da6713c515fc3d4d0c5b8e (patch)
tree30b640c8f7aca727dd5345e9016978461e96e4b9 /devel/p5-App-CLI
parent3d32498318c34fc3c1822b9654635499769a8255 (diff)
downloadfreebsd-ports-gnome-5c4551c6230917a276da6713c515fc3d4d0c5b8e.tar.gz
freebsd-ports-gnome-5c4551c6230917a276da6713c515fc3d4d0c5b8e.tar.zst
freebsd-ports-gnome-5c4551c6230917a276da6713c515fc3d4d0c5b8e.zip
Add devel/p5-App-CLI 0.03, a dispatcher module for command line
interface programs.
Diffstat (limited to 'devel/p5-App-CLI')
-rw-r--r--devel/p5-App-CLI/Makefile35
-rw-r--r--devel/p5-App-CLI/distinfo3
-rw-r--r--devel/p5-App-CLI/pkg-descr4
-rw-r--r--devel/p5-App-CLI/pkg-plist9
4 files changed, 51 insertions, 0 deletions
diff --git a/devel/p5-App-CLI/Makefile b/devel/p5-App-CLI/Makefile
new file mode 100644
index 000000000000..155c2e8b2352
--- /dev/null
+++ b/devel/p5-App-CLI/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: devel/p5-App-CLI
+# Date created: 27 Dec 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-CLI
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= App
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= App::CLI - Dispatcher module for command line interface programs
+
+BUILD_DEPENDS= \
+ p5-Locale-Maketext-Simple>0:${PORTSDIR}/devel/p5-Locale-Maketext-Simple \
+ p5-Pod-Simple>0:${PORTSDIR}/textproc/p5-Pod-Simple \
+ p5-Getopt-Long>=2.34:${PORTSDIR}/devel/p5-Getopt-Long
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= App::CLI.3 \
+ App::CLI::Command.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-App-CLI/distinfo b/devel/p5-App-CLI/distinfo
new file mode 100644
index 000000000000..78aec648ac3e
--- /dev/null
+++ b/devel/p5-App-CLI/distinfo
@@ -0,0 +1,3 @@
+MD5 (App-CLI-0.03.tar.gz) = c00c5a6a89d541a50a1fd95fb62a95d5
+SHA256 (App-CLI-0.03.tar.gz) = ed419dbeb7baeb80e587510ba29f442f8a4309a58808ad2e532ce03bdb694f56
+SIZE (App-CLI-0.03.tar.gz) = 24616
diff --git a/devel/p5-App-CLI/pkg-descr b/devel/p5-App-CLI/pkg-descr
new file mode 100644
index 000000000000..af2704e3f5b7
--- /dev/null
+++ b/devel/p5-App-CLI/pkg-descr
@@ -0,0 +1,4 @@
+App::CLI dispatches CLI (command line interface) based commands into
+command classes. It also supports subcommand and per-command options.
+
+WWW: http://search.cpan.org/dist/App-CLI/
diff --git a/devel/p5-App-CLI/pkg-plist b/devel/p5-App-CLI/pkg-plist
new file mode 100644
index 000000000000..d4429eaac902
--- /dev/null
+++ b/devel/p5-App-CLI/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/CLI/.packlist
+%%SITE_PERL%%/App/CLI.pm
+%%SITE_PERL%%/App/CLI/Command.pm
+%%SITE_PERL%%/App/CLI/Command/Help.pm
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/CLI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/App 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/App/CLI/Command 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/App/CLI 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/App 2>/dev/null || true